LSdrafting

3-d perspective views

Recommended Posts

After upgrading to X8, I have noticed the 3-D views are becoming distorted, is anyone else having a problem with this?  This is one of the best features of this program and my clients love that I can show these but ever since I upgraded they don't look the same as before.

Share this post


Link to post
Share on other sites

Upgraded yesterday, opened all current projects ( 6 ) and no issues. 3d looks great but I'm still lurking around looking for gremlins. lol

Share this post


Link to post
Share on other sites

The blurry views are intended to speed up the program, when you print, it will print at a higher resolution.

Share this post


Link to post
Share on other sites

The camera behavior changed with X8 and there's a new feature, something like rotate about object (?) that maybe is set up in a way that's distorting the view? I would look for that new feature and see what changing it does for your views.

Share this post


Link to post
Share on other sites

yes, that is the problem I am having, Dackman. the view looks great but when I rotate it to get the right angle that I want that is when it starts to become distorted and then if you scroll in to get closer it then distorts it even more. The rotation of the perspective view is different.

Share this post


Link to post
Share on other sites

Check how you set the focal point.

Are you using "Center Camera on Point" or "Focus on Object"?

Those two things make a difference in how zoom in/out with the mouse reacts.

Share this post


Link to post
Share on other sites

Joseph, I just tried those two things. I don't see any difference. The distortion is still there.

Share this post


Link to post
Share on other sites

Can you post some pics?  maybe even a plan with a perspective camera view?

Share this post


Link to post
Share on other sites

I think it's camera 'location'. There are a couple of hot keys that will move the camera in and out but can't remember them. Try moving the camera 'out' and see what happens. Or even the cursor keys, try moving the camera away and see if that helps.

Share this post


Link to post
Share on other sites

3D>Camera View Options...check Perspective Crop Mode.  This should behave like what you're used to.  There were some changes made to X8 to allow for better 3D navigation.  By default now the camera actually moves when you zoom in (Perspective Crop Mode unchecked or toggled off).  What it used to do was actually zoom the camera without moving it (Perspective Crop Mode checked or toggled on).

  • Upvote 1

Share this post


Link to post
Share on other sites

That worked! Thank you Michael!

selecting "perspective crop mode" prevents the camera from "moving"

Share this post


Link to post
Share on other sites

I have recently upgrade to version 8 and also do not like the new camera changes. I love the way they worked in version 7. If some of you would please guide me how to restore the version 7 functionality as the default I would certainly appreciate it. I have searched the help files and the menus they recommend but do not see a way to set the "crop" feature as a default. It appears that it has to be done for every camera individually. Is that right? I don't like them "moving" on me every time I zoom or pan; it is driving me crazy -- and I don't have very far to go! :wacko:

 

Thanks in advance, Mike

Share this post


Link to post
Share on other sites

Mike,

 

Open a blank plan, toggle Crop Mode on, and then File>Templates>Save As Template...select your Profile Plan. 

 

Or, make the change, Save As and select your Profile Plan. 

 

Or, simply open your Profile Plan, make the change, and then Save and close. 

 

NOTE:  If you're using a plan other than the Profile Plan as your template, make the changes to that plan file instead.

Share this post


Link to post
Share on other sites

Michael, don't you still have to do this individually for each camera in the plan? I don't see a way to do this for all cameras at once or before new ones are created - as in a default.

 

Mike

Share this post


Link to post
Share on other sites

Michael, don't you still have to do this individually for each camera in the plan? I don't see a way to do this for all cameras at once or before new ones are created - as in a default.

 

Mike

 

You're right.  I guess I wasn't thinking about that being a view specific setting.  I guess your best bet might just be to get used to hitting P (the default hotkey assigned to the Perspective Crop Mode) or add the tool to your toolbar for quick access, or both. 

 

You might want to actually post this as a suggestion.  I think it would be a good one.  I personally like Perspective Crop Mode toggled off, but I think it should be in Preferences or Defaults somewhere for those that want it on. 

Share this post


Link to post
Share on other sites

You're right.  I guess I wasn't thinking about that being a view specific setting.  I guess your best bet might just be to get used to hitting P (the default hotkey assigned to the Perspective Crop Mode) or add the tool to your toolbar for quick access, or both. 

Thanks, Michael - that's just what I do. But, to me, there should be a way to set it as a default. I am sure the CA programmers thought changing the camera operation was a great idea. And maybe it was for some. But, from the sound of it here on the forum, many just don't agree and like the "old" way better. Upgrades - you gotta' love 'um.

 

Mike

Share this post


Link to post
Share on other sites

For anyone reading this topic, I went to the Suggestions section (thanks Michael) and put in as a request the ability to have a toggle for the "perspective crop" feature in X8. This essentially changes those cameras to act like X7. If you would like this feature, please go to that section and add your 2-cents.

 

Thanks, Mike

Share this post


Link to post
Share on other sites

If you use saved cameras in you default floor plan, you can toggle this setting on for each camera and then save the template plan.

This is a per camera setting, so it will stick to the saved cameras in the template plan.

 

Because it is a per camera setting, it will stick with any saved camera in your plan.

 

But, yes, I agree, this should be a default setting.

Share this post


Link to post
Share on other sites

Adjust the Field of View setting.  Version X8 had a default setting of 60 degrees and makes everything look stretched out.  I usually view everything with it set at 40 - 45 degrees.  Double click on the Full Camera icon and you should be able to set the camera defaults.

  • Upvote 2

Share this post


Link to post
Share on other sites

Designsyko; thanks! That fixed the stretching problem for me. No more distorted views. Much obliged to you, sir.  :)

Share this post


Link to post
Share on other sites

As I learned, make sure you are tapping the "P" key while you are looking at the camera view on screen -  and before you move the view; no zoom, panning, etc. I originally thought I could do in plan view - wrong.

 

Mike

Share this post


Link to post
Share on other sites

Mike, what does tapping the "P" key do? I know Alt + P is Pan mode but not familiar with what you're describing.

Share this post


Link to post
Share on other sites

It's the default hot-key for the Perspective Crop mode for that camera - and that camera only. You will have to type it for every perspective camera you open if you want similar movement to X7; and the camera has to be open and you are in that camera view on your monitor - from my understanding.

 

Mike

Share this post


Link to post
Share on other sites

I use 55 degrees and shortened the "clip surfaces within" down to 2"-no problems, better than it used to be.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27485
    Total Members
    6254
    Most Online
    ricatic
    Newest Member
    ricatic
    Joined