mtldesigns

Lights not always showing "on" but are

Recommended Posts

I've noticed this a lot lately, on my last half dozen plans or so, and been meaning to ask...  But it seams like when I have a light "on" (with the "glow" showing) and I either adjust material, or turn another light on or off.. the glow disappears on the remaining "on" lights.  By no means a show stopper and RT still works showing the lights on.. but I like the idea of seeing which lights are on in advance.  The attached shows the same light and they both are on in the the 3D view.   Setting??  Bug??  

 

Thanks in advance.

SOMETIMES DOESNT SHOW ON.PNG

SOMETIMES IT DOES SHOW ON.PNG

Share this post


Link to post
Share on other sites

Interesting...  I did not know this.  Is there a way to change that standard setting?  I mean, it seams most kitchens have more than that now with the cans, under-cabinets and pendants.  Not a big deal like I originally said.. just mentally like seeing the glow.  

Share this post


Link to post
Share on other sites

I think something else is going on here TKA.  I am placing light fixtures in this new model, now that the room layouts are good.  I only had four of the can lights in, no other electrical.  I did turn off all but one, and still wont show the "glow".  And my vid card should be more than adequate.  My other models, where as I have tons of lights, I do turn off all rooms I am not RT, and some rooms like a family/game room I just did had 12 cans, 3 pendants..  when this would happen, I would turn one light off, then back on and they all would glow.. all 15 lights. But really, its all good, because it turns out on RT, just missed the convenience.  Thanks for replying and getting my wheels turning.     

Share this post


Link to post
Share on other sites

Some lights have Auto intensity Options IIRC and auto attenuate?  , but you are right it is weird sometimes a rebuild of a 3D view for some other reason suddenly has all the lights Off or On .... sometimes closing a view and redoing the Camera I finds turns them back on .

 

You can always turn on the Light Indicator for Camera Views so you at least know which ones may effect RT's.

 

M.

Share this post


Link to post
Share on other sites
10 hours ago, mtldesigns said:

I think something else is going on here TKA.  I am placing light fixtures in this new model, now that the room layouts are good.  I only had four of the can lights in, no other electrical.  I did turn off all but one, and still wont show the "glow".  And my vid card should be more than adequate.  My other models, where as I have tons of lights, I do turn off all rooms I am not RT, and some rooms like a family/game room I just did had 12 cans, 3 pendants..  when this would happen, I would turn one light off, then back on and they all would glow.. all 15 lights. But really, its all good, because it turns out on RT, just missed the convenience.  Thanks for replying and getting my wheels turning.     

 

That lens glow effect just makes it look like the light is active(on) when it is not. That is not related to the video card 8 light limit which is about the actual light being emitted by the fixture. I believe I have encountered what you are experiencing before, which seems to be related to rebuilding the 3D model when one makes a change.

Share this post


Link to post
Share on other sites

I have the same annoying behavior.
Lights are on;  As soon as I change a material for one of the objects in the room, lights are off again.
Rebuilding the camera (sometimes) fixes the problem. Sometimes changing the material of an object puts the lights back on.

 

bottom line, something is very buggy with this behavior.

Share this post


Link to post
Share on other sites

MOST video cards will only show 8 lights on at a time.

Chief uses the 8 closest to the camera.

if the camera is outside a room lights in that room won't show UNLESS you start the camera shot in the room

and then back out of it.  If you then adjust something in that room that the camera is no longer chief will

sense that the camera is out of the room and the lights will go off again.

The above applies to standard render camera shots.

Ray Trace not affected.

Share this post


Link to post
Share on other sites

Greg- they LOOK on but I see no effects on the floor or the room.

Not playing a trick with high emissive glass are you??

Share this post


Link to post
Share on other sites
8 minutes ago, Electromen said:

My new Mac Pro shows them all in full camera view.

 

test2.jpg

 

Very interesting, when in this view open up the adjust light dbx and check the list of lights, it will say whether or not the light is actually being used in the view. I think you will find that only 8 will be identified as actually being on. The others only look on due to effects such as bloom.

Share this post


Link to post
Share on other sites

Another way to see exactly which lights are "on" is in the light fixture DBX under Light Data check the show position box. A cross hair with a directional arrow will show in the view, this only shows if the light is considered "On".

Share this post


Link to post
Share on other sites

the "Standard" render camera tool has been limited to 8 active light sources since that feature was added in Version 7 (2000 AD). But Ray Trace views have no such limitation and will show light sources no matter how many there are.

 

DJP

Share this post


Link to post
Share on other sites
1 hour ago, Electromen said:

Here's a current project I'm working on.  I added some recessed to show more than eight lights.

This is the standard Full Camera View, not a Ray Trace.  

test3.jpg

 

If you turn on the cross hairs as Graham suggested for each light you will see which ones CA is actually using , not just making them look like they are on in Render views.....

 

here is a quick room with 49 recessed cans added and as you can see only 8 are being used for light data ..... you can see that side of the room is slightly "brighter" in the pic....

 

 

Capture12.JPG

Capture13.JPG

Share this post


Link to post
Share on other sites
9 minutes ago, Kbird1 said:

 

If you turn on the cross hairs as Graham suggested for each light you will see which ones CA is actually using , not just making them look like they are on in Render views.....

 

here is a quick room with 49 recessed cans added and as you can see only 8 are being used for light data ..... you can see that side of the room is slightly "brighter" in the pic....

 

 

Capture12.JPG

Capture13.JPG

Can you explain it to me better,  I couldn't get any arrows

Share this post


Link to post
Share on other sites

From my testing, all lights defined as On will show a glow looking at the fixture, regardless of their number.  But if you look for the light emitted on surrounding objects, as TKA mentioned, only a maximum of 8 will show.

Share this post


Link to post
Share on other sites

Give your lights a different colors such as red, yellow and then run a vector or a technical view this will show you what lights are on ... another way to see how your light spreads in your scene .

Share this post


Link to post
Share on other sites
1 hour ago, Electromen said:

Can you explain it to me better,  I couldn't get any arrows

 

You need to check the "show position in camera views" box for the fixture like this.....

 

M.

 

 

Capture15.JPG

Share this post


Link to post
Share on other sites
2 hours ago, Kbird1 said:

 

You need to check the "show position in camera views" box for the fixture like this.....

 

M.

 

 

Capture15.JPG

When I do that only Eight are ON.  Your are correct.

Share this post


Link to post
Share on other sites

AFAIK it is a limitation of most VideoCards , which can be noted on the Preferences>Render>VideoCard status Tab.

 

M.

 

 

Share this post


Link to post
Share on other sites

Here is a grab of those preferences, and even with the vid card I have, it does say 8 is the max.  Just curious though, why was 8 the max number, esp with the vid cards getting so much more advance. I know my Alien should be able to handle more.  Again, just curious.  

 

And I want to make sure I understand everyone.. the 8 is for a camera view, BUT not a ray trace correct?  In a camera view, I might have 20 with the glow, but only 8 are really on.   

 

Still wish, even though all but 8 lights are really not on, that the glow doesn't keep turning off when changing the material of an object or turning another light on or off.  Opening new cameras, or changing a material just to get that glow again is a little bit of a nuisance.   

 

Preference max lights status.PNG

Share this post


Link to post
Share on other sites
9 minutes ago, mtldesigns said:

Here is a grab of those preferences, and even with the vid card I have, it does say 8 is the max.  Just curious though, why was 8 the max number, esp with the vid cards getting so much more advance. I know my Alien should be able to handle more.  Again, just curious. 

 

It is interesting that all video cards seem to have the same limit.  It just does not make sense. GTX 1080 should do more.

 

Graham  seems to be quite sure of his facts but I am not convinced.

 

 

Share this post


Link to post
Share on other sites

I remember in the past seeing a card that supported 16 lights.  That was at least 2 years ago if not longer.

Forget which card it was.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27855
    Total Members
    6254
    Most Online
    kfilipova
    Newest Member
    kfilipova
    Joined