Transform Replicate "relative To Current Point" Not Working In Elevation View


VisualDandD
 Share

Go to solution Solved by Joe_Carrick,

Recommended Posts

Hi all.  I recently upgraded from x4 to 6.   When detailing elevations with soldiers over arched windows, I use a cad block that I made with a brick and grout.

 

I would set use transform replicate, and place a point at the arc center of the window.  Then guessing at how many copies I needed, and the angle I would get a nice soldier course.

 

My problem is in X6 I cant get transform replicate to work "about current point" in Elevation view only.   It works fine on floor plan view.

On elevation I can change the "edit behaviors" to rotate about current point.  (grabbing the little triangle rotates just fine around any point I set)

 

Am I missing something easy?   I spent a while playing with all the settings and could not see anything.

 

I even made a new plan with just 4 walls and tested....same result.   Went back to X4 and it works just fine...

 

Thanks!!!

 

Justin

Link to comment
Share on other sites

OK....in X6 I could not make transform replicate work about current point even in floor plan.   The multiple copy tool works fine though.

 

My problem is again, when I switch to elevation, multiple copy will not work work even when setting behavior to rotate/resize about current point.   I can drag it around fine about a point, but no multiple copy....

Link to comment
Share on other sites

In an elevation, the X, Y, and Z axes stay the same as the plan view. So it's possible that when you think you are transforming left to right (you may be assuming an X-direction), you are actually transforming in/out (y-direction in plan) without realizing it. (also, trying to transforming up/down in an elevation is actually moving in the z-axis) This is very confusing behavior, and I wish that Chief would fix it. Or at least give a visual cue as to the actual axes. 

Link to comment
Share on other sites

I dont think that is it.  On X6, in transform replicate, "relative to current point' radio button is "grey'd" out.  (you cant select it).  Actually you want to rotate/resize around point...but that is grey too.

 

I took a few screen caps.   First is X6.   

 

Second pic is X4 and how I used transform replicate to make an array copy of the soldier.  (I did the operation first and then re-opened and put in the settings I used so it would be easy to understand)

 

 

X90Bhiu.png

 

X4oVAVv.png

Link to comment
Share on other sites

Justin,

 

I think you are using the wrong options.

You don't want to Move the object, you want to Copy and Rotate it.

You then use the Rotate/Resize/Reflect About section down at the bottom.

Make sure you have a Current Point in the elevation or About Current Point will be greyed out. 

The drawing shows the result as set in the dbx.

post-106-0-40929200-1421477594_thumb.jpg

Link to comment
Share on other sites

Justin,

 

I think you are using the wrong options.

You don't want to Move the object, you want to Copy and Rotate it.

You then use the Rotate/Resize/Reflect About section down at the bottom.

Make sure you have a Current Point in the elevation or About Current Point will be greyed out. 

The drawing shows the result as set in the dbx.

 

 

Uncheck the move box.  Then use Rotate about point.

 

I corrected myself above.   Yes, it is not the move function.  BUT......

 

That works fine with CAD objects.   As soon as you convert to a polyline solid, the option to 'rotate around CURRENT point' goes away.  Works fine in X4....just not working in X6

 

 

What is weird, is rotate about absolute point still works.   So you can either draw in CAD and then rotate/copy>>>>then convert to polyline solid.   Or....I drew in CAD and opened the DBX with "about current point" checked (made note of exact point. (you can also get that info by just opening "input point" and it will give you current point position))>>>>>>then use the rotate/copy "about absolute point" and manually enter the coordinates in.

 

Am I missing anything.   I cant seem to get the selection "about current point" to work on objects whereas it works in X4?  

 

I was pulling my hair out last night on this one....but cant seem to figure out why this function is not working after updating?

Link to comment
Share on other sites

Just a small bump.  Wondering if this is correct and you can no longer rotate objects about current point in elevation view?   Again, I can get cad to work, but as soon as it becomes something like a polyline solid, the option goes away.

Confused as this worked fine in X4.

Thanks!

Link to comment
Share on other sites

If you want to rotate a Poly Solid in elevation view, use the Edit...Edit Behaviors... Rotate/Resize About Current Point and set your Angle Snaps to the rotate angle.   

I know I can do that.  (sorry if I did not make that clear earlier).  

 

My problem is I can not perform the function of:

 

-an array copy rotating about CURRENT point (using transform replicate)  see above posts.

-of a polyline solid

-in elevation view.

-works in CAD in elevation.....just not once you make it a solid.

 

Able to do in X4 and previous versions.  (recently upgraded)

Thanks!

 

Link to comment
Share on other sites

I can confirm it doesn't work in X6 elevation views for anything except CAD objects.  I do not know if it worked in X4 or not since I don't have that loaded on my system.

Thank you.   At least I am not going crazy.

 

I can confirm it works on X4.   I used it all the time.   The weird thing is you can rotate a poly line solid around a 'absolute point' just fine.   You just have to go though the extra steps to do it.  (Hit the input point button and it will give you current points exact coordinates.....you then have to enter them in manually).   

Hard to believe I am the first to notice this......   How would others manually model a arched soldier over a window?

 

Attached is the project I was working on where I ran into the issue.   I finally figured out to draw the bricks in CAD first and group select and then convert to polyline solid.   Much more work then using the pre-made ones I used to save to library and just transform/replicate......

 

gGOerjz.jpg

Link to comment
Share on other sites

Wait until next Tuesday (1-20-2015).  It's fixed in X7.  ;)

Thanks Joe!

 

Been away from forums for a while.    I will be hanging out much more often.  Taking time to really optimize and learn some new things as I am getting busier.

Thank you again!!!

Justin

Link to comment
Share on other sites

  • 6 years later...
  • 6 months later...

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

  • Member Statistics

    31608
    Total Members
    9156
    Most Online
    FireflyHomes
    Newest Member
    FireflyHomes
    Joined