johnny

Line style

Recommended Posts

I wanted to have a single line representing my deck area (existing) - so I turned one of the lines off (set to none) in the wall Dbx (as shown).  However, my deck outline still shows 2 lines...??  Is this a bug perhaps?

 

 

post-75-0-67567400-1440527345_thumb.png

Share this post


Link to post
Share on other sites

I wanted to have a single line representing my deck area (existing) - so I turned one of the lines off (set to none) in the wall Dbx (as shown).  However, my deck outline still shows 2 lines...??  Is this a bug perhaps?

That is not a bug.  That is how wide your railing is. Open wall dvx and check it out.

 

Now,  how do I handle it?  I rarely get the railing I want in CA,  so I build my railings out of MOLDINGS.   So with the wall that defines the deck,  I make is 1/16" thick  (double line),  I then put that rail wall on a separate layer and I can then use that layer to show my deck in site  plan,  floor plan etc.....   it seems I get more control and the line of deck shows as a single line since it is so narrow.

Share this post


Link to post
Share on other sites

Thanks Scott - I will do the 1/16" trick then.  Though there is an option for "no rail" so shouldn't that turn off the rail?  I dont claim to be a literary guru but one would get the idea that option would turn the rail off - and yet nothing happens.

 

Again, thanks for the work-around on this.

post-75-0-94682800-1440530165_thumb.png

Share this post


Link to post
Share on other sites

Thanks Scott - I will do the 1/16" trick then.  Though there is an option for "no rail" so shouldn't that turn off the rail?  I dont claim to be a literary guru but one would get the idea that option would turn the rail off - and yet nothing happens.

 

Again, thanks for the work-around on this.

I am glad you called me on this.  I would make it an INVISIBLE SHOWER WALL,  by using a shower wall you can make it 1/16" thick,  now make sure you put it on its own layer,  change line weights and line styles via layer depending on how you want to show it in plan....  whether for a site plan or a floor plan or a framing plan etc.  

 

So,  invisible wall,  1/16" thick,  on it's own layer,  does not matter if it is a railing or a wall,  define the room it defines as a deck if you want decking.

 

What I just described is a "work around",  but it works for me because I know most of the ins and outs of CA which gives me a lot of flexibility to display in a manner that you are now seeking.

Share this post


Link to post
Share on other sites

I am glad you called me on this.  I would make it an INVISIBLE SHOWER WALL,  by using a shower wall you can make it 1/16" thick,  now make sure you put it on its own layer,  change line weights and line styles via layer depending on how you want to show it in plan....  whether for a site plan or a floor plan or a framing plan etc.  

 

So,  invisible wall,  1/16" thick,  on it's own layer,  does not matter if it is a railing or a wall,  define the room it defines as a deck if you want decking.

 

What I just described is a "work around",  but it works for me because I know most of the ins and outs of CA which gives me a lot of flexibility to display in a manner that you are now seeking.

 

Sorry I wasn't trying to call you out on that - but pointing out someone would get the idea the "no rail" option would work.  Thanks Scott for all your time and help.

 

TO ANYONE:

Just cause I dont want to create another thread - one issue I am not having is trying to "close" some terrain that exists under a floor structure on a remodel project where it is supported by beam/posts.  The terrain is cutting itself - which typ would be fine, but in this case I want it to show.  Should I just do a poly/terrain feature or something in that area, or is there an actual way to control the terrain for this area?

post-75-0-93160700-1440531467_thumb.png

Share this post


Link to post
Share on other sites

Adding to my last post - I guess a terrain feature doesn't work since it gets clipped too.  Man its things like this that just ruin my work-flow.  I realize once I get it I will get it, but it kills my scheduling having to work through these issues. (mini-rant over)

Share this post


Link to post
Share on other sites

Johnny,

 

Post the Plan.  I can only guess at what the problem is,  Probably something to do with the Structure Definition of the Rooms but that as I said is just a guess.

Share this post


Link to post
Share on other sites

There is already a wall in the deck section called "Straight deck edge" you can use and get 1 line.

Share this post


Link to post
Share on other sites

There is already a wall in the deck section called "Straight deck edge" you can use and get 1 line.

 

Oddly, I dont seem to have that wall type in my defaults.....

Share this post


Link to post
Share on other sites

It's in the pull down railing wall section or the build/ railing& deck section.

Share this post


Link to post
Share on other sites

Johnny,

 I could get terrain to build open hole area if any of the 4 walls above it were made invisible. I know this isn't a fix but it heads you down a path of MAYBE GETTING IT RIGHT or just do a quick poly solid as you suggested. I don't have anymore time to find fault in walls above that would cause this. I tried different wall types and it stays open, but invisible walls allow terrain build.

Share this post


Link to post
Share on other sites

Railing &deck tools icon, straight deck edge child tool.

In my metric version the default wall/ railing is 100mm invisible deck railing/fence wall.

This type of wall, once it encloses a space, predetermines the type of room ie a deck with all its associated default framing.

To get a single edge for the room/ deck area, right click inside the space and choose make room poly line. Then turn off the layer that your walls/rails are on if you don't want to see them.

Share this post


Link to post
Share on other sites

Thanks guys....  I was able to use a 3d poly and fixed the issue.  However, I find myself in yet another odd issue.  I have my terrain set to "hide terrain intersected by building", but its not doing that.  So essentially its hidding terrain I want visible and making  visible terrain i want hidden.  My frustration level is rising quick, but I do appreciate (again) all the help.  I couldn't use this app without this help.

 

 

 

 

post-75-0-94894100-1440541269_thumb.png

post-75-0-98225100-1440541278_thumb.png

ashok_mallya_residence_b.plan

Share this post


Link to post
Share on other sites

Looks like you've lost room definition. click in the affected area to see if you have a room, if not check you wall connections.

Share this post


Link to post
Share on other sites

When I see terrain hole problems it's usually room definition problems.

 

The best solution for these is to uncheck hide terrain.

 

Then select the exterior room and create a polyline.

 

Change the poly line to a terrain feature then open it up and click make hole.

 

Now you have ultimate control.

Share this post


Link to post
Share on other sites

So I know, if I can select a room and label it automatically that would mean there is a positive definition - correct?  Otherwise, what is "room definition problem"?

 

Here is a selection of the space.  Now, the space is a basement space but I placed a slab floor in there - does that mater?

 

 

post-75-0-73271700-1440556762_thumb.png

Share this post


Link to post
Share on other sites

Jonny,

 

You are correct, you have room definition.

 

I took another look at the plan this morning. The rooms on the first floor control the way the hole is cut based on the exterior room, and room types. Certain room types should not cut terrain, like balconies.

 

If you make the first floor room that is open underneath a balcony it should not cut the terrain below.

 

However, we are seeing the terrain going inside the building where it should not and I can't find a specific problem with the plan that is causing this.

 

I get inconsistent results depending on the changes I make sometimes I can get it to work and sometimes it won't.

 

I also found that sometimes rebuilding the terrain even though it said it did not need rebuilding caused a change to the way the hole is cut. Something is not adding up for me.

 

Can you open a support incident on this? I would like the support team to take a look at the plan and see if we can track down the problem and file the appropriate reports.

 

https://support.chiefarchitect.com/home

 

Thanks,

Share this post


Link to post
Share on other sites

........

I also found that sometimes rebuilding the terrain even though it said it did not need rebuilding caused a change to the way the hole is cut. Something is not adding up for me.........

 

I see this all the time,  it says the terrain is up to date,  but it is not,  because when I say rebuild,  it does update the terrain.  

Share this post


Link to post
Share on other sites

Out of curiosity I cut the terrain from the first floor, created a new terrain perimeter on floor 0 and used paste hold position to paste the terrain on floor 0.

 

I then unchecked the automatic option for the terrain perimeter and set the value to 0.

 

Things worked much better after that. I'm not sure if I got all the features back where you want them but maybe that will help.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27469
    Total Members
    6254
    Most Online
    THDesign
    Newest Member
    THDesign
    Joined