angelaleigh

Camera room clipping

Recommended Posts

Not aware of any setting that allows you to lock a cameras position. Believe this has been requested in the past and would be a great feature.

 

Graham

Share this post


Link to post
Share on other sites

There's a checkbox in the Defaults>Camera>3D Views for "Restrict Floor Camera to Room" - but I don't think it works.

Share this post


Link to post
Share on other sites

Previous versions did not walk through the walls, and you could fish eye the view as much as possible. Correct- "Restrict Floor Camera to Room" does not work. 

Share this post


Link to post
Share on other sites

There's a checkbox in the Defaults>Camera>3D Views for "Restrict Floor Camera to Room" - but I don't think it works.

 

 

You are correct, it no longer works,  it did at one time......  somehow CA needs to work on this......  before X8 I had no problem staying in a room,  but now,  if I zoom out,  I end up  in Wasilla Alaska staring down the nose of the Alaskan Son....  eeeew....

  • Upvote 1

Share this post


Link to post
Share on other sites

Re the Restrict Floor Camera To Room setting.

 

Are you sure it's broken, or you just don't understand how the setting works?

I don't think that it is meant to lock a cameral in a room.

What it does is not display objects outside the room the camera was drawn in, when you move the camera outside that room.

 

In the attached pic, a Floor Camera was drawn inside the room and then backed out of that room.

Notice that the cabinets, roofs, terrain, etc.,  drawn outside the room do not display in the camera view.

The only things that will display in the camera view are items drawn inside the room, even though the camera was initially drawn inside the room and then backed out of the room.

 

Note that this setting only applies to the Floor Camera.

 

Are you confusing this setting with the Camera Bumps Off Walls setting?

post-106-0-80205600-1478560761_thumb.jpg

Share this post


Link to post
Share on other sites

I think I may be confusing it with camera bumps off wall.

Share this post


Link to post
Share on other sites

I think I may be confusing it with camera bumps off wall.

 

As you noted, this setting doesn't appear to work.

Share this post


Link to post
Share on other sites

I think its possible the setting you guys are after is Perspective Crop Mode (P) found under 3D>Camera View Options.  This will stop the camera from traveling through walls.

Share this post


Link to post
Share on other sites

As far as I can tell, both "Restrict Floor Camera to Room" and "Camera Bumps Off Walls" work the same in X8 as they did in prior versions of the program. 

 

"Restrict Floor Camera to Room" does not affect any camera movements and it never did.  It controls whether or not any 3D data outside of the room is generated for the camera view.  See Glenn's post above for some more info.

 

"Camera Bumps Off Walls" only controls camera movements when using some of the camera tools.  If you move the camera forward or use the camera "dolly" tools, the camera will detect walls and bounce off of them.  It does not affect other camera movement tools such as "orbit" or "pan".

 

As far as the original poster's issue, I suspect that this is related to the changes made to zooming in X8.  As Michael pointed out above, you can change to "Perspective Crop Mode" to more closely match how zooming worked in earlier versions.

Share this post


Link to post
Share on other sites

"Camera Bumps Off Walls" doesn't work, period. It doesn't work with Dolly, Pan, or Orbit.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27478
    Total Members
    6254
    Most Online
    Oilersfan20
    Newest Member
    Oilersfan20
    Joined