HaywardVT

How Do I Align Objects With Grid?

Recommended Posts

The objects of my plan are offset from the grid snaps grid by a number I can't determine. Is there a way to realign the grid? Maybe choose a point where an intersection should be? Or have it so my mouse snaps to the grid? I don't know why it's designed like this, but grid snaps doesn't snap to the grid, it snaps to the intervals of the distance the grid snap is set to from the original selection point, making the grid itself useless.

 

For example: If an object is offset from the grid (I use 1/4") by 0.0833972978", I can't just click and drag the object and snap it to the grid because I can only move it by increments of 0.25". 

 

post-8426-0-58315400-1449604009_thumb.png

Share this post


Link to post
Share on other sites

I don't think you can align the grid, but you can get everything back "on grid" by turning on Grid Snaps. This should allow you to drag CAD lines, walls, and stuff like that until they snap to the grid spacing.

Share this post


Link to post
Share on other sites

Note that it's generally the "Origin" of Architectural Objects that snaps to the grid, not necessarily an edge.  CAD Lines will snap to the grid.

Share this post


Link to post
Share on other sites

Is it easier to redefine the grid origin? Is that even an option?

Do the pros usually draw with the snap grid on? I never did in autocad but chief seems like it might work better with the grid on for ortho stuff.

Share this post


Link to post
Share on other sites

I have my grid set  to 3" and then I basically ignore it except when it gets in the way.  Then I turn it off.  Like Michael, grid snaps are only valuable to me in cases where I'm doing 2D CAD and that's usually something to do with a Custom Detail or a Layout Page Definition.

Share this post


Link to post
Share on other sites

Sorry for the temporary thread highjack, one more grid related question..

When you guys are doing 2d cad object drafting, do you just rough it out and then use the temporary dims to input precise lengths, or do you use the tab dialog, or some other method?

Share this post


Link to post
Share on other sites

I have my grids set to 1/4" and that covers just about everything.

Share this post


Link to post
Share on other sites

I start every plan by placing a temporary point at the origin, that is, absolute origin 0,0.

The bottom left corner of my exterior facade starts there. Everything lines up after that. Or at least, I don't get the 0.867543218 offset from my grid.

Share this post


Link to post
Share on other sites

To answer the original question: I occasionally get a plan off grid due to autocad import, rotating a plan via edit area, etc.  New plans are automatically on grid if set up correctly, but for those rare times it is off, here is what I do: I draw two intersection cad lines on grid, somewhat close to the corner of two walls (like in your pic), then 'edit area all' and then do a 'point to point' move from the wall intersection, to the cad line intersection.  Should be good to go after that, regardless of what your preferred grid settings are.

 

Hope that helps.

Share this post


Link to post
Share on other sites

I used to use AutoCAD as well and didn't use grid snaps then, but CA snaps aren't as good (even with every object snap option on I can't snap to things I want to) and clicking on an object doesn't always give me the gray dimensions I need to make the changes I want. It's way easier to have grid snaps on so I know the exact distance I move an object without worrying about finding the right dimensions and object snaps, especially with really small values.

 

Ben Palmer, that's a good idea but how do I know the CAD lines I make will be on the grid? That's what I call eyeballing it, and I've done it enough to know that it hardly ever works. It might look like it's where you want it but zoom in enough and you'll see that it isn't. Even if it looks like the CAD line I make is overlapped perfectly onto the grid line, it could be off by a value smaller than the width of a pixel when fully zoomed in. I only trust snaps and dimensions that I know are snapped to the right points.

 

Of course, you're solution would probably work for this situation. The grid can't be snapped to and is only there for visual aid, so if it looks like it's on then it's close enough because the snap distances come from the object and not the grid. 

Share this post


Link to post
Share on other sites

Per your picture, you have the grid, so as long as 'grid snaps' are on (Ctrl + F9), then the new cad lines will draw on grid even though you won't see any snapping visual aids.  If it isn't on grid, then there is a setting wrong, or something that is snapping off the grid forcing the line to move.  Just stay away from anything else for the cad lines to snap to.  The new cad lines don't even have to be close to the corner.  If you want to be sure, upload your plan, and someone can take a look at it.  Beyond that, we can only give you are best guess based on the information provided.  It works perfectly for me every time.  Never had a problem getting things back on grid.  Staying on grid in the first place or how people prefer to use it is a different discussion.

Share this post


Link to post
Share on other sites

Ben Palmer, that's a good idea but how do I know the CAD lines I make will be on the grid? That's what I call eyeballing it, and I've done it enough to know that it hardly ever works. It might look like it's where you want it but zoom in enough and you'll see that it isn't. Even if it looks like the CAD line I make is overlapped perfectly onto the grid line, it could be off by a value smaller than the width of a pixel when fully zoomed in. I only trust snaps and dimensions that I know are snapped to the right points.

 

 

Are you aware of the difference between the reference grid a the snap grid?

The reference grid you can't snap to whilst you can always snap to the snap grid if it is displayed. 

 

Also...when drawing or moving walls...  they will snap to the grid according to the Resize About setting (Alt+Q). 

If this is set to Outer Surface, walls will snap their outer surface to the grid - similarly for any of the other settings. 

 

Cad lines should ALWAYS snap to the grid (if turned on).

Share this post


Link to post
Share on other sites

I wasn't aware CAD lines snapped to the grid, that helps a lot. Also, I guess closing the file and reopening it will reset the grid origin. The plan I took the screenshot from is now on the grid and I didn't change anything.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27825
    Total Members
    6254
    Most Online
    ChiefDallas
    Newest Member
    ChiefDallas
    Joined
  • Similar Content

    • By divreig
      Anyone know how to change label text size? I am working on a large building and the layout scaling is 1/32". The labels are too small and cant be read. I cant find options for text size all the label panel, all it has that box that says use default, that I can check and uncheck. But don't know where to edit this default size or the individual label text size. 


    • By Doug_N
      I am working on a project that requires the plan view of each floor to have a reference grid that intersects at each column.   Is there a easy way to do this where each grid has an alpha callout at the top of the layout view and numeric callout along one or both sides.
       
      Doug Norton
      Whitby Ontario Canada
    • By zizo999
      hello everyone
      i have a question, how to draw grids and circles to assigns a number to it like the picture below  
       
       
       

    • By rikdekker
      Many websites offer 3D resources for designers (see attached example). What would be the best file type to pick for importing 3D objects?
      I have tried various ones but have trouble with the scale and materials.

    • By JonBDesigns
      Hi Everyone!
      I am working on a 90k square foot remodeling project for Veterans' and up until this point I have had zero issues or lag from my hardware or the Chief Software.
       
       I recently imported over 375 3rd party 3D objects in order to accommodated the design requirements of the project. A majority of the objects are 2017 Sketchup (.skp) files from 3D Warehouse. Some of the objects can get very complex--such as entire Coffee shops, large 3d wall panels, large furniture groupings, and complex medical equipment. On some of the more complex and larger ones it took about 20-30 minutes to get the object to load into Chief. 
       
      My file size is currently just over 3 GB and growing --- which is something my system can handle. As of right now it feels like I am using a POS computer, and I am most definitely not ( (see specs below). Just about every operation (in Chief)  is very slow and bogged down--I can still use the rest of my computer fine. 
       
      Have I overloaded the Chief Library / Software? If so, should I purge all unused objects until they are needed in order to improve performance? Is there something else that I can do? 
       
      I truly appreciate your help.
       
      Peace, 
       
      Jon
       
      Ryzen Threadripper 1950x (16 cores)
      64 GB 3200mhz Quad Channel Ram Corsair Dominator
      Nvidia Quadro P4000
      2x 512 GB Samsung 960 Pro M.2 SSD
      256 Samsung 960 Evo M.2 SSD
      2TB Samsung 960 Evo SSD
      Corsair 115i Watercooler
      Corsair HX1000i PSU