How to change rounding behaviors


jbur91
 Share

Go to solution Solved by jbur91,

Recommended Posts

Using Chief X12 and have a question about rounding.

 

Is there a way to make dimensions round to the nearest fraction? Using the manual dimensioning tools, the program is rounding inconsistently. For example, I have my current dimension defaults set to show fractions to the nearest 1/2". However, it won't round to the nearest 1/2", it will only round down. One measurement in particular is 10'-4.94", and it's showing up on the floor plan as 10'-4 1/2" instead of 10'-5" like I want it to. This is causing exterior dimensions to appear inconsistent and is overall a huge headache for me.

 

Is there some setting I'm not aware of that is preventing the dimensions from rounding up when I need them to?

 

 

Thanks,

 

Jack

Link to comment
Share on other sites

Edit-Default Settings - Dimensions - Primary-Smallest Fraction

 

This can also be done to a single dimension string by opening its dialog box-Primary-Smallest Fraction, you can also have it display in fractional feet as well.

 

DJP

 

Link to comment
Share on other sites

David,

 

I do have primary format of smallest fraction set to nearest 1/2 inch. Is there a setting that is preventing dimensions from ever rounding up? That appears to be my issue here.

 

Thanks,

 

Jack

Link to comment
Share on other sites

6 minutes ago, jbur91 said:

I do have primary format of smallest fraction set to nearest 1/2 inch. Is there a setting that is preventing dimensions from ever rounding up? That appears to be my issue here.

 

If you could post the plan file we could have a look at your specific situation.

  • Upvote 1
Link to comment
Share on other sites

Selecting the wall, and clicking on the dimension string is usually the best way to force the desired number. 

 

CAD lines can be a help as well. When placed on the same layer as manual dimensions, this method can be used to round up or down.

(Placing a line on both the outer left and right exterior walls (of the foundation) is a great way to ensure that the overall dimension string adds up). 

 

One observation... many new plans (created from a template) will have "grid snaps" on by default. Usually the reference grid as well. If by chance those features are on, try turning them off. This may assist w/unwanted snapping.  ...Just a wild guess... but the walls might be wanting to snap to the reference grid. 

 

 

 

Link to comment
Share on other sites

16 minutes ago, VHampton said:

One observation... many new plans (created from a template) will have "grid snaps" on by default. Usually the reference grid as well. If by chance those features are on, try turning them off. This may assist w/unwanted snapping.  ...Just a wild guess... but the walls might be wanting to snap to the reference grid. 

 

Not always a bad idea , but it is a good idea to set the Snaps to the same as your Dimension setting eg 1/2" in this case , so walls don't snap to strange positions.

 

image.thumb.png.4cdeed88a06c61bdae36c3f700168455.png

Link to comment
Share on other sites

22 hours ago, Kbird1 said:

 

...it is a good idea to set the Snaps to the same as your Dimension setting eg 1/2" in this case , so walls don't snap to strange positions.

 

 

Agreed. Using a 1/2" grid is best right from the start. 

 

If by chance the OP had placed walls with a 12" grid however... then it's conceivable that walls could have been positioned at various increments within that 12" x 12" parameter.  

 

...so for example, walls placed at 1/8th" or 3/4" increments would have to shift accordingly. 

 

It's a little bit of work, but that will fix everything in terms of being spot on with 1/2" dimensions - no matter which version one is working with. 

Link to comment
Share on other sites

I can't think of any way to make the program round 10' 4.94" down to 10' 4 1/2'.  

 

In the picture below, I set the walls to be exactly 10' 4.94" apart.  The dimension displays as 10' 5" because I have specified that they round to the nearest 1/2".  If you click on the dimension, it will display the actual value as 10' 4 47/50".

 

You should either post your plan or contact tech support.

 

 

dimension rounding.png

  • Upvote 1
Link to comment
Share on other sites

34 minutes ago, Dermot said:

I can't think of any way to make the program round 10' 4.94" down to 10' 4 1/2'.  

 

 

10' 4.94 " is 10' 4 15/16"   and with the OP's setting of 1/2" for the nearest Fraction I am not sure why it would round to 10' 4 1/2" ?

( *not sure why the OP is displaying or using decimal inches) there must be something else ( setting ?) causing that ?

 

Unchecking  Reduce Fractions in the Primary Format seems to do it though .....  it forces Dims to use the specified Fraction,

so it seems it rounds up correctly in this case BUT I have not had to do that in the past?

 

M.

Link to comment
Share on other sites

  • Solution

I solved the issue! I went into my dimension default settings for my main 1/4" scale dimension defaults and changed the rounding behavior from "grid rounding" to "distance rounding." It appears that with grid rounding it will not allow itself to round up, which I needed it to do. With distance rounding, it appears to now be rounding to the nearest half inch, regardless of whether that is up or down, instead of automatically rounding down every time.

Link to comment
Share on other sites

Quote

 

I can't think of any way to make the program round 10' 4.94" down to 10' 4 1/2'.

 

 

I should have remembered this, but such is life.

 

From the help article:

  • Grid Rounding ensures that the sum of the parts of a dimension line add up to the whole distance. To produce this result, some sections may not be rounded accurately. This is the recommended rounding method and is selected by default.
  • Distance Rounding addresses each section of a dimension line individually, which could result in the sum of these sections not being equal to the whole. This option is available for legacy purposes only and is not recommended. 

 

So grid rounding can round an individual value up or down so that the individual values will always add up to the overall values.  If you switch to distance rounding, your dimensions may not add up and can cause problems for people trying to use them.  The best way to avoid this problem is to make sure you have actually set the dimensions of your walls to what you want them to be rather than to adjust your rounding.

 

  • Upvote 1
Link to comment
Share on other sites

1 hour ago, Dermot said:

The best way to avoid this problem is to make sure you have actually set the dimensions of your walls to what you want them to be rather than to adjust your rounding.

Key to using Chief in general.  Accuracy and build the model like you would build the structure!!!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

  • Member Statistics

    32353
    Total Members
    9156
    Most Online
    RRSSeattle
    Newest Member
    RRSSeattle
    Joined
  • Similar Content

    • By ChiefuserMathews
      when I use the auto elevation dimension, I get 2 sets of dimension as shown in the image. Where is the settings to remove the inner dimension?
    • By Emma04
      I use Chief architect pro x14. Is there a way to lock wall length once done with imputing all your walls? Every time I try and use the room divider tool my wall always changes lengths; I thinks its just because of the angle I watched a video on how to fix it and was just wondering if there an option to lock your walls from the dimensions changing and not just being able to select them because of the active layer display . I'm new to Chief architect and when I used Revit it had a lock constraint next to the dimensions line, so I never had this problem before. Does Chief Architect not have this as a feature?
    • By AndrewSopher
      Hello,
       
      I have been working on a stepped foundation and was wondering why in the cross section for the foundation it does not display the entire wall length? It seems to extend only until the perpendicular wall intersects it. I was wondering if there is a way to change this and if not what are the easiest ways around this or to accurately measure it in the floor plan view. I attached an image (in this case there is a 4'' gap on the left side and a 3'' gap on the right side of the screenshot). Thanks. 
    • By Designers_Edge
      I have had this issue for a couple of years and just lived with it.  I do have an iMac with the Apple mouse.  Often when I do long end-to-end dimensions the lines are not straight or drawing a CAD object, they are off.  I have my "angles" checked so that I am not drawing an off angle item.  I have gone into Chief preferences and see nothing there and have also gone into the System Preferences on my computer to see if there are any controls for the mouse.  
       
      I never had this problem before.  It used to be, that I didn't have to worry about actually drawing a straight line, as Chief seemed to make sure the intended straight line was drawn that way.
       
      I put an example --this is a CAD line that I attempted to draw and I truly meant to draw it straight.  What am I missing??

    • By Ange822
      Good morning, would anyone know how to show the dimensions text horizontally and not parallel to where the dimensions is being taken?
      I am tried looking in preferences / setting / other chief talks with no luck.
       
      Much appreciated!