KDsnyder

Chief Lags when moving walls or objects

Recommended Posts

The following text is from a posted that has since been marked solved. The solution on that thread is about 3 years old and required a RAM drive using a third party download. As the issue I'm having is new after I've changed settings and only on this one file and my I'm curious if there is a different solution.

 

[copied text from "SOLVED" post] I'm currently experiencing really long lag times every time I move a wall or other object. Interestingly though I've noticed that bumping a cabinet doesn't produce the same lag time (it's almost instant) UNTIL it meets another object like an adjoining cabinet. I tested this by pulling the cabinet out into the room which resulted in a lag, then when it was in the room I was able to modify the cabinet by bumping stretching deleting and replacing like normal. Upon pushing that cabinet back to its position next to the other resulted in the same lag. Also, I am able to modify upper cabinets fine while they are touching other upper cabinets however I did notice that when I UNDO a function I also get a lag. This makes me wonder if the lag is due to the computer recognizing that the elevations and 3D views now need to reconstruct that joint whereas before the objects were just moving within the space. I'm getting about 60-80sec lag times which is absolutely insane. I haven't experienced this issue on other plans so it's very strange and makes me think I adjusted a setting somewhere that is causing this. The file size is 6.7MB

 

Thanks for any insight you may have on this. If it is helpful I can record a screen video just trying to figure out what might be the most helpful information to record.image.thumb.png.8e9afa7068252ffe2276da973b7192b2.png

Share this post


Link to post
Share on other sites

KD you didn't say what version of Chief you are using. Fix that by adding to your signature.
https://chieftalk.chiefarchitect.com/topic/18908-signature-here-at-chief-talk/

After you review the info Dermot provided I would look at Close the LAYOUT File.
Also notes & schedules, also auto rebuild, If you have a complex terrain that can cause slowdowns.
Those are the obvious ones for me with my limited knowledge.

  • Like 1

Share this post


Link to post
Share on other sites
23 hours ago, Dermot said:

Thanks so much for that. I should have mentioned that I went through all of that first before I reached out to this community. It is the oddest thing. 

 

22 hours ago, ACADuser said:

KD you didn't say what version of Chief you are using. Fix that by adding to your signature.
https://chieftalk.chiefarchitect.com/topic/18908-signature-here-at-chief-talk/

After you review the info Dermot provided I would look at Close the LAYOUT File.
Also notes & schedules, also auto rebuild, If you have a complex terrain that can cause slowdowns.
Those are the obvious ones for me with my limited knowledge.

Got it... I'll look into those options to see if that works. I did have auto rebuild walls turned on which I turned off. It didn't seem to speed it up so I went and deleted the wall framing that was generated by that action and still no performance issue. Thanks again for your help.

Share this post


Link to post
Share on other sites

You can always record a video of the situation and post the plan file.  Someone with the same or similar computer specifications can run the plan file and see if it is a hardware issue or look to see what may be causing the issue in the plan file.

 

Also please post your computer specifications and the version of chief you are using in your signature so that it is always there as a reference.

  • Like 1

Share this post


Link to post
Share on other sites

Would be best if you could post the plan, then we could see if the issue is plan related and possibly identify the culprit. Lot's of things can cause plans to run slow, just one crazy symbol can bring bring a system to a crawl.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, TheKitchenAbode said:

Would be best if you could post the plan, then we could see if the issue is plan related and possibly identify the culprit. Lot's of things can cause plans to run slow, just one crazy symbol can bring bring a system to a crawl.

Got it... here it is:

 

2 hours ago, Chopsaw said:
 
 
 
 
55 minutes ago, Chopsaw said:

You can always record a video of the situation and post the plan file. 

Here is the link to the video...

 

2 hours ago, Chopsaw said:
 
 
 
 
55 minutes ago, Chopsaw said:

Also please post your computer specifications and the version of chief you are using in your signature so that it is always there as a reference.

Sorry, a bit new to the forum. I thought I had done that. Should be good now hopefully.

 

Here's the link to the Youtube Video... sorry I couldn't figure out how to shrink the size down. 

 

Tuck_As-Built.plan

Share this post


Link to post
Share on other sites

Haven't dug to deep so I'm not sure where exactly the problem is, but I can definitely reproduce in X10.  No problems in X11 or X12 though so I suspect it's a bug or specific performance issue that's been addressed in newer versions.

  • Upvote 1

Share this post


Link to post
Share on other sites
6 hours ago, Alaskan_Son said:

Haven't dug to deep so I'm not sure where exactly the problem is, but I can definitely reproduce in X10.  No problems in X11 or X12 though so I suspect it's a bug or specific performance issue that's been addressed in newer versions.

Great, thank you so much for looking into it. I'm currently going through another file that was produced around the same time and comparing settings. So far I haven't found anything.

Share this post


Link to post
Share on other sites

Kurt,

I think I have the answer.

Working in X10.

There is a little triangular room attached to the upper right hand corner of the circular wall near the centre of the building.

Select one of the walls and designate it as a No Room Definition wall.

Delete the 2 room divider walls in the big room at the top of the plan.

Chief doesn't like island rooms.

In this case, the island room is connected to the exterior wall with a room divider, so I am not sure of the exact reason for the odd behaviour.

You are using an older version, so it just might be a bug that was fixed in later versions.

 

Screen Shot 2020-07-09 at 2.42.36 pm.png

  • Upvote 1

Share this post


Link to post
Share on other sites

@glennw Glenn, you are a wizard! I'm really curious why you thought to take care of those issues but so far that was the ticket. I deleted the first room divider then changed the wall to "no room definition" and that was pretty slow still it took about 60's once I changed the wall. As soon as I deleted the 2nd room divider the whole plan felt snappier. Even panning around in plan was smoother! Thank you so much! With that said I do still get about 2-3secs of the blue wheel when I'm working in plan and have an open elevation/perspective. Are you experiencing the same thing? Again a HUGE thank you for that I would have never even thought of that.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    28100
    Total Members
    6254
    Most Online
    s_anchia
    Newest Member
    s_anchia
    Joined
  • Similar Content

    • By Kbird1
      ======================================================================================================
      June 28th 2020
       
      *** AS OF VERSION X11 CHIEF HAS ADDED A TOOL TO PREFERENCES TO DO THIS FOR YOU, GO TO
       
      Preferences > General> File Management > File Association    .........     which is at the very bottom of the TAB.
       
      ======================================================================================================
       
      ***Dec. 2018***   For X10 and lower versions
       
      Microsoft has now fixed File associations and you can do it via
       
      Start>Settings>Apps>Default Apps> scroll down to  Choose Default App by File Type near the bottom (not File Protocol)
       
      Now scroll Down and find each Chief File type and change the Default to Chief Architect X10 ( or your version )
       
      X10 should be in the list for each type to choose from for these File Types...
       
      .alb
      .calib
      .calibz
      .layout           (sketchup maybe associated at times with this one)
      .plan
      .undoplan
       
      If Chief isn't listed or a choice above it should offer to look for Other Apps....
       
      so scroll all the way down to "look for other Apps on this PC" (in blue) if X10 is not on the List already and in the Windows Explorer Window go to :
       
      C:\Program Files\Chief Architect\Chief Architect Premier X10 (64 bit) and select the File Chief Architect Premier X10.exe
       
      after the 1st File type (.alb above) X10 should be in the list for the Others and you won't need to do this part again.... you can only change one at a time so do these 6 types...
       
      Mick.
       
       
      ================================================================================
       
      ***Nov 2018***
       
      A recent Windows  10 Update has Broken File Associations for Many Programs . not just Chief
       
      ---------------------------------------------------------------------------------------------------------------
       
      *** EDITED OCT 2018***
       
      It seems the Methods below may no longer work since the Windows 10 1803 Update in April
       
      Some other Options are :
       
      1.) You can also Right Click any .calibz file or .plan or .layout etc  and Choose Open With>CA X10  (scroll Down to bottom if you don't see X10 listed and choose look on PC  (see path below) and Select it, once found look for the Checkbox that says Always Use this App Check it 1st and then hit Ok
       
      The Default Full Path to the CA X10 Program is
      "C:\Program Files\Chief Architect\Chief Architect Premier X10 (64 bit)\Chief Architect Premier X10.exe"
       
      2.) You can also goto Control Panel>Default Programs>Select CA X10 and the Repair Button should appear and you can Use it to repairs Files for the Installed Program, this does not effect Settings etc at least not when I have tried it. This is useful if you re-install X9 or one of the Home Designer Products or an older version of CA, AFTER X10 and they overwrite the Defaults For X10.
       
      To Open Control Panel Right Click START>System> scroll to bottom on the right hand side and Chose System Info under Related Settings. In the top left hand Corner click on Control panel Home>Programs and Features> select Chief Architect Premier X10 (64bit)  and on the Ribbon next to the Organize dropdown Arrow you should see Repair appear, click on it and the Repair will begin. ( it will look like the Installer is running again)
       

       
       
      3.) There is also some Command-line Options available if you are familiar with Dos and the Command Prompt? ask if you need them , I will post them if needed but I don't want people messing their system up by accident.
       
       
       
      ==================================================================================================
       
       
      Original Method
       
      The X10 Upgrade does not seem to have reset the Default Application for .Plan, .layout .calib and .calibz , .alb Files, .undoplan to X10, which is why X9 is still opening when you double Click any of these File Types instead, from reading here on the Forum, it looks like it hasn't done this on the Mac OS either Instruction for Mac High Sierra OS are in Post #2
       
      Chief does not appear to have the ability to re-register default File Types like some Programs do, but it can be done manually via the settings App or Control Panel ( better/easier ).
       
      In Windows goto :
       
      >Control Panel\All Control Panel Items\Default Programs\Set Associations
       
      if that just takes you back to the Settings App , right click the Start Button >Run and it the box copy and Paste this and hit <Enter> :
       
      control /name Microsoft.DefaultPrograms /page pageFileAssoc
       
      goto each File extension. ( list below) and click the Change program button at top right.
       
      scroll all the way down to "look for other Apps on this PC" (in blue) if X10 is not on the List already ( wasn't for me) and in the Windows Explorer Window goto :
       
      C:\Program Files\Chief Architect\Chief Architect Premier X10 (64 bit) and select the File Chief Architect Premier X10.exe
       
      after the 1st File type (.alb) X10 should be in the list for the Others and you won't need to do that again.... you can only change one at a time so do these 6 types...
       
      .alb
      .calib
      .calibz
      .layout           (sketchup maybe associated at times with this one)
      .plan
      .undoplan
       
       
      Mick.
    • By dhurst
      All of sudden, after working for a couple of hours, I am getting the "blue spiral of death" every time that I try to alter an object of 3d images.  It takes at least three minutes to open the file.  I was working from our terminal server, but have moved to my desktop and I am still getting the same results.  Any suggestions?
       
      I would like to send you 
    • By CarlaBDesigns
      X10 for sale $1,000, this does not have SSA.
    • By KenL-sdd
      When you unlicense  x11 it also unlicenses x10 or if you unlicense  x10 it also unlicenses x11. That is fine and I understand why it is being done. However is should also work the other way if I license x11 for my laptop then it should give me access to x10 or vise versa..
      Case in point, I licensed x10 on my laptop to go into the field and meet with a client on a job, I have been working on for a while. Unfortunately the drawing had been opened and saved in x11 and was in the wrong file folder. Being in the middle of nowhere without internet connection I was hosed <that's the nice word> thanks to chiefs new way to  license. If you are going to remove access to x10 and x11 if just one is unlicensed then if I license one product the other should be licensed on the same machine it should automatically give access to the other product.
      Chief please fix this MAJOR licensing problem.
    • By wescott13
      Selling one copy of X10 Premier License.
      Does not include SSA, but SSA eligible.
      Price $2000 US or highest offer.
      I'll handle the transfer form for you.
      If interested email
      wescott13@gmail.com