fletcher

Roof auto generated a bunch of useless walls

Recommended Posts

Hey, I need some help. Last night I autogenerated a roof to be able to show a client what the home would roughly look like with the roof on it. From doing so I now have 2 issues: issue 1 is that it autogenerated a bund of walls that I don't want or need inside the roof (I noticed this when I went to delete the roof to make some more adjustments). Issue 2 is when I tried to delete the roof to continue working on the plan, certain walls have now grown taller in certain areas and I can't get them to be normal walls again. I've tried deleting them and redrawing them but as soon as I put a wall back in that spot it extends up in those areas. 

 

I am sure I am probably just lacking some fundamental knowledge of how the roofs work and how it affects the walls. 

Any suggestions would be helpful.

Thanks,

Walls.png

PJ_&_Krisha.plan

Share this post


Link to post
Share on other sites

When you build an automatic roof, the program will generate attic walls to fill in the gaps between the walls you have drawn and the roof surfaces.  When you delete the roof planes, the program will usually remove these automatically generated walls for you.  If you edit these automatic walls, then the program will convert them to manual walls and will not remove them for you. 

 

My guess is that you did something to these walls which converted them into manual ones so that now you will need to remove them yourself.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you for your answer Dermot. I don't think David understood the question because he was messing with the unfinished roof for some reason in his video. I figured the walls popping up had something to do with the roof and after doing some research found out that it was indeed creating attic walls in certain locations. 

 

Just as an FYI I am using X7

 

Do you happen to know if there is a way to turn off the function that auto-generates those walls or at least a way to be selective about it? There were only 2 gable walls that needed to be created and the rest were all under the roof where the trusses would be and definitely aren't needed structurally. I'll attach the image of the 2nd level layout to show you the walls.

 

Besides the walls that are created automatically, I am getting those few walls from the main floor that I showed in my original post that are extending up and jogging in weird spots. Would that be caused by the roof as well or is something else causing that? I use the dollhouse view to present layouts to clients and so I would like it to represent correctly. When I open up the properties of that closet on the main I get a message in the structure tab that says that the ceiling values may not be changed because the floor above has varying heights. I am not sure what is causing the error though.

2nd level walls.png

Closet Dialog box.png

Share this post


Link to post
Share on other sites
On 2/17/2020 at 6:09 PM, fletcher said:

Do you happen to know if there is a way to turn off the function that auto-generates those walls

 

Don't have X7 installed anymore but this is the Attic Wall setting to uncheck ...temporarily.... or you'll have to draw all your own.... this will allow you to delete unwanted Attic walls without them regenerating.

M.

 

image.thumb.png.e305b6fe986dde4683ef441a0103e246.png

  • Upvote 2
  • Downvote 1

Share this post


Link to post
Share on other sites

I believe that the program will only generate walls that it needs (at least in X12 it does but maybe you will see some differences in X7).  When I was looking at your model in a camera view, there were a lot of places that there would have been gaps between the roof planes and your walls had the program not generated automatic walls.

 

As far as the program generating walls that you don't want, I would make sure that the design is correct before I would spend time trying to get rid of them.  It does not look like all of your second floor walls are properly supported.  Assuming that you are going to align the walls between the floors, you will probably see a lot fewer automatic walls generated.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks, everyone. Sounds like I either need to do everything manually or just hide the attic walls. I appreciate you help on this issue.

Share this post


Link to post
Share on other sites

KBIRD1 - Thank you for this!  this happens to me all the time and its enough to drive me insane!  i did as you suggested in the default settings (im using x11) and so far so good.

 

Jennifer

Share this post


Link to post
Share on other sites
8 hours ago, DenisonDrywall said:

KBIRD1 - Thank you for this!  this happens to me all the time and its enough to drive me insane!  i did as you suggested in the default settings (im using x11) and so far so good.

 

Jennifer

 

Mick was showing how to turn the function off because somebody asked.  I could be wrong (I hope I'm not) but I don't think he was actually "suggesting" anything.  I certainly would not suggest people turn that setting off.  It's going to cause a lot more problems than it solves.  I would suggest even the most advanced users typically leave that setting toggled on...less advanced users, even more so.  If you have unwanted attic walls its almost never a problem with the walls themselves, rather, it's usually a problem with the user prematurely modifying them, or simply not understanding what the walls are doing or how to control their display.  In short, I recommend you leave them turned on and just learn to work with them as they were intended.

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
19 minutes ago, Alaskan_Son said:

 

Mick was showing how to turn the function off because somebody asked.  I could be wrong (I hope I'm not) but I don't think he was actually "suggesting" anything.  I certainly would not suggest people turn that setting off.  It;s going to cause a lot more problems than it solves.  I would suggest even the most advanced users typically leave that setting toggled on...less advanced users, even more so.  If you have unwanted attic walls its almost never a problem with the walls themselves, rather, it's usually a problem with the user prematurely modifying them, or simply not understanding what the walls are doing or how to control their display.  In short, I recommend you leave them turned on and just learn to work with them as they were intended.

 

Definintely not as a permanent solution , as I said above, just temporarily to remove a few stray walls as needed and turn it back on ...... it seems at least to me the programming behind the Attic walls in X11 is a bit more agressive than in earlier versions and sometimes clean up is needed.

 

Though someone seems to think it needed a downvote ??? wow ... makes me wonder if you even read the reply fully.... or understand what was said....

 

M.

  • Upvote 1

Share this post


Link to post
Share on other sites

Whenever i draw in a frost proof stoop, it creates a room above and then all these attic walls come in and create problems.  so if I'm doing something wrong when I create a frost proof stoop, please let me know.  It drives me crazy to have these wall show up where i don't want them.  then if you delete them, they show up as a regular wall and they never go away.

 

Share this post


Link to post
Share on other sites

You can deal with unwanted attic walls in a number of ways without turning off the functionary including but not limited to:

-Changing the attic walls to invisible walls

-Turning the layer off

-Using a more suitable wall type for the wall below (and thereby changing the automatically generated attic wall)

-Changing the attic wall itself to a more

suitable wall type

Share this post


Link to post
Share on other sites
23 minutes ago, DenisonDrywall said:

Whenever i draw in a frost proof stoop, it creates a room above and then all these attic walls come in and create problems.  so if I'm doing something wrong when I create a frost proof stoop, please let me know.  It drives me crazy to have these wall show up where i don't want them.  then if you delete them, they show up as a regular wall and they never go away.

 

Chief is just trying to fill in where walls are needed according to what is input.  If you are trying to do a roof over the stoop and you want it open to the rafters above select the room “porch” and unselect the radio button of flat ceiling above.  Occasionally you will need to delete the ceiling structure member as well but that is rare.  The attic walls will only be created where they are needed on the side.  If your trusses or rafters sit right on your top plate of your wall below then no attic walls will form as they are not needed.  But if you use a raised heel truss as many do, or your truss base is siting up above your wall top plate then chief will fill in an attic wall above it.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    28437
    Total Members
    9156
    Most Online
    Deannap
    Newest Member
    Deannap
    Joined