dskogg

Why doesnt wc show rope lights?

Recommended Posts

I made this LED mirror symbol with led lighting behind, it will only show in pbr not in wc , why is this?

 

Also i tried making a hole inside a circle sold and ca wont let this happen, Ie i made a circle turned it into a solid at 1/4" thick and then had a smaller circle i wanted to make a hole in the first solid and ca wont let this happen? I am trying to make a donut led light instead of just a circle led light.

kube mirror pbr.jpg

kube mirror wc.jpg

Share this post


Link to post
Share on other sites

Not sure about the rope light although they are different than regular lights.

 

There should not be an issue with the solids but you can do that just fine with psolids so it is not necessary to use solids.

Share this post


Link to post
Share on other sites
1 hour ago, dskogg said:

it will only show in pbr not in wc , why is this?

 

Maybe the lights setting ? ....How many default lights do you have on in the WC Camera ...8. 20 , or 100?  8 and 20 likely aren't enough ......

Share this post


Link to post
Share on other sites

All the lights show when on pbr and not with wc, 

 

I upped lights to 200

 

i have never got ripe light to work using wc 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Chopsaw said:

Not sure about the rope light although they are different than regular lights.

 

There should not be an issue with the solids but you can do that just fine with psolids so it is not necessary to use solids.

That’s what I did, I made a circle 1” dia, turned it into a poly line solid 1/4” thick and then tried cutting a hole out of it.. would not let me do it.

Share this post


Link to post
Share on other sites

image.thumb.png.a8c38a5e8dfa9f496dd3981f6d2a67fc.png

Share this post


Link to post
Share on other sites
5 minutes ago, dskogg said:

That’s what I did, I made a circle 1” dia, turned it into a poly line solid 1/4” thick and then tried cutting a hole out of it.. would not let me do it.

the hole needs to be a p-solid before it can be a hole. Did you do that?

Share this post


Link to post
Share on other sites
5 hours ago, robdyck said:

the hole needs to be a p-solid before it can be a hole. Did you do that?

 

Actually, to be more precise, it just needs to be converted to an actual polyline.  A circle is not a polyline.  It can either be converted to a multi-segment polyline or to a couple arcs.  Converting to a polyline solid does the trick, not because its a polyline solid but because its a polyline.  During the convert process, it's just broken into 2 arcs automatically.  Semantics?  Maybe,,but I think it's good to understand whats actually happening.  You can get to the same end any number of ways.  No matter what you do though, a true CAD Circle object cannot be used with boolean operations.

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
2 hours ago, robdyck said:

the hole needs to be a p-solid before it can be a hole. Did you do that?

When converting in x11 it used to ask if you want a a polling solid then you could make it a hole 

 

now it doesn’t give you an option it gives you hole option

 

 I will post plan tomorrow 

Share this post


Link to post
Share on other sites

I think @dskogg was using the "solid hole" choice as opposed to the 'hole in polyline solid" option after choosing polyline solid.

 

Share this post


Link to post
Share on other sites
4 hours ago, robdyck said:

I think @dskogg was using the "solid hole" choice as opposed to the 'hole in polyline solid" option after choosing polyline solid.

 

HI Rob thanks for video, your polyline solid has no thickness, mine is .25" thick and when i do all those steps it does not allow me to make it a hole?

polyline solid hole in a polyline circle solid.JPG

Share this post


Link to post
Share on other sites
1 minute ago, dskogg said:

HI Rob thanks for video, your polyline solid has no thickness, mine is .25" thick and when i do all those steps it does not allow me to make it a hole?

polyline solid hole in a polyline circle solid.JPG

Yes, it has a thickness, the default thickness of 1". Your definitely doing something odd. Is the larger circle already a polyline solid? Can you post your plan?

Share this post


Link to post
Share on other sites

Here is the plan, the round polyline solid below mirror i am trying to make the circle inside a mirror so the led looks like a donut and then 

re insert it back into mirror above.

 

 

LED cube mirror.zip

Share this post


Link to post
Share on other sites

You don't need to use that Hole In Polyline Solid setting.  Just use boolean operations (polyline subtraction).

Share this post


Link to post
Share on other sites
3 minutes ago, dskogg said:

Here is the plan, the round polyline solid below mirror i am trying to make the circle inside a mirror so the led looks like a donut and then 

re insert it back into mirror above.

 

 

LED cube mirror.zip

For the rope lights to show up in a WC renderings, they'll need to be much brighter. I'd suggest making a copy of the rope lights on their own layer for WC pics and use separate lighting  sets for WC. In the pic below, the rope light is at 2000 lumens.

image.thumb.png.baaceb4033d55381e2aee8658b1a0b18.png

Share this post


Link to post
Share on other sites

 

2 minutes ago, Alaskan_Son said:

You don't need to use that Hole In Polyline Solid setting.  Just use boolean operations (polyline subtraction).

I tried doing a subtraction but I could not get it to do anything?

 

Can you suggest steps?

 

 

Share this post


Link to post
Share on other sites
2 minutes ago, robdyck said:

For the rope lights to show up in a WC renderings, they'll need to be much brighter. I'd suggest making a copy of the rope lights on their own layer for WC pics and use separate lighting  sets for WC. In the pic below, the rope light is at 2000 lumens.

image.thumb.png.baaceb4033d55381e2aee8658b1a0b18.png

Ok, that is really dumb, so in pbr it works but in wc you need to up lumens? 

Share this post


Link to post
Share on other sites
1 minute ago, dskogg said:

 

I tried doing a subtraction but I could not get it to do anything?

 

Can you suggest steps?

 

 

Click the big circle.

Click polyline subtraction tool

click small circle.

Share this post


Link to post
Share on other sites
1 minute ago, dskogg said:

 

I tried doing a subtraction but I could not get it to do anything?

 

Can you suggest steps?

 

 

Select large p-line, click the subtraction tool, and then click the shape you want to subtract (smaller p-line).

Share this post


Link to post
Share on other sites
1 minute ago, dskogg said:

Ok, that is really dumb, so in pbr it works but in wc you need to up lumens? 

Exactly. It's not that dumb, is it? The rendering tools work differently. You need different lighting sets for PBR and Raytracing...

Share this post


Link to post
Share on other sites
Just now, robdyck said:

Click the big circle.

Click polyline subtraction tool

click small circle.

Ok that worked, thanks

apparently i don't know some basics!

Share this post


Link to post
Share on other sites

Thanks guys for your help, here is final product...

still trying to figure out how to make rope light go vertical to put on either side.

Kube LED Mirror.jpg

Share this post


Link to post
Share on other sites
3 minutes ago, dskogg said:

Thanks guys for your help, here is final product...

still trying to figure out how to make rope light go vertical to put on either side.

Kube LED Mirror.jpg

Use an 'added light', copy the light settings from a rope light, and replicate it vertically (z-axis).

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27613
    Total Members
    6254
    Most Online
    3dvfxarch
    Newest Member
    3dvfxarch
    Joined