Toolbar Configurations


ComputerMaster86
 Share

Recommended Posts

I am having trouble understanding why when I switch toolbar configurations I loose all my toolbar customization.  This includes custom toolbars and custom toolbar icons.  Would this be a bug perhaps?  Either way it is annoying as all hell get it out.

Link to comment
Share on other sites

1 hour ago, ComputerMaster86 said:

I am having trouble understanding why when I switch toolbar configurations I loose all my toolbar customization.  This includes custom toolbars and custom toolbar icons.  Would this be a bug perhaps?  Either way it is annoying as all hell get it out.

 

Lance - you need to make sure you have your toolbar "Checked" in the associated "VIEW".  See attached picture...

 

1030514716_ToolbarConfig1.thumb.png.9df2777a9dc13e8b4cca0eb14887a828.png

Link to comment
Share on other sites

2 hours ago, SNestor said:

Lance -

 

4 hours ago, ComputerMaster86 said:

I am having trouble understanding why when I switch toolbar configurations I loose all my toolbar customization

 

Not a bug, any customization in 1 toolbar configuration is for that configuration only, it is not global, nor is there an option to make global changes to multiple configurations.

 

I would venture a guess that I have spent more hours than anyone could conceive of spending on toolbar configs.  I've been building them out for the touchscreen environment.There are a host of problems when trying to extend your customization to other configurations.

Biggest problem in describing my methods is that that nomenclature used by CA doesn't easily distinguish between different elements of the toolbar schema.

 

I start by making a master config including all possible "toolbars"(The individual toolbar sets that can be dragged and docked or floating anywhere you like.

I make them for MEP, Dimensioning, Framing etc. 

Once I have ALL of them built, I copy/paste, say, the MEP configuration, and then as SNestor shows, I un-check everything that I don't want on the MEP config.

I do this for all of the various toolbar configs that I enjoy. That way when switching configs, there are a number of items of toolbars that never disappear, with only a core set of toolbars switching dependent on what I am working on. When you make a global change, you have to do the copy/paste deal all over again. When you make a localized change you should make it in the master config and then copy back again... Cumbersome, but I have sped his up over time.

To really be efficient you have to do some pre-planning for an extensive overhaul if that's what you desire. My 3d toolbars took a crazy amount of time to setup.

Posting an example:

Capture.thumb.PNG.92183a3582d0991568b68b7253674d0a.PNG1284692533_Capture(2).thumb.PNG.fd70d6139ec4a87af3963082d602e30a.PNG1254651901_Capture3.thumb.PNG.5c17ea6a864f75f2047ad4fce17562f9.PNGCapture4.thumb.PNG.02826746cfc9b3d120697f1700999566.PNG

 

Link to comment
Share on other sites

4 hours ago, ComputerMaster86 said:

I am having trouble understanding why when I switch toolbar configurations I loose all my toolbar customization.  This includes custom toolbars and custom toolbar icons.  Would this be a bug perhaps?  Either way it is annoying as all hell get it out.

I discovered a “bug” of sorts. 

I’m on MacBook with an external monitor. 

Toolbars were often disappearing or resizing etc, until I discovered that the offending entity was having my layer display window open on the laptop while I worked on the monitor. 

I now don’t have that layer display window docked on the laptop, instead I use a hotkey to call it up, make changes and close the window. 

Since then I don’t have any toolbar issues anymore. 

I sent it in and have spent at least 4 calls with tech support who were unable to pinpoint the cause of the problem I was having. 

Link to comment
Share on other sites

50 minutes ago, Michael_Gia said:

I discovered a “bug” of sorts. 

I’m on MacBook with an external monitor. 

Toolbars were often disappearing or resizing etc, until I discovered that the offending entity was having my layer display window open on the laptop while I worked on the monitor. 

I now don’t have that layer display window docked on the laptop, instead I use a hotkey to call it up, make changes and close the window. 

Since then I don’t have any toolbar issues anymore. 

I sent it in and have spent at least 4 calls with tech support who were unable to pinpoint the cause of the problem I was having. 

I'm on a MAC...and have experienced the same issue.  I had the issue since at least X9.  Gave up keeping the Object Layer Display window open on 2nd monitor and call up with hotkey...it works.

  • Upvote 1
Link to comment
Share on other sites

I struggle with this all of the time. I like to "float" some of my toolbars, with a child toolbar along side, especially a customized Architectural Toolbar. They will not stay put and continually disappear totally. Like Rene, I have spent hours trying to find the culprit. Using multiple monitors seems to make it worse at times. If I try to customize a toolbar it seems to always mess up some of my other customizations. I have made sure I have checked the toolbars I want visible in the appropriate views. Works for a while and then will suddenly go crazy. I have resorted to just leaving them docked for most views; sometimes it's just not worth fighting the way CA works. Hasn't solved the problem totally as some will still disappear; but it is a little more stable. I worked with my customized configurations for years without much trouble, but I only had one monitor (I work on a desktop system). The multiple monitors and the ALDO seem to be part of the problem but I haven't been able to narrow it down for sure to either or both. It would be great to have this resolved as my workflow is slower without the customization I like.

Link to comment
Share on other sites

Toolbars are a form of art,,,,,,,,,, I use no key commands or hot keys. Set up takes a minute but once you understand how to control them it gets easier.                    2019-06-10_15-41-44.thumb.png.5f7c40523694b81d67a6a23478a2ec8a.pngAll toolbars2019-06-10_15-39-07.thumb.png.08cdaf7f5d643e3a48b65e0714975d02.png

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

  • Member Statistics

    30372
    Total Members
    9156
    Most Online
    NZBrent
    Newest Member
    NZBrent
    Joined