How to disable the CPU graphics on laptop with Nvidia graphic card


OkcDesigner
 Share

Recommended Posts

OK, I have seen this talked about and as of last Tuesday, I am faced with eliminating the two graphics fighting...…….

ASUS GU501 (ROG)

 

I disabled the UHD graphics 630 in device manager.

 

Is that it or something else needed to make sure the Nvidia is the graphics at all times?

Link to comment
Share on other sites

Best practice is to set Chief to use the dedicated card in the nVidia control panel NOT to completely disable the onboard graphics. Let the onboard handle what other tasks it needs to.

The control panel is located in the taskbar or right clicking on the desktop. Go to the 3D settings tab, manage 3D settings, program settings. Add Chief Architect exe there, then go down the list. Most things get set to high performance, a few are left alone, a few are managed by program. I usually also set ChiefArchitectRayTracer.exe there though I'm not sure how much difference it makes but what the hay.

Link to comment
Share on other sites

You will typically get better battery life by only using the Nvidia Card when needed , assigning Chief in the 3D Management tab under Programs works for me....

 

Here is a more detailed post I made for another Chiefer....

 

https://chieftalk.chiefarchitect.com/topic/17190-inserting-object-from-library-browser-freezes-most-of-the-app/?do=findComment&comment=144430

 

Link to comment
Share on other sites

It's best to use the Power Settings and the Nvidia Control Panel to control which GPU your system uses. Disabling this in the device manager may cause problems should your discrete graphics card fail. To make sure your discrete graphics card is being used all of the time you need to go to the Windows Power settings and change this to High Performance. Then open up the Nvidia Control and under Global Settings set the Performance to Maximum. Then under programs add your version of CA.

 

If you want to check to confirm that everything is working fine, open Windows Task Manager, in the processes window you should see a column "GPU", watch this as you work with CA and different programs, you will notice to the left of this column notices starting with either GPU0 or GPU1 will pop up. GPU0 is your integrated graphics and GPU1 is your discrete graphics. Only GPU1 should pop up, if a GPU0 pops up then your settings are not correct. IF only GPU0 pups up then your system is only recognizing your integrated graphics, if both GPU0 and GPU1 are popping up then your system is using both and it's switching back and forth between the two GPU's, if only GPU! pops up then it is only using your discrete graphics for everything.

Link to comment
Share on other sites

4 hours ago, TheKitchenAbode said:

It's best to use the Power Settings and the Nvidia Control Panel to control which GPU your system uses. Disabling this in the device manager may cause problems should your discrete graphics card fail. To make sure your discrete graphics card is being used all of the time you need to go to the Windows Power settings and change this to High Performance. Then open up the Nvidia Control and under Global Settings set the Performance to Maximum. Then under programs add your version of CA.

 

If you want to check to confirm that everything is working fine, open Windows Task Manager, in the processes window you should see a column "GPU", watch this as you work with CA and different programs, you will notice to the left of this column notices starting with either GPU0 or GPU1 will pop up. GPU0 is your integrated graphics and GPU1 is your discrete graphics. Only GPU1 should pop up, if a GPU0 pops up then your settings are not correct. IF only GPU0 pups up then your system is only recognizing your integrated graphics, if both GPU0 and GPU1 are popping up then your system is using both and it's switching back and forth between the two GPU's, if only GPU! pops up then it is only using your discrete graphics for everything.

 

You can also turn on the Nvidia Visual indicator so you know when it is being used , at the Top of the Control Panel , under Desktop check Display GPU Activity Icon.

 

M.

 

 

Link to comment
Share on other sites

48 minutes ago, Kbird1 said:

 

You can also turn on the Nvidia Visual indicator so you know when it is being used , at the Top of the Control Panel , under Desktop check Display GPU Activity Icon.

 

M.

 

 

 

The reason I like Task Manager is that it shows both GPU's. About 2 months ago, for some reason I noticed my fan seemed to be cranking up more than normal, watched task manger and it showed that both GPU's were being used, it would bounce between GPU0 and GPU1. My main Windows power plan was set at high performance and X10 was assigned to the Nvidia, checked the Nvidia Global settings and found it was not set to maximum performance. After setting this to maximum GPU0 disengaged and GPU1, my GTX, assumed control of everything.

Link to comment
Share on other sites

1 hour ago, TheKitchenAbode said:

 

The reason I like Task Manager is that it shows both GPU's. About 2 months ago, for some reason I noticed my fan seemed to be cranking up more than normal, watched task manger and it showed that both GPU's were being used, it would bounce between GPU0 and GPU1. My main Windows power plan was set at high performance and X10 was assigned to the Nvidia, checked the Nvidia Global settings and found it was not set to maximum performance. After setting this to maximum GPU0 disengaged and GPU1, my GTX, assumed control of everything.

 

It sounds like it was jumping back and forwards between the Nvidia and iGPU when going from 2D to 3D views , which would make sense , looking at it from a power-saving viewpoint , but forcing Maximum would of stopped that , and if the Laptop is plugged in it really wouldn't matter re battery life.

 

M.

Link to comment
Share on other sites

1 hour ago, Kbird1 said:

 

It sounds like it was jumping back and forwards between the Nvidia and iGPU when going from 2D to 3D views , which would make sense , looking at it from a power-saving viewpoint , but forcing Maximum would of stopped that , and if the Laptop is plugged in it really wouldn't matter re battery life.

 

M.

 

Yes that was what was likely happening, it would also bounce when using my browser and some other programs. What surprised me was that I not only needed my Windows power setting and maximum but also the one in the Nvidia control panel under global.

Link to comment
Share on other sites

If you guys have updated to the new Win 10 version this is actually now controlled by the OS.  On my laptop I was struggling to understand why I was having issues all of a sudden controlling this from Nvidia's app.

 

Watch this video for more info....they go over the top 5 new features but they show specifically how this is now controlled by Win 10.  I started using this and works like a charm.

 

 

 

Link to comment
Share on other sites

Thanks Johnny , I wasn't aware of that but my desktop is Nvidia Only and so far my laptop has not been offered the 1803 Update , which I read maybe due to it having an Intel SSD so I haven't forced the Update on it yet.

 

PS....The Feature is at minute 5:10 in the video above if you want to have a look at it ...

Link to comment
Share on other sites

Thanks Johnny, I have the April update and took a look at that feature. From what I can deduce this is designed to allow one to override the default setting for a particular program. If for example the power plan is default set to balanced then you can assign say CA to a dedicated GPU. However, under this situation your computer will bounce between the two GPUs, using the dedicated GPU for CA and then the integrated chip for all non assigned programs. It seems that to use this as a way to force only the dedicated GPU to be used all of the time you would need to assign every program on your system. From what I can see is that it's best not to use this new feature and just set the power plan to maximum, as such the default is the dedicated GPU.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

  • Member Statistics

    30642
    Total Members
    9156
    Most Online
    oppguenard1
    Newest Member
    oppguenard1
    Joined