ShelbyHall

Grainy Ray Trace

Recommended Posts

My ray trace always turns out super grainy. I am using Premier X7 and the image I attached is after 3min. 32 sec. and 16 passes. Can someone  please help me figure out what I am doing wrong.

 

Thank you so much!

 

post-7437-0-93173800-1452040181_thumb.jpg

Share this post


Link to post
Share on other sites

Have you tried to let it cook for longer?...

 

16 passes, especially with photon mapping and a lot of specular materials might not be long enough...

Share this post


Link to post
Share on other sites

Shelby - I would change the floor to reflective vs polished.  That will help.  Your video card could be part of the problem, maybe-maybe not.

You could post the plan and others can run a ray trace for the same time and see what results they get based on their equipment.  But 16 passes in a little over 3 minutes seems to be pretty quick.  Post the plan so we can have a look,

Share this post


Link to post
Share on other sites

I can't see any objects in the plan that would need caustics so you could turn off compute caustics, that's the biggest contributor to 'fire flies' in a render.

If you need to use caustics my minimum recommendation is to let it complete 500 passes. That's the number I've found works for any scene that uses caustics.

Share this post


Link to post
Share on other sites

Thank you all for your help!

I have changed the floor to reflective and am trying another ray trace letting it go longer. I am using a 2014 Mac book Pro and I would hope that the video card is still good. I went back and checked my settings and caustics was not turned on. I have attached my plan here. It is the second floor kitchen I was trying to ray trace. 

 

Thanks again!

 

 

Eliot Hill Building 1.plan

Share this post


Link to post
Share on other sites

Video card has nothing to do with ray traces.  The video card is used for standard rendering techniques only.  Ray traces are 100% CPU.

Share this post


Link to post
Share on other sites

I don't have any of your custom textures so the scene looks a little different.

But what I found in your plan is that you had specularity or reflective properties applied to nearly every material in the scene.

 

Also, you had more light sources than was necessary and they were very intense.

This was probably adding up to your results.

 

As already mentioned, in another reply, the video card is not used while ray tracing so I wouldn't stress over that.

 

Instead I would focus on adjusting your material definitions and limiting your lights to a more real setup.

 

I've attached a modified version of your plan along with my results with only 5 passes.

 

Changes made:

 

- Turned off all the lights in the plan on every floor and deleted the extra light sources that were added. But left the lights in front of the camera on.

- Adjusted the intensity of the lights that were left on.

- Adjusted the material properties throughout the room to better fit the objects they are applied to.

- Moved the light source for the pendant lights into the pendant instead of underneath.

 

post-44-0-07926000-1452101589_thumb.png

modified-plan.zip

Share this post


Link to post
Share on other sites

You're welcome, feel free to share your results if you feel inclined. :D

Share this post


Link to post
Share on other sites

Forgot to mention in my first post as well, I modified the ray trace settings as well, be sure to poke around in there to see the changes.

Share this post


Link to post
Share on other sites

Kirk, to change the light source for the pendant is that changing the offset from base position?

Share this post


Link to post
Share on other sites

Yes, I believe I used a new offset of 30" to put it near where you should see a light bulb.

Share this post


Link to post
Share on other sites

This was after 12 passes 25 min  I changed a few materials because none of the originals from the plan were showing up

 

post-4069-0-83521200-1452133155_thumb.jpg

Share this post


Link to post
Share on other sites

It is looking so much better! But I'm not sure why my lights are so bright...

That's due to the change made to the offset and the material being set to translucent. Are those actually supposed to be open bottom pendant lights? I must have missed that while making changes.

Share this post


Link to post
Share on other sites

My ray trace always turns out super grainy. I am using Premier X7 and the image I attached is after 3min. 32 sec. and 16 passes. Can someone  please help me figure out what I am doing wrong.

 

Thank you so much!

 

The issue relates to the glass jar pendants over the island. The glass material is "Shinny White". Go to the material DBX "Properties" and set the diffusion setting to "0", it's currently set at 100%. Alternatively you can set the material to "General", reduce the "Diffusion" and increase the "Transparency".

 

I used your first posted plan drawing. Here is the same scene with the diffusion set at 0. No other changes were made.

 

Graham

post-4793-0-44589700-1452189758_thumb.jpg

Share this post


Link to post
Share on other sites

So I thought my grainy image might have something to do with the pendant so I tried using different pendants and still cant figure it out. I know I could lower the diffuse, but that changes the color of my pendants and I need them to be white. If I remove the pendants the graininess goes away. I don't understand what I am doing wrong with the pendants to cause all the grain.

post-7437-0-14918400-1452201388_thumb.png

Share this post


Link to post
Share on other sites

So I thought my grainy image might have something to do with the pendant so I tried using different pendants and still cant figure it out. I know I could lower the diffuse, but that changes the color of my pendants and I need them to be white. If I remove the pendants the graininess goes away. I don't understand what I am doing wrong with the pendants to cause all the grain.

 

Reduce the light intensity. You can do this for all of the lights in the scene. The pendants are 100 watt each, drop them to 24 watt. This will help.

 

Graham

Share this post


Link to post
Share on other sites

Im confused on that because when I open the light data the intensity is at 40 watts. Is there another place I need to change this?

Share this post


Link to post
Share on other sites

Pleased that I was able to assist.

 

Just keep an eye on those point lights as they can be problematic and will increase your Raytrace time. Unlike spot lights, point lights require far more complex algorithms to compute the lighting effect. As the light source emits from within a lamp shade or glass surround then the materials for these will alter the lighting effect. Those "Firefly's" or excessive grainy white spots if not too severe should clean-up after several passes, if not then you need to make some adjustments. Maybe the best way to envision those "Firefly's" is to think of them as blown-out highlights as in photography. Just a theory but I believe these are points where too many light rays from differing sources are diverging at a singular point, which may be why reducing the light intensity or changing the light fixtures shade material resolves the problem.

 

Graham

Share this post


Link to post
Share on other sites

Ray Tracing successfully is an acquired skill, your ability advances along with your successes and failures (both are good learning tools). There are some basic video tutorials on that subject for SSA members and some good tutorials resident at Chief Tutor.com. One of the most consistently successful ray tracers around is Jintu Montego. He created the attached PDF file as general advice for people wanting to increase their skill.

 

DJP

Raytrace Settings-Forum Notes.pdf

  • Upvote 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27825
    Total Members
    6254
    Most Online
    ChiefDallas
    Newest Member
    ChiefDallas
    Joined