Recommended Posts

GENERAL DRIVER DOWNLOAD PAGE AT NVIDIA

 

https://www.nvidia.com/en-us/geforce/drivers/

 

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

Nvidia has released new Studio Drivers today ( 8-17-2020) as well ..............Version 452.06

 

 

https://www.nvidia.com/Download/Find.aspx?lang=en-us#

 

 

 

 

--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

Nvidia has released new Studio Drivers today ( 7-16-2020) as well ..............Version 451.77

 

News

https://www.nvidia.com/en-us/geforce/news/june-2020-nvidia-studio-driver/

 

Driver Download:

 

https://www.nvidia.com/download/driverResults.aspx/162469/en-us

 

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

 

NEW Nvidia Drivers were released today July 9th 2020 - both Game Ready (GR) and Studio Drivers

 

Standard - GeForce 451.67 WHQL Game Ready Driver
https://www.nvidia.com/download/driverResults.aspx/162102/en-us

 

DCH - GeForce 451.67 WHQL Game Ready Driver

https://www.nvidia.com/download/driverResults.aspx/162105/en-us

 

-----------------------------------------------------------------------------------------------------------------------------------------------

The information below may no longer be relavent in 2020 with Drivers having reached Version 451.xx Series now.

Links to Older Drivers also removed above as of June 23 2020.

----------------------------------------------------------------------------------------------------------------------------------------------

 

Possible Fix for those using older Nvidia Drivers

Use the 382.05 Drivers

 

Many seem to have issues with the new Nvidia 388 Series Drivers and Up ( 388.0 /.13/.33 etc)  installed automatically by Windows Update

 

**edit....... just a note that the new 10 Series Nvidia Cards seem less likely to have these issues , but it's not unheard of.

 

eg. The mouse cursor disappearing in 3D views and other weirdness seem to be some symptoms in Chief , I was also get Crashes with some sort of DirectX error , in other Programs , as far as I know Chief uses OpenGL not DirectX  (maybe both?) and Chief was not Open when that was happening

 

 

One Possible Fix that helped me and a few others is Rolling the Driver back ( re-installing actually) ) to May's Version 382.05 , this Driver is no longer available since this week off the usual Nvidia Drivers Download page , at least for me, the oldest is 385.12 so below are the direct links to the download page for 382.05.

 

Make sure you get the Correct Version as there is a Notebook/Laptop version too.

 

Once you have Run the Installer you will also need to disable Windows Update from Updating Hardware Drivers or it will almost immediately re-Update you to to the 388.xx Driver again, more on that below too.

 

Nvidia Desktop Driver version 382.05  direct download page

 

http://www.nvidia.com/download/driverResults.aspx/118514/en-us

 

 

Nvidia Notebook/Laptop Driver version 382.05  direct download page

 

http://www.nvidia.com/download/driverResults.aspx/118518/en-us

 

 

How to disable Windows 10 Driver Updates

 

The Full post is over at TenForums ( a great general Win10 Issues Forum) if you'd like to check it out....

 

https://www.tenforums.com/tutorials/48277-enable-disable-driver-updates-windows-update-windows-10-a.html

 

 

But I use the provided .reg files from there as they always seem to work .... I have zipped them and attached them below for easy download , you will need to run the OFF file for now , the ON file is provided so you can easily re-enable it when desired or needed.

 

Drivers From Win Update Reg Files.zip

 

And the Instructions from TenForums  ( all Credit to Shawn aka Brink over there for the Tutorial and Files above )

 3. To Turn Off Including Driver Updates in Windows Update

A) Click/tap on the Download button below to download the file below, and go to step 4 below.

Turn_off_include_drivers_in_Windows_Update.reg
 

4. Save the .reg file to your desktop. (Unzip the File above to a Folder for reuse , if you downloaded it 1st  and double click it from there)

5. Double click/tap on the downloaded .reg file to merge it.

6. If prompted, click/tap on Run, Yes (UAC), Yes, and OK to approve the merge.

 

It is usually recommended to restart your computer after a Registry Update , so do that before starting Chief again....

 

 

If you need to Renable Driver  Updates just use the other Provided file ie..... Turn ON_

 

To Turn On Including Driver Updates in Windows Update
 
Turn_on_include_drivers_in_Windows_Update.reg
 

5. Double click/tap on the downloaded .reg file to merge it.

6. If prompted, click/tap on Run, Yes (UAC), Yes, and OK to approve the merge.

 

It is usually recommended to restart your computer after a Registry Update , so do that before starting Chief again....

 

Also if using a Laptop with two Video Cards ( Discrete Graphics ) make sure the Discrete Card is assign to be used in Chief or the HD Titles as Chief does not have a 3D Profile in Nvidia Control panel for example and is not always recognized as a 3D Application. How to below...

 

https://us.answers.acer.com/app/answers/detail/a_id/46334/~/configure-amd-radeon-switchable-graphics

or

https://us.answers.acer.com/app/answers/detail/a_id/11575/related/1

 

 

 

Hope this Helps ,

 

Mick.

 

  • Upvote 2

Share this post


Link to post
Share on other sites

Mick,  I got Nvidia v.388.13 with windows v. 1709 and don't seem to be noticing any issues but am aware of a problem the newer versions have in Adobe Reader that seems to not be fixed yet, but that problem happened after v. 378.92

 

Any additional details on the "weirdness" and what I should be watching for would be great.  Also is Chief and or Nvidia aware.

 

Thanks for the warning and detailed posting.

Share this post


Link to post
Share on other sites

It has (was) been happening since 1709 for me ,  the mouse Cursor would disappear if I had a 3D window open too long as one example , some others have reported this too , along with the Fact CA support is now recommending people with issues Rollback to the May Driver.

 

  I was also getting issues in some other Apps, so did the Rollback 2 weeks ago. But I have seen numerous Posts this week about it and was posting in two threads this morning to help out , so figured it was easier to make a new post for people to find with all the Info, assuming they do a search :)

 

I have a GTX 970 and a GTX 980Ti , not one of the new 10 Series cards which I believe the 388 Series Drivers are mainly aimed at .....newer is not always better when it comes to Drivers despite what M$ would have you believe and them pushing Drivers from Windows Update.....I personally update my own Drivers, so this Option is always off on my Systems, if I have an issue I look into , and see what others recommend 1st, especially as many of the M$ Drivers are Stripped down versions of the Full Driver and come with no GUI , eg many of Intel's GFX Drivers. I tried Versions 388.0 and 388.13 for another Program and they Broke it (DirectX Errors) and Chief but others were reporting issues with 388.0 on other Forums like OCN.net too.

 

Mick.

 

 

Share this post


Link to post
Share on other sites

Thanks for the detailed procedure on rolling back Nvidia drivers.

 

I recently switched from ATI (AMD) to Nvidia, but was hesitant because of issues often reported with newer Nvidia driver versions.  I have not seen any issue so far with 388.13 on a GTX 1070 Ti, so it's possible that regression testing is not up to par at Nvidia for older cards.  Ironically, I may fall into that 'older' category once the Titan's and subsequent cards become more mainstream.

Share this post


Link to post
Share on other sites

My GTX 1050 Ti running the latest driver causes Chief to hang upon trying to close a 3D view. If I install the driver from May '17 Chief works fine, but then I start experiencing issues with other programs because I am not using the most recent graphics driver. 

 

I have talked with Nvidia tech support and Chief Architect support. Nvidia points their fingers at Chief Architect developers and Chief Architect points their fingers at Nvidia.

 

Share this post


Link to post
Share on other sites
1 hour ago, SabGroup said:

... Nvidia points their fingers at Chief Architect developers and Chief Architect points their fingers at Nvidia.

 

Not uncommon.  What would be interesting is what each party said about the other not doing things right.

 

I'm using the latest Nvidia drivers and doing just fine with CA and all other fronts.  Go figure.

Share this post


Link to post
Share on other sites
7 minutes ago, cv2702 said:

Not uncommon.  What would be interesting is what each party said about the other not doing things right.

 

I'm using the latest Nvidia drivers and doing just fine with CA and all other fronts.  Go figure.

Has someone from CA contacted Nvidia and asked for a detailed list of changes that were made from May to June? 

 

When I upgrade to x10 am I going to have to use a 12 month old graphics driver?

 

Anyone know of any patches or updates in the pipeline?

Share this post


Link to post
Share on other sites

My guess is CA is well aware of the issues and likely the next CA X9 update will address it , hopefully anyway , since it has been some time since the last one , but I suspect that is because it appears they will show X10 in Jan. at the Builder's Show. ( see chat forum ) and I am sure that is where they are focused currently.

 

The issues seem worse for those using Laptops , so I'd make sure I was using the correct version if I had a laptop, ie the notebook Driver.

 

I was using 388.71 earlier this week but didn't spend enough time in X9 to notice any errors with the Holidays, so I can't say if they are good or not?

but in my informal testing the 388 series are no faster than the 382 or especially 385.12 or 385.69 , so I am back on 385.12 currently but had used

385.69 up until trying the 388 Series.

 

Here are the direct links if you want to test them .....

 

385.69 Desktop (Sept.21)

http://www.nvidia.com/download/driverResults.aspx/123936/en-us

 

385.12 Desktop (July31)

http://www.nvidia.com/download/driverResults.aspx/121776/en-us

 

385.69 Notebook

http://www.nvidia.com/download/driverResults.aspx/123938/en-us

 

385.12 Notebook

http://www.nvidia.com/download/driverResults.aspx/121778/en-us

Share this post


Link to post
Share on other sites

UPDATE

-------------------------------------------------------------------------------------------------------------------------------------------------

Nvidia has now released v390.65 Drivers , which reportedly also deal with the Meltdown and Spectre Issues from their end too.

 

400 series to 10 Series Desktop  Driver

http://www.nvidia.com/download/driverResults.aspx/129081/en-us

 

400M -10M-Series Notebook/Laptop Driver

http://www.nvidia.com/download/driverResults.aspx/129085/en-us

 

 

edit: ***I highly recommend NOT having any Programs running (Chief included) during Installation and to always reboot afterwards

-----------------------------------------------------------------------------------------------------------------------------------------------

  • Upvote 1

Share this post


Link to post
Share on other sites

I had X9, X10 and Suite all open during the driver update. 

 

All 3 crashed.

 

Other applications -- browser, email etc were unaffected. 

Share this post


Link to post
Share on other sites

So that sounds really bad Eric,  Is it ok after rebooting or a total failure ?   Was it just a complication of having Chief open while loading the new driver ?

Share this post


Link to post
Share on other sites

I did not reboot -- usually no need. I've installed video drivers before with Chief open without problems.

 

System working fine and Chief shows the new driver is installed.

Share this post


Link to post
Share on other sites
1 hour ago, solver said:

I had X9, X10 and Suite all open during the driver update. 

 

All 3 crashed.

 

Other applications -- browser, email etc were unaffected. 

 

Any Programming running in 3D is likely to crash during installation as the Nvidia Driver is Stopped , removed , and then replaced  , so I would say this is normal behaviour , but I personally don't have any programs running during Nvidia Driver Updates and ALWAYS reboot afterwards as on my multi-monitor system everything but the main monitor goes black during the Upgrade and any open windows are also shifted to the main Monitor.

 

Because I don't want GeForce Experience or the 3D Vision Driver Stuff installed I always use the Custom Install Option with "Clean install" checked and de-select those items in the DBX too.

 

Mick.

 

 

Share this post


Link to post
Share on other sites

I saw this topic with an Nvidia update. I just downloaded 390, did a clean install, and restarted. 

 

Opened all of my 3D programs to make sure they work smoothly. They all work as they should but one. Chief still hangs when trying to close a 3D view.

 

Chief, we are looking at you and waiting for a response. Preferably a response with a fix or a patch.

Share this post


Link to post
Share on other sites

You still haven't done you Signature ,( see mine for how)  so no idea on your system specs? , but this does not happen on my systems ( both desktops )

 

I have tried many and always gone back to 382.05 but I am still testing these (390.65) here though.....

Share this post


Link to post
Share on other sites
On 1/13/2018 at 5:01 PM, Kbird1 said:

You still haven't done you Signature ,( see mine for how)  so no idea on your system specs? , but this does not happen on my systems ( both desktops )

 

I have tried many and always gone back to 382.05 but I am still testing these (390.65) here though.....

Sorry, I don't a signature. 

Share this post


Link to post
Share on other sites
7 minutes ago, SabGroup said:

Sorry, I don't a signature. 

 

No you don't but you can add one easily , telling people what version of Chief you use and your basic hardware , just most people do,  just click on your User name above in the top right hand corner.

 

eg.   go up to the top RH Corner click on your UserName>Account Settings>Signature....

Share this post


Link to post
Share on other sites

Jan.18th.....Just a quick update I have been using 390.65 for about a week on my Desktop and had no issues in Chief or other Programs so far, they are also as fast as 382.05.

Share this post


Link to post
Share on other sites
1 hour ago, Kbird1 said:

Jan.18th.....Just a quick update I have been using 390.65 for about a week on my Desktop and had no issues in Chief or other Programs so far, they are also as fast as 382.05.

me too.

Share this post


Link to post
Share on other sites

Thanks Perry , good to have some feedback on the 390.65 Drivers...

 

M.

Share this post


Link to post
Share on other sites

Hello everyone,

I just skimmed through this post coming over from another. I'm having the issue described above (running Nvidia GTX 1060) and am unable to Roll back my driver. Not sure if there is a way around this or if anyone has figured out a permanent fix. I'm also having this same issue anytime I generate an elevation and then attempt to click out of it. 

Share this post


Link to post
Share on other sites
17 minutes ago, StudConstruction said:

Hello everyone,

I just skimmed through this post coming over from another. I'm having the issue described above (running Nvidia GTX 1060) and am unable to Roll back my driver. Not sure if there is a way around this or if anyone has figured out a permanent fix. I'm also having this same issue anytime I generate an elevation and then attempt to click out of it. 

 

Nvidia just released a new driver on January 29 which is supposed to fix the issue. Try downloading driver version 390.77 as see if this solves the problem for you.

Share this post


Link to post
Share on other sites

I've been running with 390.77 for several days without issue.

Share this post


Link to post
Share on other sites
1 hour ago, StudConstruction said:

Hello everyone,

I just skimmed through this post coming over from another. I'm having the issue described above (running Nvidia GTX 1060) and am unable to Roll back my driver. Not sure if there is a way around this or if anyone has figured out a permanent fix. I'm also having this same issue anytime I generate an elevation and then attempt to click out of it. 

 

If you "Rollback" and don't disable Windows Update Driver Updates then Windows Update will replace the Driver with the Latest WHQL Driver...

 

That being said , don't "Rollback" via Device Manager just run the required/wanted Driver and do a Custom , Clean Install as mentioned above.

 

Have not tried 390.77 yet I was waiting a couple of Days to see if there were any reports here or elsewhere of Issues.

 

M.

 

 

Share this post


Link to post
Share on other sites

Thanks for all the help. I've been using 390.77 for a few hours and the issues I've been having seem to have been resolved. I'll update my post if I run into them in the next few weeks but for now, it seems to be working great! Thank you again for all the help and expertise!

 

:: UPDATE ::

I've been using Chief heavily over the weekend and today with no apparent issues. Thanks for the fix!

Edited by StudConstruction
Planned post update

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    28411
    Total Members
    9156
    Most Online
    LFDesign
    Newest Member
    LFDesign
    Joined