NeilofOZ

Ray Tracing

Recommended Posts

Need some help on the above, just not getting anything of quality, it's either milky coloured and or covered with coal dust.

 

I design shop interiors where the settings are in an open environment with plenty of light from every direction.

Am very happy with the colour tones and definitions in the " Standard View" and just require a bit more sharpness in an image sense.

Have gone through a plethora of "Ray Trace" configurations and images are worse than the "Standard Render".

 

There must be a basic set-up for Ray Tracing, that one can use on the "Standard Render View" as the options and variety of settings 

are huge in X10 and appear to overlap. I set up 11 different "RayTrace" options and every one came out as either too light, too dark, too milky. 

 

Regards, NeilofOz

     

Edited by NeilofOZ
Grammar

Share this post


Link to post
Share on other sites
2 hours ago, NeilofOZ said:

Need some help on the above, just not getting anything of quality, it's either milky coloured and or covered with coal dust

 

I

Suggest switching to Physically Based Rendering, PBR. Many have even Graham one of the RT experts. Very long thread here with lots of information 

 

Share this post


Link to post
Share on other sites

Gentlemen,

 

After going through the weekend and trying different ideas from members as suggested, still no success and from where I stand it appears that there is still a lot of confusion and understanding of the actual settings, for both for RT and PBR and being a bit further down the evolution scale with regards to CA, I have Buckleys chance of sorting this one out. To me, this element of CA seems to be a programme within a programme and require some special tutorials.   

 

It may be my hardware and graphics can't handle the programme, but i wouldn't know where to go for an opinion on this, may be someone can check out my computer specs and advise.

 

Regards, Neil.  

Edited by NeilofOZ
spacings

Share this post


Link to post
Share on other sites

It's possible the Radeon is causing Issues , have you ever updated the Drivers? CA recommend NVida Cards but the Radeon should work as long as it support OpenGL ( it does)

 

https://www.amd.com/en/support/graphics/amd-radeon-r7-series/amd-radeon-r7-300-series/amd-radeon-r7-m360

 

You are right RT in particular and PBR both require some time to learn , it is not a Push the button and Presto you have PhotoRealistic Renderings deal, but you should be able to get PBR's in particular that are "good enough".... make sure your Automatic lights is 100 and Global Illumiantion are set in the Technique and Camera Options , think I posted on about the 4th page of the Lets PBR thread about that....

 

You haven't supplied a Plan or any images to critique to hard to advise much more but in general terms....

 

Might be worth looking at this thread from friday too....at least the second page...Graham posted some nice Images there too

 

https://chieftalk.chiefarchitect.com/topic/20014-manipulating-materials-and-lighting-help/

 

Share this post


Link to post
Share on other sites

Mick,

 

Already tried what you indicated, but no progress.

 

I have two versions of a shop interior:-

The first works with PBR, but I lose the "emissive" factor and some lighting, which is essential for signage requirements.

In the second version, the whole screen turns black, so I don't know why this happens as it never has done this before.  

 

Would have to send both plans if you want.

 

Regards Neil. 

Share this post


Link to post
Share on other sites
10 hours ago, NeilofOZ said:

It may be my hardware and graphics can't handle the programme,

Your CPU has 4 cores only but clocks aren't bad, should do RT but might be a bit slow-would watch the settings. Look like your on a laptop-make sure Chief is using the Radeon card and not the Intel card-very important for PBR, but again that card is not really up there so will be a bit laggy.

10 hours ago, NeilofOZ said:

After going through the weekend and trying different ideas from members as suggested, still no success and from where I stand it appears that there is still a lot of confusion and understanding of the actual settings, for both for RT and PBR and being a bit further down the evolution scale with regards to CA, I have Buckleys chance of sorting this one out. To me, this element of CA seems to be a programme within a programme and require some special tutorials.   

IMO PBR is not all that difficult to get decent and it is the future for this program.

 PBR- Do you have a foundation, a roof? Did change number of lights and light set, adjust sunlight, edit camera settings and PBR technique options; all as suggested in thread we sent you to? Once that is done and image is satisfactory make those defaults in a template file-then only tweaking required for decent image. If you want to get as good as Kitchen Adobe (Graham), yes you have to work on details and texture.

 

Emissive, lost lights, black RT-let go find the darts and get back to you with some wild guesses:rolleyes:

 

9 hours ago, NeilofOZ said:

Would have to send both plans if you wan

It's always a good idea to at least post a screen shot of the problem and usually a plan or a paired down one and or a screenshot of settings.

Why not go back to Let's PBR, give it another go. Then post one plan and a screenshot of a  PBR in that thread instead of her

Should get you some results.

Share this post


Link to post
Share on other sites
5 hours ago, MarkMc said:

 

Emissive, lost lights, black RT-let go find the darts and get back to you with some wild guesses:rolleyes:

 

The Black Screens ( and White Screens (white-outs)) are discussed in the Lets PBR thread and were usually due to the Global Illumination setting and switching from Standard view to PBR AFTER the camera view was Shot IIRC?  it is why I mentioned to have all that setup 1st ...I now have all the Defaults setup and PBR as the Camera 1st View Technique to avoid this in my Template as Mark mentioned.

 

M.

Share this post


Link to post
Share on other sites

Spent all weekend on heaps of different configurations that were suggested in the "Thread", no luck at all and gobbled up heaps of gloss paper

and ink to see the true effects of each render, as this is another issues on comparing display & printed graphics.

The PBR still goes all black no matter what config I do, updated all my drivers last week, checked my Radeon Video card and it has been updated

but as there are two cards listed in the "Device Manager" not sure which one is operating, nothing to see that it is or isn't, need some help here.

 

Have attached 3 pics:-

Capture MT Standard Render.1 - Standard Render camera, happy with colour, tone, lighting & back-lit illumination, not 100% though.

Capture MT RayTrace.1a - exported from best raytrace result sofar, lacks colour tone & illumination of menus and logo, not acceptable. 

Capture MT RayTrace.1b - same as above, but have induced more light via the Windows photo editing programme, but not acceptable as per above.  

 

All of the above renders were done with various fixed light fittings and light sources, as the interior has no windows for sun light to influence.5bd7eece07506_MTCaptureStandardRender.1.thumb.JPG.bbfa21370532322f61f9e34d470f4cd2.JPG5bd7eee29797c_MTCaptureRayTrace_1a.thumb.jpg.1f254e272da9618c8410d461738f9a3a.jpg5bd7eeef09b8f_MTCaptureRayTrace_1b.thumb.jpg.3f6059c460a60fdaa7726153a23e3175.jpg 

 

I can survive by using exported Standard Renders, but the ultimate goal should be to maximise the programme to deliver the best possible outcome.

 

Can't really do much untill the weekend as my work load doesn't permit, takes a lot of time to do trial & errors.

 

Regards to all, Neil.   

 

 

Share this post


Link to post
Share on other sites

Am I right in saying you don't have a Model around this scene ? ie a building with a Roof,Walls and foundation? all lighting engines require these to "bounce" the light off to light the scene.

 

You seem reluctant to post the Plan???  and that is the only and best way to figure out what you have that is set incorrectly, or what other issues there maybe, ( eg the Radeon) otherwise we are only guessing and wasting time as there are just too many variables.

 

M.

Share this post


Link to post
Share on other sites
2 hours ago, NeilofOZ said:

Spent all weekend

3 variations of PBR in 10 minutes, few more to place an emmissive object-plan was already set up for PBR so just made changes to make it as bad as I could quickly.

2 hours ago, NeilofOZ said:

Have attached 3 pics:

Can you tell what the difference is between these 3 views 5bd83180453b7_3variationsin10minutes.thumb.png.a3ee80990c21d153dfefd7126894bcd5.png

Same suggestion as before-post the plan.

 

Share this post


Link to post
Share on other sites

Mic & Mark,

 

Sorry about the plan, thought I could work through this one via trial & error, but happy for you guys to see how your fair.

 

Basically a lot of my work is in shopping centres where I don't need standard walls, ceilings and roofs and I use a lot of 

solids and soffits to build the basic structure. Have enclosed the Food Outlet with invisible walls as I need to show some finishes

surrounding the outlet and thought this may simplify the sun problem by not having to compete with other internal lighting

that I choose.

 

I have a problem uploading the Plan, ( error message reads -200 ) plan only 13.6MB, need some help!!!!

 

Share this post


Link to post
Share on other sites
55 minutes ago, NeilofOZ said:

Mark, thanks for that, see plan as discussed.

 

 

MT_Tile_Version.plan

 

Can you please Do a File>BackUp Entire Plan> Back up plan and all referenced File and check To make a Zip Archive as there are 15-20 custom textures missing...

 

then attach the Zipfile.....thx.

 

Mick.

Share this post


Link to post
Share on other sites

Mick,

Problem, zip file is 40MB.

 

Opened up the file and there are many finishes that aren't associated with this plan and

I can't see a CA Floor Plan, all new to me so need some direction.

 

Neil.

Share this post


Link to post
Share on other sites
9 hours ago, NeilofOZ said:

Mick,

Problem, zip file is 40MB.

 

Opened up the file and there are many finishes that aren't associated with this plan and

I can't see a CA Floor Plan, all new to me so need some direction.

 

Neil.

 

All plans contain the Default Materials too , which are set in the Template Plan's Defaults and are there whether used in a Particular Plan or not.

 

If you backed up the file with all referenced files, the .plan should be there too but we have it already so it can be removed from the Zip and below is a pic of the missing files when I open a 3D Camera...all others can be removed from the zipfile and it can be zipped backup and posted. All we need to do then is place the Plan in the same folder as the textures and it will use them.

 

image.thumb.png.324f14e9d71e741b3394db017ac798a7.png

Share this post


Link to post
Share on other sites

Mick,

 

Thanks for sorting this out and see attached as requested, some textures were not indicated

but not too worried at this stage on the finishes, just want to see if I can get PBR to work with RT.

 

Found the CA Floor Plan, was a bit to slick with the mouse, lol.

 

Regards Neil.

 

 

 

MT_Tile_Version.back-up.zip

Share this post


Link to post
Share on other sites

Neil- YOu don't have a complete building, no foundation, no roof-all suggested in the PBR thread and any Ray Trace Thread.

There are still missing textures.

Trick with too many is go to -3D, Materials, Plan Materials, select Purge.

That might still not make the file small enough but should from the looks of it. If not you can go make a library out of the plan materials and export that (look in help)

Quickly added 4 walls, foundation and roof. took a camera view, add some light sources away and made very minor adjustments to settings. Check the settings for camera, and technique options-then "adjust lights" those are the places where you play-At this point would likely just be adjusting individual lights.

Adjust the ceiling texture too.

This is a straight PBR-all of that and writing this took me half an hour (waiting for a phone call) Note You either PBR or Ray Trace-do not try to do a ray trace from a PBR.

PBR ONLY.png

Quick_PBR.plan

Share this post


Link to post
Share on other sites
7 hours ago, NeilofOZ said:

but not too worried at this stage on the finishes, just want to see if I can get PBR to work with RT.

 

The Finishes are what reflect the light and we aren't seeing what you are because they aren't there..... for me the whole scene is "grey" except for Tomato sign which I probably have from helping you a while back. Is the Coffee Machine really Green or is something messed up on my end?

 

To my surprise I didn't even need to Unzip the Textures ZipFile and Chief found the Textures no problem , there are still 6 missing...

 

image.thumb.png.5e0d9d27d2f10958a0f1ab2781fed560.png

 

After doing the Purge as Mark suggested you can also use the 3rd Option on that same Menu to make a Plan Material Library

which can be exported (right click it) to a Zipfile too and post it instead.

 

image.thumb.png.12d0b1f2ca7c38c763698b49d5131005.png

 

 

*** As noted ..it is either / or thing.....  The Settings for PBR may not work well for RT and Vicsa Versa , in particular they handle Reflections off Materials like counter-tops differently and Light fixtures can show differently as well.

 

Your PBR Camera has none of the Suggested settings so is very dark.....and there is no Backdrop assigned which PBR uses to reflect light....try Sky3, and Reflections ( Mirrors, Chrome etc) and Shadows are turned off for all Views , and of course having no roof or foundation etc is an issue as talked about above.

 

*** Not sure Why at this point but turning OFF Global Illumination (troubleshooting Step) in Prefs>Render stopped the PBR Black Outs for me but it is almost like a STD View if you do that, even though it says it is a PBR.

 

M.

 

 

Share this post


Link to post
Share on other sites

Mick & Marc,

 

OK, lots of things came up and learning as well, so will respond in order as follows:-

- I don't setup my projects with typical foundation/walls/roof/backdrop etc, thinking that it wasn't necessary as these are

  generally not required, but are these required due to them interacting with lighting etc, let me know if this is correct.

- Have attached the Plan Materials Library as requested, hopefully this will let you evaluate the rendering much better.

- The coffee machine is green and yuk, but it's existing. 

- Not sure on PBR & RT, are you saying I should only RayTrace Standard Renders  

- Still getting blackouts on views when I use the PBR view.

- Noticed on your PBR Render that no Emissive illumination is evident, ie the Menus & logo all have values, which is necessary and critical for effects. 

- In Preferences, it shows the video card as Intel (R) HD Graphics 530, should this be the AMD Radeon (TM) R7 M360, if so how do we or should we change it. 

- As mentioned previously, am OK with Standard Renders, but was of the opinion that RayTracing would sharpen up the edges, is this not correct. 

 

At this stage i still have problems of Blackouts in render view, Emissive not being applied  

 

MT_Tile_Version_-_Plan_Mat_Lib..calibz

Share this post


Link to post
Share on other sites
3 hours ago, NeilofOZ said:

OK, lots of things came up and learning as well,

I go back to my original suggestion-got to the PBR thread, read it ALL, try some and post over there. You will get better and  more feedback but likely Mick has some time this week AFAIK.

Yes it's already been stated here and on the thread-you need a full shell, foundation and roof. Emissive-well I did not have all your textures, which is where emissive is set, but lights are relative to each other-bright lights cancel out lighter ones-again go over to that thread. AND yes RT from standard but my suggestion is switch to PBR and be done with it.

I have Nvidia card but your Radeon will have some sort of control panel- in that you set Chief to use the Radeon card.

 

Though your Intel HD530 should run PBR just slowly-that is likely a driver issue. Look for previous thread on Intel Card -I run PBR on my Spectre with an Intel card but had issues with drivers-not always the newest is best.

Share this post


Link to post
Share on other sites
10 hours ago, NeilofOZ said:

In Preferences, it shows the video card as Intel (R) HD Graphics 530, should this be the AMD Radeon (TM) R7 M360, if so how do we or should we change it. 

 

Try this for AMD , don't have one myself so can't confirm

 

https://us.answers.acer.com/app/answers/detail/a_id/46334/~/configure-amd-radeon-switchable-graphics

 

Share this post


Link to post
Share on other sites
14 hours ago, NeilofOZ said:

Mick & Marc,

 

OK, lots of things came up and learning as well, so will respond in order as follows:-

- I don't setup my projects with typical foundation/walls/roof/backdrop etc, thinking that it wasn't necessary as these are

  generally not required, but are these required due to them interacting with lighting etc, let me know if this is correct.

 

Correct

 

- Have attached the Plan Materials Library as requested, hopefully this will let you evaluate the rendering much better.

I extracted the Library into the plan Folder and now have all the textures

 

- The coffee machine is green and yuk, but it's existing.  OK

- Not sure on PBR & RT, are you saying I should only RayTrace Standard Renders

 

That is the Current Practice, yes. as Setting a View Up for PBR may mean it does not RT well

If you Use PBR as most are, you don't need Ray Trace.

 

- Still getting blackouts on views when I use the PBR view.

 

Was this Plan Started in X9 by Chance on in a X9 Template? , I seem to remember that being one of theIssues with PBR when we 1st got it in Feb/March.

 

- Noticed on your PBR Render that no Emissive illumination is evident, ie the Menus & logo all have values, which is necessary and critical for effects.

 

That's because emmisive works differently in PBR and is controlled relative to other settings like the Sun and Potlights etc, currently they are way too bright and blow out the fact that there is actually text in that top part of the sign. at 0.4 I can read them but not at 2.0-3.0 but currently there are no walls , Roof, Foundation etc. the foundation plays a big part in PBR at to me.

 

- In Preferences, it shows the video card as Intel (R) HD Graphics 530, should this be the AMD Radeon (TM) R7 M360, if so how do we or should we change it.

See Previous Post

 

14 hours ago, NeilofOZ said:

- As mentioned previously, am OK with Standard Renders, but was of the opinion that RayTracing would sharpen up the edges, is this not correct. 

It is but , it takes time to learn and practice as does PBR and with PBR being almost instant , most have switched to it as it is "good enough"

 

14 hours ago, NeilofOZ said:

 

At this stage i still have problems of Blackouts in render view, Emissive not being applied  

 As above

 

 

 

Mick.

 

.

Share this post


Link to post
Share on other sites

I took a look at this one and made a number of adjustments to align PBR & Ray Tracing. Nothing is changed other than the rendering method. You can see that there are some minor differences in the lighting, stainless steel and the Ray Trace version seems to better resolve some of the finer details. The really big difference is that the PBR took 4 seconds to render while the Ray Trace took 41 minutes.

 

PBR

1112981247_Untitled4PBRcopy.thumb.jpg.9dec849e3cd1ee3da3603c3fccd7f8b4.jpg

 

Ray Trace

1199042146_Untitled3RTcopy.thumb.jpg.fa4dc61c86751f7aba53955b13829113.jpg

  • Upvote 1

Share this post


Link to post
Share on other sites
1 hour ago, TheKitchenAbode said:

...The really big difference is that the PBR took 4 seconds to render while the Ray Trace took 41 minutes.

 

PBR

1112981247_Untitled4PBRcopy.thumb.jpg.9dec849e3cd1ee3da3603c3fccd7f8b4.jpg

 

Ray Trace

1199042146_Untitled3RTcopy.thumb.jpg.fa4dc61c86751f7aba53955b13829113.jpg

That being said I think the Ray Trace is far superior.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27478
    Total Members
    6254
    Most Online
    Oilersfan20
    Newest Member
    Oilersfan20
    Joined