ACADuser

Offset Angle Restrictions?

Recommended Posts

Sorry i did not search the manual for this one but when I offset a line I use for elevations it sometimes strays off 90 deg.

I have the angle snaps on but it will still snap off 90 deg when I drag to offset. How can I lock the angle?

 

 

Share this post


Link to post
Share on other sites

It might be snapping to some other object or point.  I think you would normally want it to do that but you can always turn off object snaps.

Share this post


Link to post
Share on other sites

Sorry i did not search the manual for this one but when I offset a line I use for elevations it sometimes strays off 90 deg.

I have the angle snaps on but it will still snap off 90 deg when I drag to offset. How can I lock the angle?

 

Can you possibly be a little more specific?  Not sure I understand the issue.  Does the line move so that it is oriented at a 90 degree angle to where it was before or is it moving 90 degrees from where you want it to move, or...?  And what technique are you using to "offset"? 

Share this post


Link to post
Share on other sites

Alan,

 

I think I know what you mean.

When you try and drag a line, you can move it perpendicular to the original, BUT it can also slide along it's length at other than perpendicular to the line.

I assume that the line is not changing it's angle.

 

This behavior is controlled by Preferences...Edit,,,Behaviors...Primary Movement Method.

 

I bet yours is set to Polar - this will allow you to drag along angle snaps.

Change it to Orthogonal.

You will now only be allowed to drag the line in a perpendicular direction, it will not be able to slide along the Allowed Angles.

Share this post


Link to post
Share on other sites

Thanks for the replies.

See attached

OK when I do a short offset as in the picture 16" up for the next line my mouse can slide off to the right in this case enough to make Chief think I want something other than 90 deg.

I think I have the setting correct, see attached.

 

Just seems like I could hold CTRL or SHIFT  to force exact Ortho but that isn't the procedure, what is the way to force Ortho only?

post-2435-0-10682300-1453866021_thumb.png

post-2435-0-29371400-1453866040_thumb.png

Share this post


Link to post
Share on other sites

Alan,

 

The way I told you is to force exact ortho.

 

With that setting set to Orthogonal the object will only move perpendicular to itself. 

Just ignore the fact that the cursor can slide horizontally - it makes no difference to the movement of the object, the line will still only move perpendicular to itself and it will not slide sideways.

Chief will not think that you want something other than 90 deg!

 

If you select Polar and drag the line, it will stay parallel to itself, BUT, you can also drag sideways to displace the line that way as well as perpendicular.

 

Have a play with both settings and note the difference.

I will do a vid.

 

http://screencast.com/t/ADn7qnRXPd

Share this post


Link to post
Share on other sites

Hey, were are waking up here in Florida. :)

 

Great video glenn, very informative.

The problem I have is with the "Multiple Copy" command, sorry I call it the ARRAY command! Set the distance short to say floor framing thickness (16" on my system)

I have Ortho ON. Joe I did not see where to set SNAPS angle to 90.

 

Try the "Multiple Copy"

Share this post


Link to post
Share on other sites

I personally don't seem to have the problem you're describing.  A few ideas though...

 

-Is it possible you're inadvertently snapping to something thereby causing the behavior?

 

-Try using the circular edit handle to create your multiple copies.  It will force you to move those copies in a path perfectly perpendicular to the original line. post-46-0-02527900-1453921762_thumb.png

 

-You can always hit tab during your move to make sure you're not veering off course. 

Share this post


Link to post
Share on other sites

Michael you unraveled the mystery. :)

 

The Square grip is in view when I am zoomed in and near the end of the horizontal line. The round grip is out of screen as the line is some 40 to 60 feet long.

Wonder why the round grip is not on screen. The square grip shows the Multiple Copy cursor when you go to grip it.

But when I use the round grip all is well. The square grip works only if you keep the mouse lined up.

Thanks for your time.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27602
    Total Members
    6254
    Most Online
    Floriance
    Newest Member
    Floriance
    Joined