ChristinoDesign

PBR Object specific lighting render issue?

Recommended Posts

Just finished a plan and starting taking my PBR shots, I'm getting a strange washed-out reflection/highlight on one specific wall and two windows in my living room that are rendering out different than the rest of the room. Materials don't seem to be any different than the rest of the walls or room trims, and I've tried to delete the objects and redraw them getting the same results. Anyone come across something like this before? I attached the PBR views, the walls and windows in question look bright yellow. There is a standard view for comparison.

Thanks

Floor plan.JPG

PBR view 2 (2).JPG

PBR view 2 (1).JPG

Standard view 1.JPG

Share this post


Link to post
Share on other sites
40 minutes ago, ChristinoDesign said:

Anyone come across something like this before? I attached the PBR views, the walls and windows in question look bright yellow

This can be caused by the general color tone of the backdrop, the sunlight, and other lights. You may not want to change your backdrop so a few options to correct this would be:

  • reduce the sunlight intensity (try 1500)
  • change the sunlight color (try medium gray...experiment)
  • PBR technique options...slightly adjust hue
  • consider adding interior lights 
  • use a light set specifically for that camera

Share this post


Link to post
Share on other sites
13 minutes ago, robdyck said:

This can be caused by the general color tone of the backdrop, the sunlight, and other lights. You may not want to change your backdrop so a few options to correct this would be:

  • reduce the sunlight intensity (try 1500)
  • change the sunlight color (try medium gray...experiment)
  • PBR technique options...slightly adjust hue
  • consider adding interior lights 
  • use a light set specifically for that camera

 

Thanks for the feedback! This affect seems to happen no matter the backdrop, sunlight color, or intensity. Adding lights did helped some, but it's been a real trick to minimize the yellow.

Share this post


Link to post
Share on other sites
3 minutes ago, ChristinoDesign said:

 

Thanks for the feedback! This affect seems to happen no matter the backdrop, sunlight color, or intensity. Adding lights did helped some, but it's been a real trick to minimize the yellow.

If you post your plan, I will see if I can offer any other suggestions.

Share this post


Link to post
Share on other sites

Just a wild guess, the flames in the fireplace, do they have an emissive setting, if so set it to zero.

Share this post


Link to post
Share on other sites

Is this closer to what you have in mind?

Untitled 1.jpg

Share this post


Link to post
Share on other sites
11 hours ago, robdyck said:

Is this closer to what you have in mind?

Untitled 1.jpg

Emissive issue still exists, can see it in the trim.
Too many problems with this particular plan to list. Something in defaults I would guess. Sometimes bringing the model to 0,0 will fix it but that only fixes the window trim. All through the house is an emissivity issue. Even in the 3d preview window the walls are black. You can delete wall by wall in this plan and the issue will bounce around to a new location. Consider starting from a new template if this issue carries into new plans. Could be a really difficult time to locate the culrpit. Turn off all lights and sun and the issue still exists. Which would typically point to a material issue.

Share this post


Link to post
Share on other sites
10 hours ago, Renerabbitt said:

Emissive issue still exists, can see it in the trim.
Too many problems with this particular plan to list. Something in defaults I would guess. Sometimes bringing the model to 0,0 will fix it but that only fixes the window trim. All through the house is an emissivity issue. Even in the 3d preview window the walls are black. You can delete wall by wall in this plan and the issue will bounce around to a new location. Consider starting from a new template if this issue carries into new plans. Could be a really difficult time to locate the culrpit. Turn off all lights and sun and the issue still exists. Which would typically point to a material issue.

 

Agree, took a look and just changing things like the sun or lighting does not resolve the issue, just makes it less obvious depending upon those settings. The glowing interior wall opposing the fireplace with the two door openings is for some reason being lit wrong due to some improper connection at the top, if I pull it down so it does not touch the tray ceiling then it renders correctly. Not certain why the two windows on the fireplace wall and the mantel are rendering incorrectly, have had similar issues with windows when using those blinds, but in this case removing the blind did not resolve it. Also noticed the fact that in the 3D preview window some of the previews show the wall finish as black even though the material states the finish as say drywall, something amiss here. There are other things such as different room heights and interior wall types used as exterior walls, difficult to say what if any impact this may have but it makes it very time consuming to correct all of these during the elimination process. Will take another look at it today.

  • Like 1

Share this post


Link to post
Share on other sites
11 hours ago, Renerabbitt said:

Which would typically point to a material issue.

Yup. I adjusted that material after, and several others and still couldn't get everything copacetic. This was the best I could do in the time I had available.

1590941860_Untitled7.thumb.jpg.a784f74f8dd7016a94403d6facacaac3.jpg617294714_Untitled4.thumb.jpg.071a867a250ffe6b2d16cf5f86c3229b.jpg

Share this post


Link to post
Share on other sites

Here is the solution, not sure why but the Tray Ceiling needs to be set to Recess into Ceiling, that solves the glowing wall opposing the fireplace. For the fireplace mantel change one of the walls being used for the fireplace to No Room Definition. After those two changes things seem to render as expected.

Share this post


Link to post
Share on other sites
2 hours ago, TheKitchenAbode said:

Here is the solution, not sure why but the Tray Ceiling needs to be set to Recess into Ceiling, that solves the glowing wall opposing the fireplace. For the fireplace mantel change one of the walls being used for the fireplace to No Room Definition. After those two changes things seem to render as expected.

I think I had solved for the fireplace mantle by relocating everything back to 0,0. Can't remember. definitely some funny things going on with that plan though.

  • Like 1

Share this post


Link to post
Share on other sites

Sorry for the delayed response - but thank you for taking the time to check over the plan! I do think there is something off with the template plan we had been using, and haven't been able to pinpoint it. I've since recreated a new template for us to use moving forward.

I really appreciate all the feedback!

Share this post


Link to post
Share on other sites
39 minutes ago, ChristinoDesign said:

I do think there is something off with the template plan we had been using, and haven't been able to pinpoint it.

 

Not certain there is anything fundamentally wrong with your template as I was able to replicate the issue here using a new plan with just a simple room with a tray ceiling and a separate room for the fireplace.

Share this post


Link to post
Share on other sites
37 minutes ago, dskogg said:

I am having the same problem with walls in this entry ...I am modeling an existing plan for an interior designer.

 

skogg pbr plan.plan

 

The sun intensity is way too high. Turn it down to 100 lux and it PBR's just fine.

Share this post


Link to post
Share on other sites
5 hours ago, dskogg said:

I am having the same problem with walls in this entry ...I am modeling an existing plan for an interior designer.

 

skogg pbr plan.plan

The almost free Twinmotion will solve PBR woes.

SKOGGS_001.png

  • Upvote 1

Share this post


Link to post
Share on other sites
On 9/15/2020 at 5:22 PM, TheKitchenAbode said:

 

The sun intensity is way too high. Turn it down to 100 lux and it PBR's just fine.

I turned it down to 1500 and it didn’t help.. 100 ? That is really low.. seems like pbr has issues still

Share this post


Link to post
Share on other sites
22 minutes ago, dskogg said:

I turned it down to 1500 and it didn’t help.. 100 ? That is really low.. seems like pbr has issues still

 

Why is 100 low, just adjust the camera exposure and brightness to get the look you want.

Share this post


Link to post
Share on other sites
5 hours ago, TheKitchenAbode said:

 

Why is 100 low, just adjust the camera exposure and brightness to get the look you want.

well it works and stops the walls from glowing but it is dark looking outside...so not the way it is supposed to work, don't you agree?

100 sun setting pbr.jpg

morning sun pbr.jpg

Share this post


Link to post
Share on other sites
17 minutes ago, dskogg said:

well it works and stops the walls from glowing but it is dark looking outside...so not the way it is supposed to work, don't you agree?

 

 

Something is messed up with your cameras...the backdrop isn't showing. The backdrop, sun angle and sun color will drastically change your images. Open, the camera, move it outside, and with the library browser open, swap out a different backdrop. Just select one in the library, move the pointer to the camera and with one click it'll swap out.

Then, with your camera in its final position, change the sun angle and direction so some sunlight comes through the windows. 

Turn the shadows off for the 2 chandeliers.

Change the drop off rate for the recessed lighting to 12 or 15 for a less harsh effect on the wall.

1500 is my favorite sunlight lumen setting.

 

Share this post


Link to post
Share on other sites
12 minutes ago, dskogg said:

well it works and stops the walls from glowing but it is dark looking outside...so not the way it is supposed to work, don't you agree?

 

I have not looked at the things in your plan to see if something is wrong there. Check to make sure your glass is correct, do you have the "use backdrop" checked in the PBR DBX?

 

Your wall can glow bright if it is not contained within the room. Check to make certain the no part of the wall penetrates into the attic or into an exterior wall cavity.

 

I have used PBR extensively and have never had these types of issues.

Share this post


Link to post
Share on other sites

David - took another look at your plan. There are a lot of things, especially with the roof were connections are not proper. With PBR it is critical that everything be properly enclosed or you will encounter some odd things.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    28278
    Total Members
    6254
    Most Online
    ChiefPerry
    Newest Member
    ChiefPerry
    Joined