KittleDesign

Copy and Paste from one plan to another?

Recommended Posts

Am I missing something?  I swear I used to be able to go into an old plan and copy items (specifically posts, beams, korbels, pillars, etc.) that I have already drawn and then paste them into the new drawing that I am working on, without having to recreate them all over again.  I'm not going crazy, you used to be able to do that, right?  Is that option really not available anymore or am I just doing it wrong?

 

I guess I could block them and add them to my user library but that is not as quick and as easy as just doing a copy and paste.

Share this post


Link to post
Share on other sites
1 minute ago, KittleDesign said:

Am I missing something?  I swear I used to be able to go into an old plan and copy items (specifically posts, beams, korbels, pillars, etc.) that I have already drawn and then paste them into the new drawing that I am working on, without having to recreate them all over again.  I'm not going crazy, you used to be able to do that, right?  Is that option really not available anymore or am I just doing it wrong?

 

I guess I could block them and add them to my user library but that is not as quick and as easy as just doing a copy and paste.

 

I am glad you asked this.  The answer is yes you can,  however,  I have run into this once in a while when it does not work.

 

Close the program and reopen and it should work.

 

I cannot explain it.

  • Upvote 2

Share this post


Link to post
Share on other sites

They might be pasting in to a layer that's turned off? Not sure why anyone would ever want to do that but Chief behaves like that so after pasting item and before hitting enter open the item and select the layer you want to paste it to. I know it sounds dumb but sometimes it works.

Share this post


Link to post
Share on other sites

As long as you are not copying to a previous version it should work as always.

Share this post


Link to post
Share on other sites

dshall, thanks!  That solved it, just shut the program down and reload it and it copy and pasted just fine, as normal.  I thought maybe it had something to do with the program update that I did this morning.  I guess I should have done that before beating my head against the wall for the last half an hour.  Thanks for the help!

Share this post


Link to post
Share on other sites

I've run into this with Chief and also with LibreOffice. I have the impression that it happens more often when copying from one monitor to another but that may be hogwash.

Anyway, I got hold of a little script to clear the clipboard which usually works, though sometimes saving helps, or both save then clear-finally copy and paste.

 

Made a shortcut on the desktop, placed this in Target

  %windir%\System32\cmd.exe /c echo off | clip

Run in

%windir%

 

Then set a shortcut key for it.

 

Added- the shortcut key doesn't work until you reboot. Not much happens on the screen, slight lag, then a little blip on one side.

 

Clear Clipboard.png

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    28281
    Total Members
    6254
    Most Online
    New2Chief
    Newest Member
    New2Chief
    Joined