ACADuser

Dynamic Linetype Scale View On/Off Switch?

Recommended Posts

Some time back I turned off the Dimension Dynamic Scale feature & forgot where that is.

But now I want to stop the dynamic scale of line type display in plan & elevations.

I prefer the line type display fixed so there are no surprises when printing.

Anyone know where that setting is?

 

Share this post


Link to post
Share on other sites

Alan,  I believe it is in Preferences>Appearance and I have all three settings at 0 pixels but I wish they would go to something "-" to give more control. 

Share this post


Link to post
Share on other sites

This is my setting but the line types still change while zooming in section view.

CA Lineweight.JPG

Share this post


Link to post
Share on other sites


Yes that is what I have as well and wish there was even more control but 0 seems to be the limit.

Share this post


Link to post
Share on other sites

Try toggling the tool for showing line weights.  This tool also affects the line style display. 

Share this post


Link to post
Share on other sites

Thanks but I want a permanent solution.

I do not want full time display of line weights but I do want full time display of line type in all views.

 

Share this post


Link to post
Share on other sites
12 minutes ago, ACADuser said:

Thanks but I want a permanent solution.

I do not want full time display of line weights but I do want full time display of line type in all views.

 

 

Are you saying you want the line weights displayed correctly but NOT other things like dimension text etc scaling?  If thats what you are saying then hell yes I would like to do that as well.

Share this post


Link to post
Share on other sites

I don't want line weights displayed but I do want the line type displayed correctly.

Personally I don't like the dynamic dimension size or the dynamic line type display.

I just want to know how can I turn this FEATURE OFF? :)

 

 

Share this post


Link to post
Share on other sites

You can do what you want with layer sets.

Leave line weights toggled on.

Create a new layerset (Copy an existing one), select all the layers and give them a line weight of 1.

As long as your line styles are set to by layer, you will get the static line types when zooming with all line weights displaying as 1.

If you need to see line weights (with static scaling), change your layer set.

 

 

Share this post


Link to post
Share on other sites

"I don't want line weights displayed but I do want the line type displayed correctly."

 

As far as I know, the only way to show the line style the way that it will actually print is to either turn on Line Weights or Print Preview. What is surprising to me is that, as far as I know, no one has ever asked for this even though it seems like this might be a good way to work.  Glenn's work around of setting up a layer set with all your line weights set to 1 would probably work for you but I doubt you would want to use this layer set when printing or sending to layout.

 

Regarding dimension and label sizes, the preference settings shown in the 3rd post will let you specify a minimum size for your dimensions and labels shown on the screen.  This allows you to zoom way out and still be able to see and modify your dimensions which can be very useful.  What might not be so obvious is that there is also a maximum size for dimensions shown on the screen.  This is useful for when you zoom way in so that you can still use your dimensions.  I don't think there is a way to modify the max size or turn it off unless you are in Print Preview mode.

 

If you would like the program to work differently, then you should probably send in an actual feature request.

 

 

Share this post


Link to post
Share on other sites

I guess that working with static line types & dimension sizes for 20 years has me set in my ways.

When I see a line type that doesn't look correct I think I need to fix that. But wait it was the Zoom that was tricking me.

When I zoom out the dimension look wonky. I don't need or want that feature but can't turn it off.

 

Yes I will put in a feature request & with a vote of one we'll see how long it takes to implement it. :)

 

Seriously though there are several other things I would like to see fixed/changed before the line type issue.

 

I realize i am only one voice and other users have learned to use the software "as is" so I have little hope of real change.

 

 

 

Share this post


Link to post
Share on other sites
6 minutes ago, ACADuser said:

When I zoom out the dimension look wonky. I don't need or want that feature but can't turn it off.

What does "look wonky" mean.

Doesn't setting Minimum Display Size to zero fix that?

 

I would support a request to separate Minimum Display Weight and line type scaling - they should not be linked as they are 2 completely different parameters.

  • Upvote 2

Share this post


Link to post
Share on other sites
45 minutes ago, glennw said:

I would support a request to separate Minimum Display Weight and line type scaling - they should not be linked as they are 2 completely different parameters.

 

100% agree

Share this post


Link to post
Share on other sites
1 hour ago, ACADuser said:

I realize i am only one voice and other users have learned to use the software "as is" so I have little hope of real change.

 

I am not so sure you are alone in this one Alan.  Sometimes I get so disoriented that I wish I could just turn off all the automatic adjustments so that it would be the same as zooming in and out on a PDF.   I am not sure anyone really wants to zoom in to check a detail only to have the dimension to cover it up as you get close enough to see it.  And yes dimensions can be turned off but sometimes you actually need them.  I am sure there are many who don't even understand what is going on.

Share this post


Link to post
Share on other sites
3 minutes ago, Chopsaw said:

I am sure there are many who don't even understand what is going on.

 

A couple of images sure would help us novices. Might lead to more up votes.

Share this post


Link to post
Share on other sites

That looks like it is caused by the effect of screen resolution and has nothing to do with the line weight or line scaling discussed.

Is this a separate issue than the one we have been discussing?

Because the line is so close to horizontal it is "jumping" to the next pixel row- sometimes called "jaggies".

Can you increase screen resolution?

 

There are a couple of settings that MAY have an effect on this - but I am only guessing.

In the camera dbx (also in 3D...Camera View Options), there is a setting for Edge Smoothing When Idle. Note that this setting is view specific.

Check that and see if it does anything.

There is a Hardware Edge Smoothing setting in Preferences...Render.

Try setting that to High.

 

Or maybe Dermot can chime in and tell us in more detail if these setting should have any effect at all - because I am not sure.

 

Share this post


Link to post
Share on other sites

Zoom in and the line dash & gap are 7"

Zoom out & the gap & dash grow.

 

LT7.JPG

LT24.JPG

Share this post


Link to post
Share on other sites

And when you set the display to Show Line Weights this is what you see.

So none of the previous displays give you any clue as to what the print result will be.

Personally I want to see line types as the print all the time but can't without line weights.

 

LTprint.JPG

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27991
    Total Members
    6254
    Most Online
    KPawlyshyn
    Newest Member
    KPawlyshyn
    Joined