dshall

How do I get no "white" back ground

Recommended Posts

sEe pic,  if I take a camera view,  I get a default white background,  I want no background at all.  It seems to me that there is now a setting that will only give us the building,  and any area around building is "transparent"

 

Does anybody remember how to do this?

 

I am trying to create a building camera view on top of the actual picture without using PS.

 

 

post-50-0-91621400-1478085838_thumb.png

Share this post


Link to post
Share on other sites

There is this option:

 

post-95-0-33279900-1478090398_thumb.png

 

when saving the image, but I can't get it to work. Every picture I export with this option checked still yields a background. The Reference Manual provides no insight.

Share this post


Link to post
Share on other sites

Open the Image dbx and set the Transparency.  The Image does need to be a png and you might need to adjust the "Tolerance".

Share this post


Link to post
Share on other sites

There is this option:

 

attachicon.gifbackground.PNG

 

when saving the image, but I can't get it to work. Every picture I export with this option checked still yields a background. The Reference Manual provides no insight.

That option simply sets the export to be a png (which can have transparency). 

 

After importing the Image you have to open its dbx and select the color that you want to be transparent.  Any color in the image can be selected as the one and you can adjust the "Tolerance" for how close a pixel needs to be to that color to be considered transparent.

 

Note:  Areas defined as "Transparent" in the Image originally (from PS, etc) will still be transparent.  Images exported from Chief do not have any such areas, so you have to make adjustments.

Share this post


Link to post
Share on other sites

Joe,

 

Perhaps I mistunderstood Scott's question. I assumed he is referring to EXPORTING, not importing.

 

According to the Reference Manual:

 

post-95-0-37313900-1478094140_thumb.png

 

To me this implies that when exporting an image from a camera view the background should be transparent (and I'm assuming a backdrop is NOT an object and should therefore not be exported).

Share this post


Link to post
Share on other sites

Robert, I don't think you misunderstood.  It's just that the Chief "Export Image" doesn't know what area you want to be considered transparent.  It simply allows for that.  The "Backdrop" isn't exported - just left as a white area in the Image.

Share this post


Link to post
Share on other sites

Robert, I don't think you misunderstood.  It's just that the Chief "Export Image" doesn't know what area you want to be considered transparent.  It simply allows for that.  The "Backdrop" isn't exported - just left as a white area in the Image.

 

Not according to all of my experimentation. Try it yourself. Export an image with a backdrop and the checkbox selected, and you'll still get the backdrop. The Reference Manual clearly states: "Check Transparent Background to produce alpha transparency in the spaces between objects that can be seen in the current view." Doesn't that imply that Chief must "know" what an object is, and which objects are in the current view?

Share this post


Link to post
Share on other sites

Not according to all of my experimentation. Try it yourself. Export an image with a backdrop and the checkbox selected, and you'll still get the backdrop. The Reference Manual clearly states: "Check Transparent Background to produce alpha transparency in the spaces between objects that can be seen in the current view." Doesn't that imply that Chief must "know" what an object is, and which objects are in the current view?

The tool clearly states that "Transparent Background" doesn't apply when a "Backdrop" is present.  Take a look at the small print next to that checkbox.

Share this post


Link to post
Share on other sites

Scott,

 

I tested this out and thought at first that I couldn't get a transparent background to work for 3D views but I was mistaken.  If you remove the backdrop and check Transparent Background during the export it works just fine.  I was originally testing with an app that wasn't properly handling the transparent background.  I tested again in layout and it works perfectly. 

Share this post


Link to post
Share on other sites

The tool clearly states that "Transparent Background" doesn't apply when a "Backdrop" is present.  Take a look at the small print next to that checkbox.

Joe,

 

Are we talking about this dbx?

 

post-95-0-13377800-1478099800_thumb.png

 

Because I don't see any fine print. Maybe we're referring to different export methods?

Share this post


Link to post
Share on other sites

So, this is rather annoying.  The background transparency for pictures exported from 3D views works in LAYOUT but not in any other apps I tested it in. Transparent background for pictures exported from plan views works just fine in all apps.  

Share this post


Link to post
Share on other sites

Scott,

 

I tested this out and thought at first that I couldn't get a transparent background to work for 3D views but I was mistaken.  If you remove the backdrop and check Transparent Background during the export it works just fine.  I was originally testing with an app that wasn't properly handling the transparent background.  I tested again in layout and it works perfectly. 

 

Not for me. Even with no backdrop I get a white background. Importing into GIMP demonstrates that no alpha transparency is present:

 

post-95-0-51358400-1478100503_thumb.png

 

This is what I would expect to see using Chief's export with Transparent Background:

 

post-95-0-53262900-1478100613_thumb.png

 

Maybe my expectations are wrong, or I simply don't understand the intent (or functionality) of the option.

Share this post


Link to post
Share on other sites

Not for me. Even with no backdrop I get a white background. Importing into GIMP demonstrates that no alpha transparency is present:

 

attachicon.gifgimp.PNG

 

This is what I would expect to see using Chief's export with Transparent Background:

 

attachicon.giftrans.PNG

 

Maybe my expectations are wrong, or I simply don't understand the intent (or functionality) of the option.

 

My mistake.  I had 2 views overlapped and it was the view sent to layout that appeared to have the transparent background.  The exported image was in the background. 

 

Sorry for the confusion but here are my conclusions...

 

-Images exported from 3D views will not have a transparent background no matter what you do in Chief.

-Images exported from plan views will have a proper transparent background as long as you put a check in the box.

-You CAN get a transparent background for 3D views in layout but NOT using the export tools.  To get a transparent background simply send a 3D view to layout with the background turned off. 

Share this post


Link to post
Share on other sites

Scott, I was working with this in a related problem and discovered that this functionality was lost with X8 and I had to go back to X7 to do my work and then import into X8. I was trying to make a transparent image in an elevation view and found that in X8 it only works in plan view. However I did not realize that this was a lost functionality in 3D views until now, and have not reported that to tech support.

 

If you have a moment please go back to X7 and see if it works the way you remember and I think you will be pleasantly surprised. No need to even remove backdrop. But then we must be sure this is restored for X9

post-4797-0-57771200-1478108154_thumb.jpg

Share this post


Link to post
Share on other sites

Thanks Chop,  I cannot go back to X7.....  I have moved on,  but thanks for heads up,  I will report to the muckity mucks.

Share this post


Link to post
Share on other sites

I know it is impossible to take a plan file backwards, but do you not keep a copy for testing and research ?

Share this post


Link to post
Share on other sites

I know it is impossible to take a plan file backwards, but do you not keep a copy for testing and research ?

 

NO

Share this post


Link to post
Share on other sites

CA is aware of the problem,  and they are working on it.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27865
    Total Members
    6254
    Most Online
    RichRidgewood
    Newest Member
    RichRidgewood
    Joined