Sign in to follow this  
Garreth

shadows

Recommended Posts

Hi All not sure why but I can't seem to get the elevation or 3d camera view to show shadow.

(In vector mode)

Have played around with shadow toolbar toggle turning on and off but no visual changes.

Checked north point and shadow angle on.

not sure what is going on here,

any thoughts

Share this post


Link to post
Share on other sites

Please post the plan file.

Share this post


Link to post
Share on other sites

When a camera view is open or active there is an icon for that camera view called "Edit Active Camera" where for that camera view, you can select shadows and other attributes. There is also "Edit - Default Settings - Cameras" dialogs were such attributes can be set per camera type.

 

DJP

Share this post


Link to post
Share on other sites

So many different things can cause this:

 - shadows can be turned off either through the camera dialog or through the toggle shadows toolbar button (or hot key).

 - shadows can be turned off and on for each camera view now.  In prior versions, you could only modify them for all cameras.  you may be trying to turn them on in your default camera and this will only affect any new camera views but not any that you already have.

 - the sun can be turned off or your default sun could be messed up or your sun angle you are using could be messed up.

 - you may have messed up your preferences by turning off "Use Enhanced Lighting" (there is a reason why this section is called "troubleshooting" and you really shouldn't change these settings unless working with tech support to diagnose video card issues.)

 - you could be having video card or driver issues.

 

Also, I really hope you are not still using the X10 Beta like it says in your signature.  If you are not using the latest update for X10, then all bets are off.

 

You could post your plan and someone might be able to narrow this list down for you.  If all else fails, you should contact tech support.

 

 

Share this post


Link to post
Share on other sites

I am having the same issue with shadows. I have checked every setting I can. They've worked since I've upgraded to CA10 and I haven't changed anything. No, I am not using the Beta version. I'm not sure if there is a setting I am overlooking, I know some of the menus have changed since the upgrade, or if it's something to do with my video card. 

 

This is a drawing I am working on now. I have erased all of the CAD details, dimensions and text only to reduce the file size. The shadows do not work in any file that I open up.

R-2577-1_Shadows_Test.plan

Share this post


Link to post
Share on other sites

Shadows show in all views.

 

ct1.thumb.jpg.d615dce926f48eef109d1cf076292663.jpg

Share this post


Link to post
Share on other sites

Odd that I changed no settings and the shadows were there.

Share this post


Link to post
Share on other sites
5 minutes ago, solver said:

Odd that I changed no settings and the shadows were there.

 

Yes that is strange indeed as Plan Defaults should control that as David just explained in his video.

 

And David, you now have me totally confused about Preferences.  I thought they were program wide and were not controlled by any one imported plan file.  My understanding would be that you are using Kansas sun settings ?

Share this post


Link to post
Share on other sites
8 minutes ago, Chopsaw said:

My understanding would be that you are using Kansas sun settings ?

Nope, Central Texas is where I live and where my settings are set to. I just checked his plan's Preferences out of curiosity since Dermot mentioned them earlier on this Shadows thread (no one was more surprised than myself, I assure you). I was just trying to be thorough in my check over.

 

DJP

Share this post


Link to post
Share on other sites
28 minutes ago, DavidJPotter said:

Nope, Central Texas is where I live and where my settings are set to. I just checked his plan's Preferences out of curiosity

 

Ok then something is broken for sure because you can't access someone else's Preferences as far as I know.

 

Just downloaded and opened dbocholz's plan file and it had no effect on my preset sun settings in Preferences.

 

I do appreciate your detailed video but just want to clear up that one issue if possible.

 

That was one troubleshooting technique that I thought could be depended on to determine if a glitch was caused by Preferences or not by loading a plan file onto another machine with a potentially different set of Preferences.

Share this post


Link to post
Share on other sites
5 minutes ago, DavidJPotter said:

I do not know, I reported what I saw, that is it.

 

Maybe you could check your sun settings in Preferences on one of your own plans and we would know the answer.

Share this post


Link to post
Share on other sites

Man, you are persistent Chop! It was my own settings that were off, not his. I think I had a project in Kansas a while back and then did not reset for Austin. Any way, it is corrected now. Thank you, I guess :)

 

DJP

  • Upvote 1

Share this post


Link to post
Share on other sites

I opened one of the saved elevation cameras in the dbucholz plan and the shadows were turned off.  They looked fine when I turned them on in the camera specification dialog (not the camera defaults dialog).  Turning them on in the camera defaults will only affect new cameras.  Shadows in X10 are camera specific now and not for the whole plan like they were in prior versions and this may be what is confusing some people.  If they are not showing for dbucholz then either he did not turn them on correctly or he is having some kind of machine specific problem (like he mucked with his preferences or is having video card issues).  In either case, there does not appear to be anything obviously wrong with the plan.

 

Just for clarification, preferences are always machine specific and they are not stored in your plans.  You can even have different preferences for different user accounts on the same machine.

 

Still haven't heard back from the original poster to see if he resolved his problems.

Share this post


Link to post
Share on other sites

I noticed the same thing when I looked at his file, most camera types, shadows were off, only two or three camera types were on for shadows.

 

DJP

Share this post


Link to post
Share on other sites
Quote

 

I opened one of the saved elevation cameras in the dbucholz plan and the shadows were turned off.  They looked fine when I turned them on in the camera specification dialog (not the camera defaults dialog).  Turning them on in the camera defaults will only affect new cameras.  Shadows in X10 are camera specific now and not for the whole plan like they were in prior versions and this may be what is confusing some people.  If they are not showing for dbucholz then either he did not turn them on correctly or he is having some kind of machine specific problem (like he mucked with his preferences or is having video card issues).  In either case, there does not appear to be anything obviously wrong with the plan.

 

 

I opened your Elevation 01 camera dialog and turned on the shadows and they looked fine to me.  So the comments I made to dbucholz above would apply to your case too.

Share this post


Link to post
Share on other sites
7 hours ago, Garreth said:

Thanks all and Dermott,

apologies haven't updated my profile from X10 Beta is X10 is current.

I will apply some of the advice and get back to you.

here is a copy of the plan file

ELDO 28 Anchorage Dr PROP floor plan BP REV A.plan

 

Garreth, thanks for this thread.  I was having some of the same issues.

Now I have shadows turned on, by making sure to select
In Preferences; Render, Use Enhanced Lighting

 

 

Shadows Turned On.JPG

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

  • Member Statistics

    28281
    Total Members
    6254
    Most Online
    New2Chief
    Newest Member
    New2Chief
    Joined