Rusty7

Spell Check ignores words in ALL CAPS

Recommended Posts

I'm using X7 on an iMac, running El Capitan as of this morning. How can I get Chief to spell check words that are in all caps? Most programs have an option, but I can't find it for the life of me. Thanks!

Share this post


Link to post
Share on other sites

It's more of a Mac issue, I think. It didn't work with the last OSx either.

Share this post


Link to post
Share on other sites

Yes, I know. It works fine on PC. What I'm looking for is a solution for Mac.

Share this post


Link to post
Share on other sites

I'd switch to using iCaps instead - that will probably work.

  • Upvote 1

Share this post


Link to post
Share on other sites

Rusty,

Not sure if this will help or not, but in Windows there is a .ini file that controls the spell check preferences.
In Windows it is:
C:\Users\"your name"\Documents\Chief Architect Premier X7 Data\lex\ssce.ini

There are a couple of settings in there that may help:

IgnoreCappedWords=0

IgnoreAllCapsWords=0

and possibly

CaseSensitive=1

If the mac method is the same as windows these (the first 2) may be set to =1 which means that option is enabled.

0 means disabled.

If they are set to 1, you should be able to change them to =0.

I think you will need to start Chief AFTER changing these.

 

From the help file which you can find at:

 C:\Program Files\Chief Architect\Chief Architect Premier X7 (64 bit)\lex\ssce.hlp

Ignore Capitalized Words: When enabled, any words beginning with a capital letter are ignored (i.e., are skipped over without being checked). You might enable this option if the text being checked contains many proper names.

 

Ignore All-Caps Words: When enabled, any words containing all capital letters are ignored (i.e., are skipped without being checked). You might enable this option if the text being checked contains many acronyms.

 

Case Sensitive: When enabled, a distinction is made between capitalized and non-capitalized words. For example, canada is considered different from Canada, so canada would be reported as a misspelling. When the option is disabled, canada and Canada are considered identical. Note that the performance of the spelling checker will be reduced if this option is disabled.

 

 

Keep in mind though that this is all in windows - I haven't got a clue about a mac.

Also keep in mind that I believe that Chief is using a stripped down version third party spell checker which hasn't been fully implemented and is missing a lot of the interface and features described in the help file.

And...also keep in mind that Chief probably doesn't sanction this sort of messing about and neither do I. :rolleyes:

So proceed at your own risk.

Chief may have just gotten the OOB settings for the mac incorrect as indicated above - or on the other hand, it could be something completely different.

  • Upvote 1

Share this post


Link to post
Share on other sites

This is unfortunately a Mac thing.

Apple assumes that a word spelled in all caps is an acronym and therefore should be ignored.

 

You see the same behavior in any application on the Mac. There is no option for it either, spellcheck settings are under 'System Preferences> Keyboard> Text'.

You can change your language and choose whether to correct spelling automatically or not and that's all.

  • Upvote 2

Share this post


Link to post
Share on other sites

Actually as an after thought, you could probably use an all caps font instead of a regular font.

  • Upvote 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27493
    Total Members
    6254
    Most Online
    jjmitchell5231
    Newest Member
    jjmitchell5231
    Joined