McQueen3D

3D performance drop after Win10 upgrade

Recommended Posts

I've updated to Windows 10 and the 3D performance on my Chief X7 fell through the floor. This in addition for the app taking several minutes to start. Before, everything was quick and snappy. Anyone else experience this?

Share this post


Link to post
Share on other sites

No, on my Desktop system I experienced better performance. You an easily revert whenever you like. I upgraded my 8 year old laptop to Windows 10 and did not like its performance and so reverted, the process was quick and easy.

 

DJP

Share this post


Link to post
Share on other sites

Don't have win10 yet , but make sure you have the latest win10 graphics Driver for your card.

 

CA Server is down again this morning which is why it takes about 2 mins to get it going, the authentication has to time out 1st then it starts...

 

you can only revert Win10 within 30 days of installing it , then you would need to do a full reinstall of previous OS.

 

M.

Share this post


Link to post
Share on other sites

Updated the NVIDIA driver and still has the same issue. Turning shadows off helped but it's like going back to version 9. I set it to Win8 compatibility mode and it started faster, but no help for the graphics.

 

By the way, my 3D games are performing as well as under Win8, there is no difference.

Share this post


Link to post
Share on other sites

I am finding  that all progammes are slow to start, the whole computer is slow for the first 15 or so mins while the machine is searching the internet then it is no different.

I was using my laptop (which is the only 1 I have updated) the other day 50miles from an internet connection and it was good.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27469
    Total Members
    6254
    Most Online
    THDesign
    Newest Member
    THDesign
    Joined