Christina_Girerd

Object movement with arrow key blocked but no obvious reason

Recommended Posts

I have noticed this for a long time, but usually been too busy to ask about it.  Anyone know why the movement of an object, such as a text box, using the "select" then tap the "down arrow" on the keyboard method would not work when they are no obvious items in its path?

 

For months, I have noticed this issue, particularly in my Layout file when I'm adjusting text boxes.  In the example below, I did a wide selection of the area to show that there are no other objects immediately below the text items circled in red.  I can select and use the up arrow and both those text boxes move.  Yet not for the down arrow in this instance.  I like to use the keyboard arrows for small movements because it is precise and quicker than opening the Transform dbx to move it a specific amount.  Another "oddity" is that I can move the left text box (Bldg Coverage) with the left arrow key, but then I can't move it back with the right.  As if it hit some invisible buffer, though I'm just moving it back to where it was.  I don't know if this is an issue with the latest release, but I don't remember having so many issues with the arrow keys in the past.

 

Is there any key I can press while using the arrow keys that while override whatever Chief thinks the object is bumping against?  I tried Ctrl, Alt, and a few others but didn't find anything.  Or suggestions about why the arrow keys are behaving as if blocked?

2020 07 11 Arrow Down not working.JPG

Share this post


Link to post
Share on other sites

Maybe attach the layout file? 

Share this post


Link to post
Share on other sites
Posted (edited)
43 minutes ago, Christina_Girerd said:

So the text that I circled above, will go down about 4 "down arrow clicks" now, but then stops.  At least when I just tried it. 

 

Seems fine here.  Low batteries in your keyboard maybe ?

 

Edited by Chopsaw
Sorry I forgot that I had Bumping turned off. Same results as Eric here.

Share this post


Link to post
Share on other sites
37 minutes ago, Christina_Girerd said:

will go down about 4 "down arrow clicks" now, but then stops.

 

That's what I'm seeing too.

 

 

Share this post


Link to post
Share on other sites

You're being limited by CAD items on other pages.  I would consider this a bug that you might want to report.

Share this post


Link to post
Share on other sites
Dragging down with the mouse seems to pick up other ghost items.
 

 

Share this post


Link to post
Share on other sites

Interesting clip Eric, thanks.  How do you get those "ghost items" to be colored and show like that?  Are those items from other pages that Michael was referring to?  After Michael's comment, I deleted all the other pages, and then the movement worked just fine.  Thanks.  I'll put in a bug report.

 

 

Share this post


Link to post
Share on other sites
4 minutes ago, Christina_Girerd said:

How do you get those "ghost items" to be colored and show like that? 

 

I was just dragging the 2 problem text boxes down and noticed it. I figure they represent the items on other sheets.

 

I'd reference this thread in your report.

Share this post


Link to post
Share on other sites

I put in the report and mentioned the comments.

 

When I drag the boxes down, I don't get anything else colored. 

 

I also tried this in a generic blank layout (one of Chiefs), putting a text box on one page and another lower down on a second page, but at least in that very quick test, could not get it to reproduce. 

 

Share this post


Link to post
Share on other sites

A quick fix is to select those text boxes on Page 1, and on the Line Style panel, uncheck Bumping>Cad Stops Move. 

  • Upvote 1

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    28448
    Total Members
    9156
    Most Online
    Burtonmadness
    Newest Member
    Burtonmadness
    Joined