TopagnaOverlook

Polyline solid in cross section

Recommended Posts

I have two overlapped polyline solids in a cross-section elevation, and I can't seem to click-select the small triangle-shaped polyline behind the large one. (Although l can see it).

 

Can anyone tell me the mouse clicks to do that?

 

 

elevation1.png

cross_section.plan

Share this post


Link to post
Share on other sites

Try selecting the larger one and then tab once or twice.

Share this post


Link to post
Share on other sites

I tried that via the "next" icon, but neither approach works in this case.  I've been able to do it in other plans however.

Share this post


Link to post
Share on other sites

The smaller piece just needs to be on the surface of the larger, not buried in it.

 

They are also on different levels.

 

Move the larger one away so you can select the smaller, move it an inch into the room and to the same floor as the larger.

 

Move the larger back.

 

Select the smaller and use it to cut the hole.

Share this post


Link to post
Share on other sites

Thanks Eric.  I've moved both solids entirely away from the structure.  Even though overlapped, the "Hole in Polyline Solid" checkbox for the small triangle is disabled.  What should I be looking for to determine the levels or surface/depth of the two solids?  Can this be done from within the elevation view?

Share this post


Link to post
Share on other sites

One is on the Attic level, the other on the 1st floor. Look in plan and you can see.

 

Make both the same and your make hole will work.

Share this post


Link to post
Share on other sites

I cannot see either object in my plan view.  CAD, Default is set to display in my working layer set.

Is there another layer I need to turn on to see them?

Share this post


Link to post
Share on other sites

Seriously, who keeps doing this??!

 

CEEE7153-C618-4BB2-A49B-ED4E6A348428.thumb.jpeg.2ea7587361c705edd8cd357248541df4.jpeg
 

You’re being rude and totally unhelpful.  Example...In X12, even if you draw polyline solids in the same view but edit in another view, they get automatically converted to a solid and lose the ability to use polyline boolean operations like you would normally expect.  You end up having to use SOLID boolean operations which means the object have to actually be touching and will be affected in 3D instead of only the usual 2D extrusion shape.  Also, if someone was to try and help, and then repost the modified plan in X12, it would be a useless waste of everyone’s time if the OP was using X10.
 

Please consider taking the attitude down a couple notches and recognize that Eric and others continue to request current version information for very legitimate and helpful reasons.  

Share this post


Link to post
Share on other sites

Mark -- did you see my response above and get things to work?

  • Upvote 1

Share this post


Link to post
Share on other sites

I started over and got it to work.  I cannot explain how I originally put the two solids on different levels from the elevation view, but when I did it again, they both ended up on the first floor.  I'm pretty sure that what caused the "make hole" box to be disabled is that the inner solid was slightly overlapping the edge of the surrounding solid.  When I re-positioned the inner solid entirely within, the checkbox became enabled.

Share this post


Link to post
Share on other sites
2 hours ago, TopagnaOverlook said:

I cannot explain how I originally put the two solids on different levels from the elevation view

 

Just a heads up.

It is easy to unintentionally place objects on other floors than what was intended when working in elevation.

When in an elevation/cross section view, the change floor tool works by changing the floor "focus", even though you can't see any change to the cross section view - it doesn't move up or down.

ie, say you have a 2 storey house and have an elevation view and the current floor  indicator says 1.

You can draw an object on what looks like the second floor in elevation, but it will actually reside on floor 1 - the currently active floor. 

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks Glenn,

 

Good tip.

 

Although I wasn't monitoring the the change floor tool, I know that I didn't intentionally change it.

 

Maybe I accidentally hit "Shift-N"...

 

 

 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    28439
    Total Members
    9156
    Most Online
    JennieT
    Newest Member
    JennieT
    Joined