Toolbar Icon migration issues


NectarDesign
 Share

Recommended Posts

I recently upgraded to x11 on my personal computer/license. I also have a license for my employee which is set up on various new computers without my original default settings. Basically my tool bar icon's still look like x9, while my employees icon's are the newer versions. Is there a way to update just my icons to the new look, without having to do a full reset on my defaults? It's easier to work between computers when all the icon's look the same...

Thanks,

Jenn

Link to comment
Share on other sites

1 hour ago, NectarDesign said:

It's easier to work between computers when all the icon's look the same

Just to clarify, are you saying that the icon .png(image) files of each individual toolbar tool is different across two computers, or are you saying that the toolbar configuration(layout/orientation) is different?

Link to comment
Share on other sites

It's odd that your X11 "icons" would look like X9 "icons"

since the installation of X11 or any future update of X11

would automatically update the "icons".

 

Chief calls the "icons" buttons and you will find them @

C\Program Files\Chief Architect\Chief Architect Premier X11 (64 bit)\resources\buttons

 

There are hundreds of them. You could copy them all,

or just the ones you want from your employee's 'puter

and then paste them into the buttons folder on your rig.

 

You may be asked for administrative permission to 

overwrite the existing buttons. Also be aware that if you

are hand picking a few buttons to change, there are many

similar buttons. Be sure you are copying the correct ones.

 

Image7.png

Link to comment
Share on other sites

That is not correct ...

 

Chief creates the Data folder for each user and copy all resources to that folder.

User resources are loaded instead from 

C:\Users\<User>\Documents\Chief Architect Premier X11 Data\Toolbars

 

I believe, also never verified that if you delete them, chief will recopy the toolbar icons.

 

So I would copy from C\Program Files\Chief Architect\Chief Architect Premier X11 (64 bit)\resources\buttons to C:\Users\<User>\Documents\Chief Architect Premier X11 Data\Toolbars  or rename that folder to let CA recopy.

Link to comment
Share on other sites

I suspect that on one machine, your toolbars were migrated from a prior version and on the other they were not. 

 

It's relatively easy to make sure both machines have the same out of the box settings.  Simply rename your "Chief Architect Premier X11 Data" folder and then relaunch the program.  This will make sure the program is using all of the out-of-box toolbars, hotkeys, templates, etc.  You may then have to manually migrate any custom libraries and plan files.  More information about migrating settings can be found here:

 

https://www.chiefarchitect.com/support/article/KB-00001/migrating-chief-architect-to-a-new-computer.html

 

If you have any problems, I would highly recommend contacting our tech support.  

  • Upvote 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

  • Member Statistics

    30205
    Total Members
    9156
    Most Online
    emmabrownnn
    Newest Member
    emmabrownnn
    Joined