Keifuz

X10 roof line editing

Recommended Posts

This is something that's started after upgrading to X10.  Working with roof lines, line breaks are appearing on their own making it very difficult to join plane using #2 button.  And before, line breaks would automatically disappear when you straightened a line, now they don't.  I can't find a setting that determines this behavior.

 

Thanks

Share this post


Link to post
Share on other sites

I made a video and sent Chief a sample plan, but they are unable to reproduce.

Share this post


Link to post
Share on other sites

There seems to be quite a few strange things that are going on after upgrading to X10.

Share this post


Link to post
Share on other sites
31 minutes ago, JMininger said:

Same issue here.  It's a new behavior in X10

 

Is that an opinion, or something from Chief?

Share this post


Link to post
Share on other sites

It's my observation that line breaks in a roof plan remain now after editing.  In previous versions if you reshaped a roof polyline to have a straight side the breaks would disappear automatically.  The line breaks prevent joining roof plans in many instances so it is a nuisance.  I have not heard anything about it from Chief.

  • Like 1

Share this post


Link to post
Share on other sites
On ‎3‎/‎22‎/‎2018 at 11:00 AM, JMininger said:

It's my observation that line breaks in a roof plan remain now after editing.  In previous versions if you reshaped a roof polyline to have a straight side the breaks would disappear automatically.  The line breaks prevent joining roof plans in many instances so it is a nuisance.  I have not heard anything about it from Chief.

Yes this is happening and is definitely a step backwards; at first I thought it was an aberration, but realized after working on a couple of tedious roof jobs where I knew planes should be joining but wouldn't, I can confirm that it is not. 

My tedium is now amplified, because of having to zoom in and clear out roof plane breaks to join planes - an extra action that I didn't have before.  If this is planned change, at least elucidate as to why.

  • Like 1

Share this post


Link to post
Share on other sites

I've provided Chief with multiple plans and videos demonstrating this problem. Even showing the same plan in X9 and X10, doing the same actions and showing the different results.

 

No reply so far.

Share this post


Link to post
Share on other sites

Chief responded as they so often do.

 

Based upon the details you submitted within Case # 79030, you will be happy to know that our testing and software development teams are able to reproduce this issue. 

Thank you for submitting this additional and requested information. This helps greatly.

 

And

 

Thank you for supplying reproducible steps in regards to this issue within the X10 program. I have sent this additional information over to our development team. 

  • Upvote 2

Share this post


Link to post
Share on other sites

Eric,

 

Thanks for letting us know - I am going to assume they will address it.

Share this post


Link to post
Share on other sites

Been having Roof Trouble myself this week ( SEH Errors clicking on roof planes) in .43 and 20.1.1.1 but Tech Support can't reproduce the Issue even with Steps provided , but this morning She admitted She is using 20.1.1.2 already ( won't be released for 2-4 weeks to us apparently) so She couldn't even save the Plan and send it back to me. She tried saving in HD Pro 2019 but as it doesn't have PBR all my saved cameras and materials etc are totally messed up.

 

Thankfully She found the other SEH Error , I couldn't make material lists , turned out from my error reports that I had a buggy wall cabinet , She told me to delete it  and Material lists started working again ......

 

X10 has been hell this week , all sorts of weird issues with decks and other anomalies I never saw in X9...... I feel like an Alpha Tester at the moment never mind Beta Tester , lots of wasted time this week , but plan was already 1/2 done in 10 so I had to continue with it.

 

M.

 

 

Share this post


Link to post
Share on other sites

This junk right here is driving me crazy.  Roof line breaks just appearing out of nowhere & almost impossible to get rid of them.

roof line madness.png

Share this post


Link to post
Share on other sites
On 3/23/2018 at 3:08 PM, solver said:

Chief responded as they so often do.

 

Based upon the details you submitted within Case # 79030, you will be happy to know that our testing and software development teams are able to reproduce this issue. 

Thank you for submitting this additional and requested information. This helps greatly.

 

And

 

Thank you for supplying reproducible steps in regards to this issue within the X10 program. I have sent this additional information over to our development team. 

 

Any further replies?  I have latest update & still happening constantly.  Big pain.

 

image.thumb.png.5120283d5abc1e1db76dd79be5b31a62.png

 

Share this post


Link to post
Share on other sites

Interestingly, Since Beta 2 of X10, I have not seen this unwanted phenomenon at all (Knock on wood), I am sorry you guys are. If Tech Support says "they can duplicate" the result, they can and will fix it as soon as they have a bulletproof fix, of that you can be sure.

 

DJP

Share this post


Link to post
Share on other sites
20 hours ago, JMininger said:

I have the latest update and still experience it

Ditto

Share this post


Link to post
Share on other sites

My new unnecessarily indispensable tool for editing roof planes

trim both.JPG

Share this post


Link to post
Share on other sites

Wish they would correct this in an update, this has become very time consuming trying to find the broken lines fix them and make the connections, Chief please fix asap

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27611
    Total Members
    6254
    Most Online
    ChiefAKBuilder
    Newest Member
    ChiefAKBuilder
    Joined
  • Similar Content

    • By ChristinoDesign
      We're trying to figure out how to change the angle of pendent lights on vaulted ceilings. When we create the ceiling angle, the lights follow and aren't angled properly. How do we change the lights so they go vertical rather than at a tilt?
    • By Alyssa5
      Hi,
      I am using Chief Architect X8 on a Mac.
      I am having trouble with roof planes - I want to be able to change the baseline height but it keeps defaulting back and won't alter.
      Yet when I open the same file on another computer I can change it
      Any suggestions?
       
      Thanks
    • By josiemlittle
      Hello, I’m needing help lowering the roof. I’m trying to make a 50x80x16 shop with the pitch lower than the default gable height. I’m new to this and I’m hoping this software will help build our dreams on our farm. I want the look of the attached photo with the front being the 80 ft side. 

    • By amydutton
      How do I put a roof return on this roof? Can't find a video about it anywhere on the Chief Website... is there another name for it?
       
      See attachment, and where I drew in black.