Sign in to follow this  
VisualDandD

Deleting Unused Layers? Strange

Recommended Posts

I impoted a DWG with two layersets.   I have since deleted all remnants of them.  They do not show as used in my dialogue, but it wont let me delete them....  They are not mapped to any specific "Chief" layers that can not be deleted.

 

I can delete other unused layers have created....just not those two that came in as an import.

 

Could this be a X8 bug?   Anyone run into anything similar?

Share this post


Link to post
Share on other sites

You kinda went back and forth between layers and layersets in your post. Are they layers or layersets that you cannot delete? And can you possibly attach the plan so one of us can check to see if we have the same problem?

Share this post


Link to post
Share on other sites

You kinda went back and forth between layers and layersets in your post. Are they layers or layersets that you cannot delete? And can you possibly attach the plan so one of us can check to see if we have the same problem?

I am sorry.... I meant individual layers.

 

I fixed it but in a draconian way.   I just copied everything (leaving those two created Import layers off) and pasted into my "save as" template.   I already deleted the old file.

 

I am working on sprucing up my "save as" template and did not want to clog it up with any unnecessary layers that I could not get rid of for whatever reason.  

 

I can try to reproduce and also try to do it in X7 and see if it does same thing.   Have to make a note to do it...

 

[edit] plan example attached below.

Share this post


Link to post
Share on other sites

OK....I repeated it real quick

 

Blank plan.  Imported two layers to copy an old plan.

 

SPWALL_OUTLINE

SPWALL_TEXTURE.

 

I then just closed a box in the plan to define a room.   Now turn "all off" on the layers and just select 

 

SPWALL_OUTLINE

SPWALL_TEXTURE.

 

to show on drawing.   Group select and delete all those objects from plan.

 

Now open Layers up and confirm that those layers are not used.   Now try to delete those unused layers.   I cant do it....  Maybe I am missing something?....

 

 

Running X8

layer exp.plan

Share this post


Link to post
Share on other sites

Worked for me.  How are you deleting your layers?  I was doing it through the Layer Display Options dbx. 

Share this post


Link to post
Share on other sites

Weird...Just tried doing it through the ACTIVE Layer Display Options dbx and here's what I found...

 

You can't delete the layers unless first changing your layer set or closing the display.  I think the list just needs to reset.  If you do that you can delete the layers just fine.  If you just changed layer sets instead of closing and re-opening the display you'll have to de-select the layer before re-selecting and deleting it. 

Share this post


Link to post
Share on other sites

Hmmmmm...  I just closed X8 and rebooted and then opened it again.   Now it worked?!

 

Ha....never know sometimes.   Never hurts to re-boot when having an issue and see if it goes away.

 

Thanks!

Share this post


Link to post
Share on other sites

I have this same issue but I cannot remove the superfluous layers. The layers I am trying to delete are also a result of DWG imports. They act like they are system layers and  the delete option is not available in the "Layer Display Options" box. I have a title block plan that has all my settings the way I like them and I use it to start new files and update it as I work on new projects. The list of unwanted layers is ever growing and I would like to get rid of them. The methods discussed above have not worked for me. I'm using X8 on a Mac but the problem has persisted through several upgrades.

 

I have attached a sample file in which I have renamed the layers z through z15 just to get them out of the way as you will see. I also added some layers manually. Some will not let me delete them, others will. I thought maybe I copied a system layer and renamed it and thought that might be the reason they would not allow me to delete them.

 

Any assistance would be appreciated.

file:///Users/Don/Desktop/temp.plan

Share this post


Link to post
Share on other sites

I see my attachment is just text. Don't see how to add the file?

Share this post


Link to post
Share on other sites

one of the recommendations I have seen is to always import "unkown" stuff into

a new plan, cleanup as needed then copy to the desired plan

or save to the library

 

sometimes these .dwg files (or .skp or ???) can have a zillion layers

 

Lew

Share this post


Link to post
Share on other sites

Here is a sample file that has some unused layers that I cannot delete. Can someone please check to see if it's just me. I'm usually pretty good at solving these types of issues but this one has me stumped.

The layers are from previous imports and I have renamed them Z... to get them out of the way.

Cant delete layers.plan

Share this post


Link to post
Share on other sites

Ibuttery,

Good suggestion. I'll keep that in mind for future imports.

But for now any advice on how to get rid of these current, unwanted, layers.

See file on previous post.

Share this post


Link to post
Share on other sites

The problem is that I believe those layers are being used in some of your CAD Blocks.  If you check "Automatically Purge CAD Blocks" you can delete the layers just fine.

Share this post


Link to post
Share on other sites

Awesome, Thanks Michael!

That worked for all but one of them. "Z 11" still won't go away but i'm good with that.

Nice to have pros on the case.

don

Share this post


Link to post
Share on other sites

You can't delete Z11 because its actually a system layer that you just renamed.  Its the Terrain Features layer. 

Share this post


Link to post
Share on other sites

Okay, Thanks. I delete one of the layers I created and then rename it to that to get rid of it. I'll change it back to it's default.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
Sign in to follow this  

  • Member Statistics

    27645
    Total Members
    6254
    Most Online
    ChiefUserTyMN
    Newest Member
    ChiefUserTyMN
    Joined