X-15 Hangs when opening User Library / Catalog


Go to solution Solved by JLU_Design,

Recommended Posts

Thumbnail creation might just be taking a long time. See if this helps.

You can turn off thumbnails by

1. Right clicking the header in the Filter Results panel (where "Name" is shown)

2. Uncheck "Thumbnail"

3. Then, try clicking on your User Catalog.

Link to comment
Share on other sites

  • Solution

The following is what solved my problem.

I'm using Windows 10 to run Chief Architect.


I ended up going to:

C:\Users\YOURUSERNAME\Documents\Chief Architect Premier X15 Data\Database Libraries

I deleted everything in the X15 folder.

Then I opened X15 and started a new user library and added a few things to it to make sure it was working.

Then I went to:

C:\Users\YOURUSERNAME\Documents\Chief Architect Premier X14 Data\Database Libraries

And opened (User_Library.calib) with X15 which initiated the import.

Everything worked right away after it was all imported.


I'm assuming the user library was somehow corrupted when I tried to import it during the program installation.

Thankfully the X14 library was still intact.


Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now