dskogg

Nvidia driver updated but ca doesn't recognize it?

Recommended Posts

I have just updated the nvidia driver on my laptop and it shows in the nvidia control panel but Chief is still showing a driver from 2016, i have rebooted laptop, not sure

what i need to do.

Anyone have a suggestion?

Share this post


Link to post
Share on other sites
2 minutes ago, dskogg said:

I have just updated the nvidia driver on my laptop and it shows in the nvidia control panel but Chief is still showing a driver from 2016, i have rebooted laptop, not sure

what i need to do.

Anyone have a suggestion?

 

shouldn't need to do anything really , you can try in the NVCP on the manage 3D tab Add CA as a Program. being a laptop you may need to force the Preferred card to be the Nvidia Card so CA uses it all the time , down side maybe lower Battery time though, not an issue if plugged in in the Office though.

 

image.thumb.png.58cd82e51d949fd830936e14f5a481dd.png

 

image.thumb.png.b9b531e2e195a048b88a18ad483ec5eb.png

Share this post


Link to post
Share on other sites
8 minutes ago, Kbird1 said:

 

shouldn't need to do anything really , you can try in the NVCP on the manage 3D tab Add CA as a Program. being a laptop you may need to force the Preferred card to be the Nvidia Card so CA uses it all the time , down side maybe lower Battery time though, not an issue if plugged in in the Office though.

 

image.thumb.png.58cd82e51d949fd830936e14f5a481dd.png

 

image.thumb.png.b9b531e2e195a048b88a18ad483ec5eb.png

Yes i did this but ca still does not recognize the latest version?

ca video card status.JPG

system info status.JPG

nvidia control panel view.JPG

Share this post


Link to post
Share on other sites

The Driver Version in Chief is showing the Intel GFX Driver number it looks like ? have you updated it too recently?

 

In Device Manager does the Display Driver for the Nvidia Card say 440? 

 

In the Manage 3D App scroll all the way down and make sure the OpenGL is set to the Nvidia Card too...

 

image.thumb.png.d7a3cda2cae7a58dc9b8b3497aa65de8.pngimage.thumb.png.194035419dcc91a43b5dcb4855b01ec5.pngimage.thumb.png.2a27036aa7ca9b54d55f5fbfb958a28a.png 

Share this post


Link to post
Share on other sites
11 minutes ago, Kbird1 said:

The Driver Version in Chief is showing the Intel GFX Driver number it looks like ? have you updated it too recently?

 

In Device Manager does the Display Driver for the Nvidia Card say 440? 

 

In the Manage 3D App scroll all the way down and make sure the OpenGL is set to the Nvidia Card too...

 

image.thumb.png.d7a3cda2cae7a58dc9b8b3497aa65de8.pngimage.thumb.png.194035419dcc91a43b5dcb4855b01ec5.pngimage.thumb.png.2a27036aa7ca9b54d55f5fbfb958a28a.png 

i changed the opengl to the nvidia...here is a snipit of the display driver

display adapter.JPG

Share this post


Link to post
Share on other sites

Mick you are right..it looks like its using intel driver

 

video card status ca.JPG

Share this post


Link to post
Share on other sites
32 minutes ago, dskogg said:

Mick you are right..it looks like its using intel driver

 

video card status ca.JPG

 

You may need to call Tech Support on Monday if you have Told CA to use the NVidia Card in the NVCP and it isn't , then I am not sure why.

 

I would look into updating your Intel Driver too as perhaps it is at fault and not releasing , so the NV Card can't take over like it should in 3D etc

 

M.

Share this post


Link to post
Share on other sites

Just wondering if the power plans are all set to maximum/high performance in both windows and the NVidia settings.

Share this post


Link to post
Share on other sites
10 minutes ago, TheKitchenAbode said:

Just wondering if the power plans are all set to maximum/high performance in both windows and the NVidia settings.

graham, what is a power plans?

Share this post


Link to post
Share on other sites
20 minutes ago, Kbird1 said:

 

You may need to call Tech Support on Monday if you have Told CA to use the NVidia Card in the NVCP and it isn't , then I am not sure why.

 

I would look into updating your Intel Driver too as perhaps it is at fault and not releasing , so the NV Card can't take over like it should in 3D etc

 

M.

i went to display adapters and made sure the intel driver was up to date and it was...does it make sense to reinstall chief? would i lose anything..

Share this post


Link to post
Share on other sites

Power plans tell windows how to control specific hardware such as the GPU to either minimize power consumption or ignore power usage and deliver maximum performance. The integrated GPU needs less power than the GTX 960 so if the power plan is set below maximum performance Windows will under certain circumstances use the integrated chip versus the GTX 960.

 

There are two places for settings, under Windows, System there is the Windows one. Change it to high/maximum performance for both plugged in and battery mode. Then in the NVidia settings just scroll down the Global settings and you should see a performance settings, set this to max. There is also the same setting in the list where you added CA to the GTX 960, make sure it is also set to high/maximum.

 

Reboot and see if this corrects your issue.

Share this post


Link to post
Share on other sites
18 minutes ago, dskogg said:

i went to display adapters and made sure the intel driver was up to date and it was...does it make sense to reinstall chief? would i lose anything..

 

Updating Intel Drivers Via the Device Manager is not always successful ... it isn't if it is still showing 2016 guaranteed. Check the Manufacturer's Website for updates etc too and lastly you may need to get it direct from Intel.

 

Graham has a good point about the Power Plan and Power Settings in the NVCP

 

image.thumb.png.99b7b592b33a7f01aff6ecfde688acb2.png

 

image.thumb.png.f10247d312591126e92b4b6a2cc073cb.png

 

 

Share this post


Link to post
Share on other sites

Mick is correct about how you update the drivers. When you use the update driver through the device manager Windows only looks for the last official Microsoft approved version. This often differs from the latest version offered by the hardware manufacturer, also most systems have support for drivers and this can also differ as some drivers may be customized for your laptop.

 

If you get the driver from NVidia they do have an option to completely remove the old driver before installing the new one. Sometimes the standard update option will leave bits and pieces of the old driver on your system. The only disadvantage of doing a remove and install is that you will loose the option in device manger to roll back the driver in the event that the new driver causes problems, rare but it does happen.

Share this post


Link to post
Share on other sites
1 hour ago, TheKitchenAbode said:

Mick is correct about how you update the drivers. When you use the update driver through the device manager Windows only looks for the last official Microsoft approved version. This often differs from the latest version offered by the hardware manufacturer, also most systems have support for drivers and this can also differ as some drivers may be customized for your laptop.

 

If you get the driver from NVidia they do have an option to completely remove the old driver before installing the new one. Sometimes the standard update option will leave bits and pieces of the old driver on your system. The only disadvantage of doing a remove and install is that you will loose the option in device manger to roll back the driver in the event that the new driver causes problems, rare but it does happen.

i went to intel and had them scan my system and it says its up to date...

I changed power setting in nvidia as shown..

I only have one power setting to choose from not the ultimate power setting..

so it still shows intel driver...

Share this post


Link to post
Share on other sites

Intel's Scanner is next to useless in many cases , I am not sure why , it doesn't work with my Surface 3 and didn't work with a laptop I had for a short time a year ago either and both have intel Graphics etc etc.

 

Show me the Hardware Tab from Device Manager for the INTEL Display adapter and I do a Search.....

 

This shows where to find it ...as you can see I DON'T have an intel card in my Desktop....  I need the PCI\VEN Numbers for your Intel Card

 

image.thumb.png.7c111802b0b69e3492ad0ba3bfdce8d4.png

 

 

Share this post


Link to post
Share on other sites
13 hours ago, dskogg said:

I changed power setting in nvidia as shown..

 

Did you also change the power settings in Windows?

Share this post


Link to post
Share on other sites

I tried but there was only one option to chose from.. no MaX power option?

Share this post


Link to post
Share on other sites
1 hour ago, Kbird1 said:

Ultimate is not an option on Laptops , but High should be, though some laptop manufacturers seem to disable all but balanced.

 

https://www.tenforums.com/tutorials/110372-restore-missing-default-power-plans-windows-10-a.html

Hi Mick, thanks for this, i loaded both high and ultimate onto laptop and rebooted...its still showing the intel video card...

Do you adjust any other nvidia card options?

 

I guess next step is to chat with CA...sometimes they are not as technical as forum guys like yourself...unless there is anything else to try.

Share this post


Link to post
Share on other sites
15 hours ago, Kbird1 said:

Intel's Scanner is next to useless in many cases , I am not sure why , it doesn't work with my Surface 3 and didn't work with a laptop I had for a short time a year ago either and both have intel Graphics etc etc.

 

Show me the Hardware Tab from Device Manager for the INTEL Display adapter and I do a Search.....

 

This shows where to find it ...as you can see I DON'T have an intel card in my Desktop....  I need the PCI\VEN Numbers for your Intel Card

 

image.thumb.png.7c111802b0b69e3492ad0ba3bfdce8d4.png

 

 

mick here is what i have on this...looks like it hasnt been updated for a while..

 

530 events.JPG

intel 530.JPG

Share this post


Link to post
Share on other sites
1 hour ago, dskogg said:

mick here is what i have on this...looks like it hasnt been updated for a while..

 

 

 

 

Details Tab >Hardware ID Dropdown> ( see my pic above) ....copy and paste the PCI/Ven Code info back here please...

 

Also what is the EXACT Model Number of your Acer Nitro Laptop please , it is not in your Signature after all.

 

M.

Share this post


Link to post
Share on other sites
16 minutes ago, Kbird1 said:

 

Details Tab >Hardware ID Dropdown> ( see my pic above) ....copy and paste the PCI/Ven Code info back here please...

 

Also what is the EXACT Model Number of your Acer Nitro Laptop please , it is not in your Signature after all.

 

M.

Hey Mick, i added model to my signature now... it doesn't seem like there is a new driver since 2016?

 

PCI\VEN_8086&DEV_191B&SUBSYS_10391025&REV_06
PCI\VEN_8086&DEV_191B&SUBSYS_10391025
PCI\VEN_8086&DEV_191B&CC_030000
PCI\VEN_8086&DEV_191B&CC_0300
 

hardware ids.JPG

Share this post


Link to post
Share on other sites

Wow Acer is brutal , there isn't a single hit for your particular Intel HD 530 on the Microsoft Update Catalog, which explains why it says you are upto date, lots for other brands eg Lenovo , with the  PCI\VEN_8086&DEV_191B GFX Card but generally they won't install without the full number.

 

Found some Info back on 10Forums ( great Site for all things Windows 10 )  here for your CPU and HD 530 in the 2nd section for Gen.6 Chips.

 

 https://www.tenforums.com/graphic-cards/14192-latest-intel-graphics-driver-windows-10-a.html

 

Know that you download any drivers at your own risk and as it seems the Driver type has changed from Standard to the Modern DCH Drivers make sure to download the .EXE version NOT the .zip version here :

 

https://downloadcenter.intel.com/download/29113/Intel-Graphics-Windows-10-DCH-Drivers

 

DO NOT PROCEED WITHOUT A FULL IMAGE BACKUP with a rescue disk/usb made and tested.....PLEASE

I use Macrium Reflect Free for this purpose , do a search on 10Forums if you need it, for more info, or have a local computer store do it all for you....

 

M.

 

 

Share this post


Link to post
Share on other sites

Just noticed that you have an external monitor. If so I assume you have it attached via the HDMI port. There are times on laptops where it will default to the integrated chip to drive the external monitor. Disconnect the external monitor and boot up your laptop, load CA and then check the CA preferences to see it now fully recognizes the GTX 960.

Share this post


Link to post
Share on other sites
26 minutes ago, TheKitchenAbode said:

Just noticed that you have an external monitor. If so I assume you have it attached via the HDMI port. There are times on laptops where it will default to the integrated chip to drive the external monitor. Disconnect the external monitor and boot up your laptop, load CA and then check the CA preferences to see it now fully recognizes the GTX 960.

 

Oh Wow , interesting ...that would be bad unless it has other Ports like VGA or Display Port , assuming they don't have the same issue.

 

I assume it has Bios 1.12 ? it's old, Dec. 2016 , but may correct some issues if yours is not upto date.

 

M.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27825
    Total Members
    6254
    Most Online
    ChiefDallas
    Newest Member
    ChiefDallas
    Joined