Hip Roof Overhang Per Wall Does Not Seem To Work


foleys1
 Share

Recommended Posts

Hello,

When creating a hip roof, and using the Wall Specifications dialog to manually set an overhang length for a single wall, it does not seem to work as expected.

Steps to reproduce:
1. Draw 4 exterior walls to create a room.
2. Select one of the walls and set its overhang to 0".
3. Select the Build Roof tool, and make Roof Baseline Polylines.
4. Notice the polyline for the edited wall is at the outside edge of the wall, just the same as the other walls.
5. And when you Build Roof Planes, that wall has the same overhang as the other walls, even though you specified a non-default overhang for that wall.

This is in comparison to what happens when the wall is a gable wall.
1. Draw 4 exterior walls to create a room.
2. Select one of the walls, set its overhang to 0", and make it a Full Gable Wall.
3. Select the Build Roof tool, and make Roof Baseline Polylines.
4. Notice that the polyline for that edited wall extends past the exterior edge of the wall. So if you drag that polyline back to the exterior edge of the wall, and Build Roof Planes, that wall will have no overhang.

Maybe I'm missing something, but I cannot figure out how to create a hip roof with a single wall that has no overhang, without dragging the polyline inwards past the interior edge of the wall. But this method removes the ability to control the size of the automatically created roof plane, because all you are doing is offsetting the baseline to put the overhand where you want it on the plan.

 

 

Chief Architect X7 build 7.3.0.25

Link to comment
Share on other sites

Yes, but that would require manual roof plane editing of not only that roof plane, but all adjoining roof planes, which gets difficult with a complex hip roof. I'm trying to rely on the auto build feature of the roof build tool to automatically build the complex roof planes for me. This concept seems to work with walls that are configured as a gable roof type, but not with a hip roof.

Link to comment
Share on other sites

You need to guide the program to get the desired results.

 

Draw an invisible wall inside the wall that you want no overhang on. Set the small room created to no Roof Over This Room. Build the roof. Adjust the location of the invisible wall to get the look you want.

 

post-1284-0-35749400-1450468949_thumb.jpg

Link to comment
Share on other sites

Yes, it does appear that the wall settings for roof overhang is ignored, but your example wouldn't work well for "automation" regardless since geometry would require the baseline to be set inward from the wall by the same distance as the common overhang.

 

Another option might be to then segment out a "room" the distance of the overhang, and choose "no roof" over that room which will automate a baseline that will keep the fascia heights aligned.  This may get you the automation you seem to be after.

post-75-0-17183700-1450473235_thumb.jpg

Link to comment
Share on other sites

In the default Build Roof dbx, uncheck Same Roof Height At Exterior Walls (on the Roof Panel).

 

Hey Glenn - just as a matter of exercise I did this and the roof overhang still built at 18" (default) and ignored my manual overhang I made input on the "wall" diagram.  Perhaps I have something wrong....

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

  • Member Statistics

    32065
    Total Members
    9156
    Most Online
    Shatimwene
    Newest Member
    Shatimwene
    Joined