Pkbldr

Unable to delete several objects

Recommended Posts

I have a plan that is fairly early in development (attached) that has a Room Divider wall that I can't seem to delete (I didn't add it as far as I know) and some dimensions on a Bay Window that won't delete either.

I'm using X16 Build:16.2.0.47x64.

Any help appreciated.

 

Toby

Share this post


Link to post
Share on other sites

Hi Toby, no attachment that I can see but let me take a guess as to what is the problem.

 

Go into the layer set and turn off the layer that is "ceiling break lines" next, open the bay window and turn off the "display dimensions" in the options tab.

 

Andy.

  • Upvote 2

Share this post


Link to post
Share on other sites

OOPS! I have that disease that has me say there's an attachment in emails and there isn't so it must transfer to forum post as well. I think I have it included this time.

 

The Bay window dimensions worked (thanks!) but the Ceiling Break Line layer did not.

When I open it, it says it's a Room Divider wall type.

I changed it to a Interior 4 type and still couldn't delete it.

As I said, I didn't intentionally create any wall there so...

 

Any other ideas?

 

Toby

 

 

 

Hill_Floor Plan-1.plan 

Share this post


Link to post
Share on other sites

Island room connector wall....

Thanks Bill but that's not it either, didn't work.

Now I have to go learn about "Island Rooms".

New to me.

Share this post


Link to post
Share on other sites

Turn off 'connect island walls' in General Wall Defaults.

 

Works for me on your plan...

Share this post


Link to post
Share on other sites

Put the room divider or island wall on its own layer and turn off the display of it

Share this post


Link to post
Share on other sites

Bill- Really? That IS odd! See the attached image of the selection unchecked, saved, closed and reopened and still displaying.

 

Drawzilla- I considered the layer isolation and will do that if it's the only option but I really do hate workarounds....

 

post-500-0-62060400-1395761321_thumb.jpg

Share this post


Link to post
Share on other sites

Bill- Really? That IS odd! See the attached image of the selection unchecked, saved, closed and reopened and still displaying.

 

Drawzilla- I considered the layer isolation and will do that if it's the only option but I really do hate workarounds....

 

attachicon.gifRoom Divider.JPG

Not really a workaround, I have walls on every plan I do, that need the display of, to be turned off. Set up a template plan with all your extra layers you need and then its very simple to do.

Share this post


Link to post
Share on other sites

Do not turn off "connect island rooms" in your general wall defaults. 

 

The problem is that your utility closet is creating an island room.  An island room is any room that is not connected to any outer walls forming an "island" inside your house.  Island rooms cause all kinds of strange and mysterious problems which is why you don't want them.  Turning off the default will just cause you more problems later.

 

Instead, you should always connect your island rooms by manually drawing your own invisible walls.  Once you have correctly drawn your own invisible walls, you can delete the automatically created one.  If you don't want to see them in your plan views, then just turn off the layer.

Share this post


Link to post
Share on other sites

Bingo, we've got a winner!

Thanks KT, very productive for your 1st post!

I drew a invisible wall in the narrow opening, sort of like a header, turned the island room connect default back on and was able then to delete the room divider.

Thanks to all for the assistance.

 

Toby

 

post-500-0-00161400-1395771352_thumb.jpg

Share this post


Link to post
Share on other sites

The thing is, I don't see any condition that would put an island wall there in the first place. A room divider wall is just an invisible wall with a zero thickness. Something else might be wrong. An island wall would be standard wall thickness

Share this post


Link to post
Share on other sites

Bill- Really? That IS odd! See the attached image of the selection unchecked, saved, closed and reopened and still displaying.

 

Drawzilla- I considered the layer isolation and will do that if it's the only option but I really do hate workarounds....

 

attachicon.gifRoom Divider.JPG

 

Once you turn it off, you have to delete the wall, it will not regenerate.  Here's your plan without it...

Share this post


Link to post
Share on other sites

If you turn off the "connect island rooms" and delete the room divider, you will get a "living area" in the middle of your plan and you will also get a very strange exterior room.

 

This is why you should not turn it off.

post-844-0-13789100-1395779890_thumb.jpg

Share this post


Link to post
Share on other sites

If you turn off the "connect island rooms" and delete the room divider, you will get a "living area" in the middle of your plan and you will also get a very strange exterior room.

 

This is why you should not turn it off.

 

You are correct, (just trying to explain how the option works)...

 

And commendations on your answer! However I still leave it 'off' with a lot of the other auto stuff...  I know how it works, don't bother me!

 

It does indeed screw you sq. footage if you have an island room unconnected...It shows the island room sq. footage and adds that to the total!

 

Maybe CA should rethink "island rooms" and how they work or don't., and the options...

 

Again, Thanks!

 

Bill

 

 

 

.

Share this post


Link to post
Share on other sites

BTW, Perry has a good option that is not necessarily a 'work around', just another way of using CA.  divider walls normally go to the 'invisible walls layer'...

 

Case in point , I may want to show them, but not the invisible walls layer, hence another layer needs to be created.. , a matter resolved in seconds...

 

Keep in mind that all posts can lead to inspiration and solutions...

 

Thanks Perry!

Share this post


Link to post
Share on other sites

Bill

Thank you sir, you made my day.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27833
    Total Members
    6254
    Most Online
    jaimeducusin
    Newest Member
    jaimeducusin
    Joined