Custom Window - Trapezoid Shape


Go to solution Solved by Ange822,

Recommended Posts

Hello - I am wondering if there is a way I can create a Trapezoid shaped window. I found a similar thread but it was for a parallelogram shaped window.

I have been playing around with the "shape" tab in the window specification, but can not for the life of me figure it out! I have also looked at other threads to see if I can make a custom window but I could not find that either. I have shown in red what I would like the window shape to be;


Any help would be greatly appreciated!





  • Like 1
Link to comment
Share on other sites

Unfortunately, Chief currently doesn't let you do that easily. The only way I know of to get a window that shape is using a symbol. Luckily you can create an appropriate symbol using a shaped window.



  1. Create a window with the desired look, but rotated.
  2. Convert that window to a symbol.
  3. Rotate that symbol about the y-axis.
  4. Place the symbol in the plan.
  5. Cleanup the wall around the symbol.



The window shape has some significant limitations:

  • Top
    • Maximum of three edges.
    • No edge can be vertical or undercut another edge. Specific limitations: horizontal offsets must be sequential and must have a separation of at least 1".
    • Lowest point is 1/4" above the bottom (there is a workaround).
  • Bottom
    • Only allows sloping the bottom (always one edge).


Edit: I realized there is an easier orientation for this situation that doesn't require the workaround, but I'll leave it here in case it helps someone else. Left window is the original, right doesn't require the workaround.

The workaround to remove side edges:

  1. Make the window height 1" larger than you want the final result.
  2. Create the desired shape, but set the Side and Top Inside Corner heights to 1" higher than the final result.
  3. Make a new window that is the desired height.
  4. Use the object painter to transfer just the window height to the shaped window.
  • Notes
    • The bottom of the frame breaks when doing this, but that issue and others are fixed in X15. Now that these issues are fixed, we should probably change the left and right side height minimums to 0" instead of 1/4", but that obviously hasn't happened.
    • Making the side edges zero works fine, but making the side edges negative with this workaround is problematic.
    • Opening the window specification dialog and clicking OK will reset the shape and undo the workaround.



  • Upvote 1
Link to comment
Share on other sites

13 minutes ago, DrawingABlank said:

Looks like there is a solution using symbols.

Just adding this in case others find this thread looking for odd shapes...

Eric had some ideas for non-typical shapes using pass-throughs.

Odd Shaped Doorways Using a Pass Through - Chief Architect

Good point. Manually mulled pass throughs is a good way to enable most of the window functionality, and to do 90% of the wall cleanup. You'll still need the workaround and symbol for this particular case.


Here is a working example that only needs a little touch up.



Link to comment
Share on other sites

  • 1 month later...

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Member Statistics

    Total Members
    Most Online
    Newest Member
  • Similar Content

    • By Allen43
      I recently updated to X15 and after doing so I have had a few problems. The last one I have to fix is my macro for auto cabinet label generation.
      I am by no means a programmer and I barely understood ruby when I made this macro. I have been trying to relearn but I still can't figure out what my problem is.
      I have attached my macro below and this is the error I have been getting:
      Evaluation Error: Ruby TypeError: no implicit conversion of nil into String
      Stack Trace:
      from eval:10:in `eval'
      from eval:10:in `block (2 levels) in <main>'
      from eval:4:in `loop'
      from eval:4:in `block in <main>'
      Any help is apricated. Thanks in advance!
    • By Allen43
      I recently updated to x15 Premier and have loved the new features. However, I just ran into a problem. The camera tool is kind of busted. Standard view only renders the glass in the windows and light sources. Physically Based is a grey screen. Clay is also a grey screen. And finally, Duotone only renders the glass and light sources again.
      Is this a problem that other people have ran into?
      Any suggestions and help are appreciated as I use the camera view a lot in my design process.
      I have attached to images that show the two main problems.

    • By NatalyaH
      I have been trying to place a rectangular polyline onto a Layout file that has a solid grey fill.  All the fill settings are set to grey as well as the default CAD layer color.  Despite this when I exit from the polyline specification box the rectangle will still only show as a solid black.  Does anyone have any suggestions on how to fix this and make the polyline boxes be filled with a solid grey? 
    • By donnabagdy
      Has anyone experienced these report errors after trying to update the catalog set  in the library?  I've deleted the CAD Block Bonus Catalog, reran the update and it's clean.  I downloaded the catalog anew / FRESH from the website and installed it successfully.  BAM.... same error returns when I press the "Update Library Catalogs" button.  See screenshot below.  Thanks for any help you can provide,   Mark
      PS -- I'll add commentary that we are a bit frustrated with the new library format -- it changes (probably due to user farble) and it's not very intuitive how to return to the format we were used to when searching libraries, getting confused when there is a filter set (that makes catalogs disappear).   Yes, we can work with it, but seriously lacks some intuition it used to contain. 
      PSS -- Also a bit confusing with Catalog Updates:  If the Time Tracker timeout pops up during a catalog install or library catalog update -- the program appears to FREEZE during operation with no way to take action.  This happened when installing the HUGE Kohler catalog and Task Manager said CA was NOT RESPONDING.  I was about to force it to end, when it suddenly finished.  It should never freeze preventing any action, like accepting the Time Tracker.   And either way -- a Catalog Update always leaves the last catalog showing as 100% completed when the attached error message shows up, leading one to believe THE ERROR MESSAGE APPLIES TO THE LAST CATALOG until you carefully read the message (in my case:  message for CAD BLOCKS and Last Catalog: ZLINE.   Not related.)
      Thanks for listening to the PS/S  ...

    • By SNestor
      So, if you specify "roof trusses" in the structure tab of the roof build dialogue and specify zero inch heel height...the top chord of the truss sits at the outside edge of the wall main layer. 
      Is this a bug...or, do we always have to specify a heel height when specifying trusses?