thorn-ecoc

X6 Toolbar - Child Tools

Recommended Posts

Wondering if I'm missing something, or just need to adapt.

 

I have always used child tools.....when opened, the child menu would appear to the right, on lower of the 2 main tool bars.

In X6, it appears I can either have a floating child menu bar, dock it to either side, or below the 2 main tool bars.

Below seems to work for me, but does take up some screen space. When the "tabs" are also present, I loose even more drawing space.

 

So I guess my questions are, can I get the child menus to open or dock on the main tool bars?

Or, do I just deal with either using drop down menu's or less drawing space?

Share this post


Link to post
Share on other sites

I posted a similar item on a different thread yesterday on other X6 issues. I guess I should have started a separate thread on this one. Before X6, I was able to have the child buttons display "on" the same toolbar (which I customized) as the parent. When I clicked a parent button the child buttons would change accordingly and show up right under the parent group. Worked great for me. I have tried everything and cannot get this functionality back. I have the floating child toolbar next to my floating parent toolbar. I prefer to float them as opposed to fixed location. I move them when needed and I get considerable more screen space.

 

Mike Blackwood

Share this post


Link to post
Share on other sites

I'm with you on the child tools and would still prefer them -

 

the menue bar is ugly where ever you put it than where it was always stationed for all versions going back to V4 where I started - now it can not be placed there, why not - it is wider than the others and messes with everything around it - have gone to drop down which I did not like and still do not - the menue bar is removed if you chose drop down.

 

I never had problems with tool bars by selecting "all views" when placing them - that option was also removed and now the toolbars are unstable and moving from one session to another ...

 

rather than improve toolbar stability they have made it worse particularly by deciding the child menue bar should not remain where it was, affecting alll bars aroud it, or the option even to place as origonally out of the way and easily identifiable.

 

* spelllll check for some reason does not work in this forum ... firefox.

Share this post


Link to post
Share on other sites

I, too, have a problem with the toolbars refusing to stay put. They change their size mostly and not only from session to session but from view to view as I work. I am constantly resizing them back to a squarish (I know, not a word) shape instead of the telephone pole they resort back to. I choose to float most of my toolbars and that is probably why they move so much. But for me, the fixed locations take too much mouse travel. My wrist gets tired enough already without having to constantly move all the way across the screen to pick a new tool.

 

Spellchecker? I don't even see a spell checker.

 

Mike

Share this post


Link to post
Share on other sites

I was about to post and then read this. My problem is a bit different this time (although I've experienced all the ones described here). One of the new aspect of X6 that I really like is when I for example select the measurement drop down tool, all the available options appear to the left of the screen. Suddenly that went away, so no I actually have to select one of the drop down choices. I've even reset the toolbars to no avail. 

Share this post


Link to post
Share on other sites

I was about to post and then read this. My problem is a bit different this time (although I've experienced all the ones described here). One of the new aspect of X6 that I really like is when I for example select the measurement drop down tool, all the available options appear to the left of the screen. Suddenly that went away, so no I actually have to select one of the drop down choices. I've even reset the toolbars to no avail. 

 

Adam,

 

Go to the View menu and select Tool Palette, that should turn it back on.

Share this post


Link to post
Share on other sites

I just upgraded to X6 and am having the same issue with the child tools not being to the right of the parent on the same line.

Did anyone come up with a way to make that happen as it did in X5 and earlier?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27612
    Total Members
    6254
    Most Online
    kBdesignND
    Newest Member
    kBdesignND
    Joined