Household

3D Graphics Not Rendering in X10 on Windows 10

Recommended Posts

I just got a new Windows 10 laptop with a Intel Iris Xe graphics card.  I installed  Chief Architect X10 and opened my existing plans, as well a new one.  The materials in the 3D camera view are all messed up.  I read on the support documentation that the graphics driver might need to be updated, so I contacted HP and got that fixed.   The problem seemed to be resolved for some materials but not for all.   Chief Architect says the graphics card is supported but I just don't know what to do. The attached pics are what this bathroom looks like on my new laptop and what it looked like before with the materials rendering correctly.  After buying the new laptop I can't afford to update Chief Architect too.  Anyone have suggestions?

Capture.PNG

Capture2.PNG

Share this post


Link to post
Share on other sites

https://laptoping.com/gpus/product/intel-iris-xe-g7/

 

 Question
Pat S. – January 19, 2021

Software I need to download says
“ 3D class video card with 1 GB of memory or higher and support for hardware acceleration.” Is the Intel Iris Xe sufficient?

 Notify me of replies

 


Dan – January 19, 2021

Hi, generally the Intel Iris Xe isn’t a “3D class video card”. It’s an integrated graphics processor which uses the notebook’s main memory since it hasn’t its own. It is much weaker than what’s usually considered to be 3D class video cards with their own memory. For example, the Nvidia GeForce GTX or RTX series with 4GB, 6GB, or 8GB video memory.

Nevertheless, the Iris Xe is a good performer in comparison to other integrated graphics processor and it can utilize 1GB of the main system memory. It’s possible that it can work with your software, but still it will run graphics operations much slower than real video cards.

Share this post


Link to post
Share on other sites

Maybe posting a plan and trying to run a render on different user's computers and see what the outcome will be.

Share this post


Link to post
Share on other sites

I'm having similar issues with a new HP Spectre. Views are overshaded unless I zoom in. I did try to download the latest drivers which did not help. It's obviously an XE issue because it's not happening on my main rig with a dedicated gpu

Share this post


Link to post
Share on other sites
On 2/11/2021 at 9:33 PM, Chopsaw said:

Check your Render settings in Preferences such as "Hardware Edge Smoothing" and "Texture Compression"

 

What video card was in your last laptop ?

 

https://www.chiefarchitect.com/products/sysreq.html

This was the issue. I checked texture compression under render preferences and that solved it.

Share this post


Link to post
Share on other sites
23 minutes ago, Steve-C said:

This was the issue. I checked texture compression under render preferences and that solved it.

 

As far as I know that is not actually a solution.  It just allows you to keep working on a system that is not capable of properly rendering the scene.

Share this post


Link to post
Share on other sites
18 hours ago, Chopsaw said:

 

As far as I know that is not actually a solution.  It just allows you to keep working on a system that is not capable of properly rendering the scene.

I don't know, I'm getting pretty decent 3D renders now from Xe graphics. It's a laptop intended mainly for meetings and travel so it doesn't have to be stellar, just decent.

Share this post


Link to post
Share on other sites

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    29331
    Total Members
    9156
    Most Online
    KayKeller
    Newest Member
    KayKeller
    Joined