robdyck

Find/Replace Text

Recommended Posts

I thought I'd give the find/replace text tool a try and it doesn't appear to work (in this case). According to the Help page, I'm doing it correctly, yet it can't find the rich text shown on the screen. In the find/replace tool, I used a copy of the text in question so there's no typing errors. Hmm...I'll try a few more. Any tips from other users would be appreciated!

image.thumb.png.dfc964ea185a8c068f83fb03c140c0e6.pngimage.thumb.png.ba330eb1b8972d7a77afa083c7313a49.png

Share this post


Link to post
Share on other sites

And the next logical try provided the desired results! I limited the text choice to text that is 'within' the desired text. Bingo! I can't believe that in 20 years I've never used this tool!

image.thumb.png.ec2144bbd83dc98b3cf4464305e4c38e.png

Share this post


Link to post
Share on other sites
4 minutes ago, robdyck said:

I can't believe that in 20 years I've never used this tool!

We've only had it in Chief since the release of X11

Share this post


Link to post
Share on other sites
1 minute ago, Alaskan_Son said:

We've only had it in Chief since the release of X11

Alrighty then! So it's true... you don't know what you don't know!

Share this post


Link to post
Share on other sites
18 minutes ago, robdyck said:

I thought I'd give the find/replace text tool a try and it doesn't appear to work (in this case). According to the Help page, I'm doing it correctly, yet it can't find the rich text shown on the screen. In the find/replace tool, I used a copy of the text in question so there's no typing errors. Hmm...I'll try a few more. Any tips from other users would be appreciated!

image.thumb.png.dfc964ea185a8c068f83fb03c140c0e6.pngimage.thumb.png.ba330eb1b8972d7a77afa083c7313a49.png

Silly question--maybe not---but did you perhaps forget to click Find Next or Replace All?

Share this post


Link to post
Share on other sites
Just now, Alaskan_Son said:

Silly question--maybe not---but did you perhaps forget to click Find Next or Replace All?

Not a silly question! With that first example I clicked and tried everything until I was out of breath! I tried that particular rich text box because I know exactly where the 2 instances are located. I tried 2 forms initially:

-right clicked the text box, control-c, then control-v into 'find/replace tool'. Didn't work.

-opened the rich text box, highlighted the entire text selection, control-c, exit text dbx, then control-v into 'find/replace tool'. Didn't work.

Share this post


Link to post
Share on other sites
5 minutes ago, robdyck said:

Not a silly question! With that first example I clicked and tried everything until I was out of breath! I tried that particular rich text box because I know exactly where the 2 instances are located. I tried 2 forms initially:

-right clicked the text box, control-c, then control-v into 'find/replace tool'. Didn't work.

-opened the rich text box, highlighted the entire text selection, control-c, exit text dbx, then control-v into 'find/replace tool'. Didn't work.

 

Strange, because I can't replicate.  It always seems to work for me.

Share this post


Link to post
Share on other sites

I just did a quick trial: the reason (I think) it can't find that text selection is due to format of the original rich text. It is from my library, and has been typed over 2 lines as opposed to having it's textbox resized to make it display over 2 lines. The 'find/replace' tool doesn't like that.

image.thumb.png.4e2502d80c63d03226c89afbb23054ea.png

Share this post


Link to post
Share on other sites

This would appear to be one of the issues of having at least 2 different types of text inherent in the program. Kind of like how spell check isn't available within the custom object fields dbx. And kinda like grids aren't available in rich text. There's probably quite a few other text pet peeves or inconsistencies ( or whatever you want to call them) that other uses woul have examples of.

Share this post


Link to post
Share on other sites

It seem to be that the carriage return is the problem.  It appears as if though it isn't actually getting pasted into that particular dialog box.

Share this post


Link to post
Share on other sites

Along these lines, I tried to 'check spelling' of a door schedule where I purposely entered some incorrect spelling into the 'comment' field of 1 door.

The spell checker will find it, but even though I click 'replace', and it moves to the next selection, there is no change to the schedule.

Share this post


Link to post
Share on other sites
4 minutes ago, Alaskan_Son said:

It seem to be that the carriage return is the problem.  It appears as if though it isn't actually getting pasted into that particular dialog box.

Yup. The entry field doesn't 'support' a full or identical rich text copy. Would you consider this to be an issue that needs to be addressed by Chief? It seems to me that all text features within the program would need to be amalgamated into only one type of text box/field. I'm sure that's no big deal for Chief's programmers!

Share this post


Link to post
Share on other sites

Yes it should be fixed.

This is a new tool & need rigorous testing by users.

PLEASE REPORT YOUR PROBLEM.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    28622
    Total Members
    9156
    Most Online
    rainrow
    Newest Member
    rainrow
    Joined