Chiefer

Raytrace: No more lightbleed

Recommended Posts

Folks, attached is the cause of all your lightbleed misery.

 

Sol'n: Uncheck "use camera view settings" and make color white. Thank you!

 

misery.thumb.jpg.73d2d1c806d8e042e9e0f6c72a0fa9cc.jpg

  • Upvote 2

Share this post


Link to post
Share on other sites

Fantastic!!!!!

Now why was that setting not the default in the first place?

  • Upvote 2
  • Downvote 1

Share this post


Link to post
Share on other sites
2 hours ago, Chiefer said:

Folks, attached is the cause of all your lightbleed misery.

 

Sol'n: Uncheck "use camera view settings" and make color white. Thank you!

 

misery.thumb.jpg.73d2d1c806d8e042e9e0f6c72a0fa9cc.jpg

 

Are you certain about that? All of the samples I posted have the use camera view setting unchecked. I never use the camera view settings in my Ray Traces.

Share this post


Link to post
Share on other sites

 

9 hours ago, Joe_Carrick said:

Fantastic!!!!!

Now why was that setting not the default in the first place?

Chief's good intention is for an unbiased rendering thus the default settings but It does not help much,

Share this post


Link to post
Share on other sites
8 hours ago, TheKitchenAbode said:

 

Are you certain about that? All of the samples I posted have the use camera view setting unchecked. I never use the camera view settings in my Ray Traces.

101% certain.

 

It's because your ray traces always depend on LIGHTS, now try to render an interior scene without a single light source with your settings,

Share this post


Link to post
Share on other sites
7 hours ago, Chiefer said:

101% certain.

 

It's because your ray traces always depend on LIGHTS, now try to render an interior scene without a single light source with your settings,

 

The reason I asked was not to say that unchecking the Use Camera View Settings would not have a beneficial effect. Based upon my testing I would expect it to be beneficial as it would potentially reduce the luminosity(brightness) of the exterior lighting. If I look at the settings you posted I would not really expect any light bleed issues regardless of whether or not one has any interior lights on as they are not really dissimilar to what I normally use, expect that I tend to use the colour versus the sky under environment light.

 

When I posted those extreme examples in the other thread I did run a number of other configurations which included using the sky versus the backdrop under environment light and found that these also had a positive effect in reducing light bleed as did reducing the luminosity if one used the color setting. The point I have been attempting to make is that the light bleed is the result of having too high of a luminosity(brightness) exterior light level. Depending upon ones other settings this can be reduced through a variety of methods, reducing the direct sun level, reducing the environment level or using the sky or backdrop, reducing the luminosity level of the sun and also by unchecking the use camera view setting. Also, depending upon these settings placing a roof on the structure has a positive effect and if the environment light is being used then having a foundation with a floor also impacts on this, in fact I also found that having a terrain made a difference concerning the environment light effect.

 

Will take a look at interior lights on versus off to see what role they played in all of this.

Share this post


Link to post
Share on other sites
16 minutes ago, Joe_Carrick said:

I got a -1 for that post?  very strange indeed.

 

Just for the record, it was not I. I have never issued a negative to anyone. Would never have crossed my mind and certainly not to Joe who is such a great contributor to all.

Share this post


Link to post
Share on other sites

Just ran a comparison with the interior lights off versus on.

 

The Use Camera View Settings is off, Direct sun at max, Environment lighting at max, color 255,255,255, no roof or foundation.

 

Interior Lights Off

59dd0ee6a8944_Sun50_EL100_Color100_RoofNo_FoundationNo_InteriorLightsNo.thumb.jpg.0fe6614f84c62441b91c5a6226d6f017.jpg

 

Interior Lights On

59dd0f16ded86_Sun50_EL100_Color100_RoofNo_FoundationNo_InteriorLightsYes.thumb.jpg.b56dec304bc9bccf2e0a90ca261cbfec.jpg

 

I did not find any discernable difference in the degree of light bleed as a result of having the interior lights on or off. If anything, the light bleed is less evident when the lights are turned on, this would be expected as the turned on lights have reduced the interior contrast level.

 

I have run a number of other Ray Traces at many differing settings and to date I can only find one sure relationship concerning the degree of light bleed, the greater the exterior luminosity the greater the chances are that light bleed will occur.

 

Share this post


Link to post
Share on other sites
2 hours ago, TheKitchenAbode said:

Just ran a comparison with the interior lights off versus on.

 

The Use Camera View Settings is off, Direct sun at max, Environment lighting at max, color 255,255,255, no roof or foundation.

 

 

 

Why would a normal user use maxed settings?

 

 

Share this post


Link to post
Share on other sites
3 minutes ago, Chiefer said:

Why would a normal user use maxed settings?

 

 

 I'm not suggesting that these settings be used. They are part of a series of test runs that where done using a wide range of settings. Using the max setting allows one to evaluate what effects what. If something reduces the light bleed under the most sever conditions it will have a similar relative effect under less sever conditions. A 100% solution to any problem is one that works under all conditions.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27478
    Total Members
    6254
    Most Online
    Oilersfan20
    Newest Member
    Oilersfan20
    Joined