architect

Sidewalk and curb offset in 3d

Recommended Posts

The pictures show a plan view and 3d view of a curb and side walk in x9.

Although the sidewalk is drawn to the backside of the curb in plan it shows 6" away from the curb in 3d.

This is most disturbing.......Hopefully it is user error and I am missing an inside-out setting or something.

 

Also, prior versions (x8) had the curb "handles" at the back side of the curb but has been moved to the inside face of the curb.

I am no longer able to "fill" the curb itself within plan view.  Any way to fill in the curb other than creating another cad polyline and layer.

 

Thanks Again,

Eric

curb plan view.jpg

3d vurb view.jpg

Share this post


Link to post
Share on other sites

Move your sidewalk over so that it lines up

with the inside of the curb in plan view.

Image7.png

Share this post


Link to post
Share on other sites

Thank you for your feedback.

 

The problem being that in real life a sidewalk bumps up against a 6" wide curb not over it.

Faking it to show it correctly in 3D creates all sorts of 2D drafting and area calculation problems.

 

If I start a drawing from an old x8 plan with the curb handles the "old way" it works correctly in x9.

Copying an x8 era curb into a new x9 file does not.

 

Eric

.

Share this post


Link to post
Share on other sites

Upon further review.... I see what you are saying.

For some reason the center of the sidewalk now

snaps to the street side of the curb, thus creating

the problem. In X8 the center of the sidewalk used

to snap to the sidewalk side of the curb. Looks

like a bug to me. You might want to report it.

While you're at it ask them why the center of the

sidewalk is used as the snap point? Seems like we

should be able to choose either edge as the snap

point. I didn't see anything in the defaults to change

this behavior.    

Share this post


Link to post
Share on other sites

Definitely looks like a bug to me.  The curb is getting drawn correctly in plan view but is getting extruded inside the road polyline instead of outside like it should be.  Here's what a 12' wide road road with a 4' wide curb looks like in plan view...

59ad6aa986e98_Road2.thumb.png.f8fe5a53d459fbfd298f17abf0a77602.png

...and in 3D...

59ad6b1f69fde_Road3.thumb.png.6f5fa0bc61c5e8a92a6249721b062a69.png

Notice how the selection area in 3D seems to coincide with the plan view...

Road.thumb.png.3d9e0e6ec8739185f54f101dc7dc6205.png

Definitely needs to be fixed.

Share this post


Link to post
Share on other sites
2 minutes ago, dshall said:

I am not having the problem.

 

59ad8eda8afa0_ScreenShot2017-09-04at10_34_18AM.thumb.png.842c447d3d23ecc60144ec3d2677fbf1.png

 

Oops,  my bad,  I auto built the sidewalks next to road and never noticed that 6" of sidewalk sits on 6" of curb.

 

Sorry for my mistake. Nice catch.

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you Chief for fixing this in new x10 release.

Now I just need to be able to show that ADA curb ramp....

 

Eric

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27849
    Total Members
    6254
    Most Online
    goshgolly
    Newest Member
    goshgolly
    Joined