DTCBuild

Question for Mac users

Recommended Posts

I am running X8 on an Imac I7 27" with a second display connected (Samsung 26"). Moving the cross hairs on the Samsung is smooth but on the Mac is very jerky. I have tried different resolutions with no improvement. The cursor moves smoothly on all other software. Any suggestions appreciated.

A second, less annoying problem, is lately my icons are re-arranging themselves. This was a problem in an earlier release, but I thought it had been fixed.

 

Regards

Dennis

Share this post


Link to post
Share on other sites

I would be interested to hear if tech support resolved this issue. I've use CA X7 and X8 on two Macbook pro laptops and when I use a mouse it's very jerky, the trackpad however is smooth as silk. Fortunately when I'm on the Macbook I'm more inclined to use the trackpad anyway but I don't really have a choice in the matter because of this issue. I have no trouble with the mouse on any other application, only CA. This is also one of the reasons I bailed on my iMac a couple of years back.

Share this post


Link to post
Share on other sites

I'd like to hear the tech response as well. It seems odd. I use an intuit tablet since I do a lot of video editing,. animation and graphics.

I have three macs and one PC, but rely on my imac most.

 

THX

 

Larry

Share this post


Link to post
Share on other sites

Im using a track pad with my 27' iMac with no issues to report. However I have noticed my icons rearranging themselves even when I have the tools bars locked. I thought it was just me going mad ! 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27357
    Total Members
    6254
    Most Online
    MarkMMV
    Newest Member
    MarkMMV
    Joined
  • Similar Content

    • By clarkbreyman
      Working on a very simply model (my first - just a kitchen) in X11 on MBP 13 2018 (16GB ram, Quad i7). I started getting lock ups when using materials and things have progressed to more random lockups opening views and panning. 
       
      The most recent stack trace looks like this at the bottom:
       
      47  qtrender::CAOpenGLWidget::paintGL() + 169 (CAInterior + 19921801) [0x10befdb89]
        47  QMetaObject::activate(QObject*, int, int, void**) + 2320 (QtCore + 2219168) [0x127728ca0]
        47  qtrender::LayeredCanvasGL::paintLayers(bool) + 183 (CAInterior + 19950759) [0x10bf04ca7]
        47  qtrender::LayeredCanvas::paintLayersCore(bool) + 322 (CAInterior + 19941442) [0x10bf02842]
        47  qtrender::CanvasLayer::doPaint(bool) + 76 (CAInterior + 19922860) [0x10befdfac]
        47  qtrender::CanvasLayer::paint(qtrender::PaintTarget&) + 55 (CAInterior + 30269943) [0x10c8dc1f7]
        47  QMetaObject::activate(QObject*, int, int, void**) + 2320 (QtCore + 2219168) [0x127728ca0]
        47  CanvasPaintGLController::paintGL(qtrender::PaintTarget&) + 164 (CAInterior + 7998116) [0x10b39eaa4]
        47  CanvasPaintGLController::paintScene(qtrender::PaintTarget&) + 727 (CAInterior + 7998983) [0x10b39ee07]
        47  qtrender::PaintTarget::Painter::~Painter() + 31 (CAInterior + 19973631) [0x10bf0a5ff]
        47  qtrender::FramebufferPaintTarget::endPaintImpl() + 121 (CAInterior + 19929321) [0x10beff8e9]
        47  render_engine::RenderableMesh::drawImpl(render_engine::GpuResourceContext&, unsigned long) const + 1154 (libCARender.dylib + 1362338) [0x11f50e9a2]
        47  glDrawArrays_GL3Exec + 254 (GLEngine + 696989) [0x7fff3eff729d]
        47  glrIntelRenderVertexArray + 254 (AppleIntelKBLGraphicsGLDriver + 58310) [0x7fff2c5323c6]
        47  GenContext::ProgramPipeline() + 16522 (AppleIntelKBLGraphicsGLDriver + 76968) [0x7fff2c536ca8]
        47  void updateBindingTable<SGfx3dStateBindingTablePointers>(GenContext*, unsigned int, SGfx3dStateBindingTablePointers&) + 2647 (AppleIntelKBLGraphicsGLDriver + 89325) [0x7fff2c539ced]
        43  IOAccelContextAddResource + 8 (IOAccelerator + 9304) [0x7fff58820458]
       *38  hndl_alltraps + 223 (kernel + 928079) [0xffffff80002e294f]
       *29  user_trap + 684 (kernel + 2512220) [0xffffff800046555c]
       *29  exception_triage_thread + 417 (kernel + 1300561) [0xffffff800033d851]
       *24  exception_deliver + 1295 (kernel + 1299935) [0xffffff800033d5df]
       *23  mach_exception_raise + 269 (kernel + 1692381) [0xffffff800039d2dd]
       *16  mach_msg_rpc_from_kernel_body + 268 (kernel + 1320764) [0xffffff800034273c]
       *16  ipc_kmsg_send + 309 (kernel + 1148453) [0xffffff8000318625]
       *13  ipc_kobject_server + 568 (kernel + 1317272) [0xffffff8000341998]
       *13  ??? (kernel + 1693962) [0xffffff800039d90a]
       *7   catch_mach_exception_raise + 103 (kernel + 1614855) [0xffffff800038a407]
       *3   handle_ux_exception + 387 (kernel + 7494691) [0xffffff8000925c23]
       *2   IOLockLock + 33 (kernel + 2480657) [0xffffff800045da11]
      Kitchen1213B.plan
    • By acquavella
      Hello! I'm using X7 Interiors as I specialize in kitchen and bath.  I recently bought a new iMac (specs below) hoping that Chief Architect would work better as it would suddenly quit with errors when I was running it on my 2013 MacBook Pro.  The random quitting still occurs (which is annoying, but that's not my question here); however, ray trace which, ironically, worked on my 2013 MacBook Pro will not even start on my 2017 iMac.  I receive the following error:
       
      /Users/autobuild/p4sync/dev/releases/17/chief/source/raytrace.cpp(619): Error #272032202
      "Unable to open ray tracing engine - ray tracing disabled for this session."
      10/24/2018 10:49:20 PM
      Build: 17.3.2.2OSX
       
      I've already tried their suggestions... I made a simple plan and it still came up with the error.  Then I checked for updates in both Chief Architect and my system and they are up-to-date.
       
      I plan on upgrading in December to the newest Chief Architect assuming these problems will go away... but I'm scared that they won't.
       
      Any help or ideas would be appreciated! Thanks!
       
      Chief Architect Interiors X7
      Build: 17.3.2.2OSX
       
      iMac (Retina 4K, 21.5-inch, 2017)
      3.6 GHz Intel Core i7
      Memory: 16 GB 2400 MHz DDR4
      Video: Radeon Pro 555 2048 MB
    • By usingchief
      I am contemplating purchasing a new MacBook pro.  Currently I have a mid-2014 version, 2.5 GHZ, Core i7,... now running Mojave OS, have 16GB Memory / Graphics card: 750M/2048MB.  Sometime CA runs SO SLOW especially when opening up the library.   Any advice from Mac people who use CA on their MacBook pro would be appreciated. ;-) 
    • By KTransue
      Am I the only one having problems getting Function Keys to work on a MacBook Pro (with the Touch Bar feature)?  They didn't work on my 2016 model, and still don't work on my new 2018 model.  Function Keys do perform their expected behaviors as assigned by the operating system, but not as "Hotkeys" assigned within Chief Architect.  I am concluding that CA has not tested or remedied Function Key behaviors on Mac notebooks newer than 2015, and that they must not be supported on these newer Macs.  Am I wrong about this?  Please tell me I'm wrong about this...
    • By aHughJassDude
      So I don't know what the heck is going on here. I'm using several PDFs on my layout (like I've done many time before) and for an unknown reason the line weight on the PDFs are really faint when I use the Chief Architect Save as PDF option to print. The Preview and the Layout both show the line weights on the PDFs at the correct weight. It's only when I save out the PDF that it goe faint. Nothing else on the drawings change. The weight for everything drawn in Chief is good. The PDFs themselves have the correct weight when you open them. It's ONLY when I'm saving out the PDF that the line weight gets reduced on ONLY the PDFs. 
       
      See the photos below. They demonstrate what's happening.
       
      1.
      2.
      3.
       
      Here's what I've tried already with no change:
       
      -Run in in both black and white
      -Save the PDFs to the Layout file
      -Toggle line weight on Layout on/off
      -Adjust DPI