madcowscarnival

Modifying room label with additional text

Recommended Posts

Where is the default information for the Room Label located?  When I go into default settings->Floors and Rooms->Room Label I can add a macro (Room Height in particular), but cannot see the "Room Type" or "Room Dimensions" macros.  When I place the Height macro in the "Text" area, it places this information on the same line after the "type" label

 

<Room Type><Room Height>

<Room Dimensions>

 

  If I place the height on the second line, it places the information below the label, but above the dimensions.

 

<Room Type>

<Room Height>

<Room Dimensions>

 

I am trying to place the Room Height at the bottom of the label.  How can this be accomplished?  A follow-up question: is it possible to "refresh" the existing labels on the drawing to have them display the new label data without opening the dbx, turning off "show label", closing, re-opening, reselecting "show label"?  I'm not having any luck with CA KB or Forum search.  Thank you.

 

Share this post


Link to post
Share on other sites

ct1.thumb.jpg.625daedfa00be3b174d125685fc1ba1d.jpg

 

I'm not clear on what the issue is.

Share this post


Link to post
Share on other sites

Solver, thanks for the reply.  When I place those three macros in that text area, it results in a label that generates this:

 

<Room Label><Room Label>

<Room Dimensions>

<Ceiling Height>

<Room Dimensions>

 

What I'm trying to do is simply place the <Room Height> label below the <Room Dimensions> in the default room label.  As is, using that default text area, placing those macros inserts them between the Room Label and Room Dimension in the default label.

Clipboard01.png

Clipboard02.png

Share this post


Link to post
Share on other sites

This isn't smoothly done, but it demonstrates my issue.  When I add macros, they insert between the room label that's already there.  If I try to control the labels that always show up with layer controls it grabs the "always on" labels as well as referenced macros.

 

Share this post


Link to post
Share on other sites
2 minutes ago, madcowscarnival said:

This isn't smoothly done, but it demonstrates my issue.  When I add macros, they insert between the room label that's already there.  If I try to control the labels that always show up with layer controls it grabs the "always on" labels as well as referenced macros.

 

...now turn off the Rooms, Interior Dimensions Layer as Eric showed.  

Share this post


Link to post
Share on other sites

I did see your post Solver, and had tried the layer control.  Somehow when I performed this action, it seemed the layer control-> "Rooms, Interior Dimensions" turned off the default label as well as my macro label for room dimensions.  Have repeated this morning more thoroughly, labels are now functioning as intended.  Thanks all.

Share this post


Link to post
Share on other sites

CA shows the Interior Dimensions by default , turn them off in the ALDO so they don't interfere, and then use the Macro in the label for them above the Ceiling height. You don't need the Room type macro as CA adds that automatically...if the Room Name is different than the Type you may want to use it though?

 

image.thumb.png.c9394b9af664704f963829f40cb93627.png

 

 

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27602
    Total Members
    6254
    Most Online
    Floriance
    Newest Member
    Floriance
    Joined