J_Ward

Limit CPU when Ray Tracing

Recommended Posts

I just jumped from X7 to X9. In X7 there was a setting regarding letting Chief still be usable while there where ray tracing going on in the background. The defaults in X9 are clearly to use all of the CPU and it really makes using the rest of Chief difficult. Where are those settings now? I need to save some horsepower for other things.

 

Thanks

Share this post


Link to post
Share on other sites

They are under Preferences, Ray Trace. You can set the number of dedicated cores. By default this is set to max. Usually a reduction of one or two cores should do the trick, especially on older systems.

 

Graham

  • Upvote 1

Share this post


Link to post
Share on other sites

You can also "Set affinty" in Windows Task Manager...

Step 1.pngStep 2.pngStep 3.pngStep 4.png

 

You can control core usage for any and all tasks/apps this way.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27861
    Total Members
    6254
    Most Online
    mmebsc
    Newest Member
    mmebsc
    Joined
  • Similar Content

    • By pgjacob
      HI All
      I am ray tracing a scene with a 3D plant (from sketchup) and the shadows are showing squares rather than the actual shadow of the plant (1 pass image shown below).  I have purposely moved the sun around to cast shadows to the back of the image as I have found manually manipulating the sun gives much better RTs than using natural sun angles (at least for me).  I attach the skp file and what the plant looks like in the object info window of CA.  Any ideas how to get rid of this square shadow?  I uncheck the ray casted shadows in camera tool pre-ray trace, and it looks better but still ray traces with the square shadow.
      Thanks in advance,
      melissa
       
       

      Blue Flax Lily.skp
    • By LeeDrafter
      Hi All, I am trying to achieve a ray trace with a tree in the foreground that sort of frames the picture. Attached is an example of my goal- I did not create the attached jpg. I am getting close by placing a tree close to the camera but mostly out of view, but every tree I have tried is blurry. See the saved camera in the attached file. Then I place another big tree closer to the house to create a shadow on the house/driveway. I will crop that tree out of the final picture. Are there any trees CA has that you recommend for close-up high resolution (5500x3200 pixels) ray trace? I found a thread from the old Chief Talk where they had a similar problem and Larry Kumpost  suggested a high res tree, but I don't know where to find one. Here is the old thread http://www.chieftalk.com/showthread.php?34289-Exterior-Critique&highlight=trees+foreground. Thank you in advance!

      THE ADLER RENDERING.zip
    • By hikerj
      Can anybody tell me why I get ray traces that are really grainy?  I can't find a topic on this.  I am using X9 on a mac. 
    • By kylejmarsh
      I'm interested in building a new Mac setup for running Chief. 
       
      Currently I have a Mid-2014 Macbook Pro, 2.5 GHz Intel Core i7, 4 Cores, w/Nvidia GeForce GT 750M 2048MB GPU. This setup will run Chief Models well until they get to about 3000 SF - by 'well' I mean they are pretty lag-free in 3D mode (with optimized exterior camera i.e. cabinet, interior casing, plumbing layers 'off' to decrease total modeled polygons). I've noticed that on a recent 6000 sf project, I was often waiting for the model to 'rebuild' even getting a dialog at times - my productivity was way down, and I was frustrated (and bored at the same time - waiting for all that refresh time.) In Layout, I'm often waiting for views to refresh / render for me, especially 'plot line' views - even when I'm working with a smaller model, in order to make a set of CD's it seems that I wait just a bit too long for everything to happen - especially if this is my business. So it seems I've located a place where my current setup is lacking.
       
      I'm committed to running a Mac - although the concepts of a setup should be similar even if you're planning a PC.
       
      Mostly I'm using Chief to create models of homes and renovations of 1500 - 4500 sf, and to create Construction Docs from the model. I do a few renderings through the course of the process, but no video exports. Mostly I'm interested in a model that rebuilds quickly, and layout views that update quickly - and if I could eliminate that tiny lag that happens with pretty much every operation - then I'd really be happy.
       
      What do I need Chief to do? 
       
      1. A model that rebuilds quickly
      2. Layout views that update quickly
       
      What Computer do I need to make this happen?
       
      I'm tempted to get a Mac Pro tower from a few years ago which has twin 3GB video cards, bumping me from 2GB to 6GB. This also would have 6 cores, each running at 3.5 GHz - vs. my current 4 core / 2.5 GHz setup. I can get one of these for $1800 - so as soon as it saves me 18 hours it's all gravy after that.
       
      In regards to the Model Rebuilding time, it seems like the video card upgrade won't do much to help my cause. From what I can gather, the model rebuilds itself using only one core, no GPU, and so is entirely dependent on the clock speed of your processor - so going from 2.5 to 3.5 would be almost a doubling, which is nice - but not the kind of gains I was hoping for (but I may just have to settle for).
       
      // I read something recently by a Chief Programmer which said the model had to be rebuilt in a certain order, and thats why they couldn't split it across the different cores. I wonder why they can't at least split each floor level on a core, and the terrain on another core - but I'm not a coder so I can't answer why not. There's probably a good reason.
       
      My question is - and I haven't been able to find any info about it - is what effect does the video card have on Layout Views updating? 
       
      I did some basic testing using the Activity Monitor utility, watching CPU and GPU history as wall as CPU load graphs, and got the following results:
       
      Creating Plot Lines (Layout) seems to rely on the CPU, but seems to split the load across all the Processor Cores. So for this, I assume more cores is better, as well as processor speed. GPU seems to be idle during this process. 
       

       
      Working in Elevation View (actually an orthographic camera of the 3D model). Zooming in and out, the load split across processor cores.
       

       
      Manipulating the model and waiting for the model to update, we also get multi-core activity, and little action on the GPU. The only time we get GPU action is when we look at things in the 3D exterior camera - standard rendering style.
       

       
      So I guess that leaves me with some answers. It basically seems like:
       
      1. The GPU isn't a big deal, and even my 2GB card is pretty good
      2. More Cores + more speed are my friend. Although the graphs don't have a number, watching the percentage on the processor shows that it was hitting 100% during the layout zoom operations - so I'm out of processor.
       
      So this changes what I buy somewhat. Guess I'm looking for Cores + Speed instead of upgrading to a massive video card. Does anyone else have insight to this?
       
       
       
       
       
       





    • By dJanzenINTERIORS
      When doing a Ray Trace the cabinets seem to be lit from the inside.
      There were no lights added to these cabinets and it seems to be happening every time.