Evolution

X8Beta And Surface Pro Question

Recommended Posts

My surface pro 4 i7 was only 18 days old and operating great. I decided to load x8 on it. First day or two wonderful! WOW fast as lightning and so portable. It died over the week end (wouldn't turn back on) and MS tech attempted to help but to no avail. I've since returned it to the retailer and, now have a new replacement.

Cutting to the chase, I am about to load X8 on this one, but thought maybe I should ask if anyone on the forum using the surface pro had encountered the same or similar issue. I did do the MS forum and it seems a large number of folks had the same experience but they don't say if under the same circumstances. not just the 4 i7, but others also). Has anyone on the forum had it happen to them?

Thanks!

Share this post


Link to post
Share on other sites

I went ahead and loaded it on my SP4. So far so good.  The MS forum I'm on continues to get others stating they're having the problem of shutting it down and then not being able to wake it up or turn it on without a hard reset. The hard reset didn't work on my other one, hopefully I want have to deal with it on this replacement. I really love how responsive it is with CAX8 so far.

Share this post


Link to post
Share on other sites

Hmm, I did have something similar happen but I was able to turn it back on

 

Yep, same here with my Surface 1 (2-1/2 years old) and with a brand new Surfacebook.  I was able to get back up and running on both. 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27617
    Total Members
    6254
    Most Online
    zzubin
    Newest Member
    zzubin
    Joined