TomBiggs

Leader line - How to make first segment stay horizontal when moving

Recommended Posts

How do you make the leader line stay horizontal when you move either the object it points to, or the text?  I noticed this was the case on I think the Breckenridge Sample Project, but couldn't figure out how it was done.  Thanks.

Share this post


Link to post
Share on other sites

In the Leader Line dbx there's a setting for ARROW>Auto Position Head.

However, if you are using an evaluated macro in the text box it might cause a problem.

Share this post


Link to post
Share on other sites

Hmm.  When I open up the dialog of the leader line (dbx?)  I see the Auto Position greyed out.  Instead I only can check the Auto Position Tail. See screenshot.  I'm still in version 9.  Maybe they fixed this in 10.

Capture.PNG

Share this post


Link to post
Share on other sites

I struggle with this issue often in V9 & 10 also.  I turn off the auto position buttons and it seems to have no impact on the behavior.  Other issues I have with leader lines is they move when I move an unrelated nearby object or worse get deleted when I delete a nearby object.....they must associate with inadvertently.  I also have issues creating multiple leg leader lines....half of the time it just creates 2 leader lines instead of one continuous line.  Sorry to turn this post into a mini rant on leader lines.  Any enlightenment on this minor issue is greatly appreciated.

Share this post


Link to post
Share on other sites
4 hours ago, mdarch47 said:

I struggle with this issue often in V9 & 10 also.  I turn off the auto position buttons and it seems to have no impact on the behavior.  Other issues I have with leader lines is they move when I move an unrelated nearby object or worse get deleted when I delete a nearby object.....they must associate with inadvertently.  I also have issues creating multiple leg leader lines....half of the time it just creates 2 leader lines instead of one continuous line.  Sorry to turn this post into a mini rant on leader lines.  Any enlightenment on this minor issue is greatly appreciated.

 

The number of segments in the Leader lines is Controlled by the Setting in Preferences >Appearance>Text>Leader Lines  , the default is 2 you can also specified Rich Text (vs text)

 

On 6/8/2018 at 10:19 AM, TomBiggs said:

Hmm.  When I open up the dialog of the leader line (dbx?)  I see the Auto Position greyed out.  Instead I only can check the Auto Position Tail. See screenshot.  I'm still in version 9.  Maybe they fixed this in 10.

Capture.PNG

 

If an Item is greyed out I believe that means it is not associated with an object , the tail usually is as that is the Text... unless you don't create the Text which is possible by cancelling out the Text Input DBX

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    28284
    Total Members
    6254
    Most Online
    GeraldWalsh
    Newest Member
    GeraldWalsh
    Joined
  • Similar Content

    • By amddrafting
      Is there any way to make a new arrow and have it in the list of arrows? I tried making one using the new line tool but no luck. 
    • By RicochetX
      So I’m having an issue with the arrow attachment to objects. When I copy the arrow to different places on my detail, and then delete the original object the first arrow was attached to, it deletes all the copied arrows too. I just deleted a CAD block and lost 5 arrows of my detail. Is there an option to turn off the attachment of arrows to objects? The only thing I saw in the help says, “Lines with arrows can be attached to other objects. They attach to a closed polyline-based object along its edges, but can attach to an architectural object anywhere within its 2D symbol in floor plan view. If an arrow is attached to another object, deleting that object will also delete the arrow.” It seems that even though I’m copying the arrow to a new location it still stays attached to the original object, unless I move the arrow head to attach to a new object and even then it doesn’t always seem to work. I would just as soon not have arrows attach to anything.
       
    • By CRHDesign
      Hi there. In the image below, you can see that the line arrows are only showing up on the exterior walls, while the interior walls have no arrows (the slash). Is there a way to make the line arrows show up at each segment of the dimension? The dimension was made with the manual dimension tool.

      A visual example of what I'm looking to do:
      \--\-------\-\-----\-\-----\-\----\-\-------\--\