X5 & Windows 10


Wildback
 Share

Recommended Posts

Hey Everyone

 

Does anyone know if Chief X5 runs on Windows 10? I only have Sage and Chief on my machine and Sage will have no issues. So was hoping it would be the same for Chief.

 

I have a relatively new PC which Windows 10 supports, so just hoping someone could chuck some helpful comments my way.

 

Thanks for your time.

Link to comment
Share on other sites

  • 4 years later...

November 2020

 

This is an old thread but maybe this will help someone.

 

 

Had a hard drive crash and had to reinstall Chief Ver 10.0 in a fresh install of Windows 10, latest version 1004 with all current updates through November 2020. Yes Chief Architect Version 10/10.08 still works and I am too cheap and hardly use it enough to justify any upgrade. After installing version 10.0 from my saved installation files, Windows 10 would not allow me to open the Chief Architect program as the User Account Control (UAC) security stopped the program from opening. I had to go into Registry Edit and turn UAC off (note many online articles as how to do this and turn it on and off). After the install of Chief Architect 10.0, the program could not find the HASP key. Took a while but I found the following to get new hasp key drivers. I suggest deleting all old Hasp Key drivers (mine were Aladin files/drivers) prior to installing the new downloaded files/drivers (which will be Sentinel). Once I got the Hasp Key recognized I updated to 10.08 and Chief 10.08 works as normal..

 

Go to step 3 for the file to download the drivers. Please uninstall any old drivers first. You may need to insert the hasp key for the files/drivers to show in Control Panel/Device Manager/USB controllers to uninstall them.

 

1.  Went to site: Thales Customer Support Portal at: https://supportportal.gemalto.com/csm/?id=portal_home_page
then using their search look for the following: hasp driver chief architect


2.  That search will lead to the following page:

https://supportportal.gemalto.com/csm/?id=kb_search&q=hasp drivers chief architect

where you will look for: Sentinel HASP/LDK Windows GUI Run-Time-Installer 8.13


3.  This is the download site for the driver:  

 

There no spaces in this address. This thread would not allow word wrap for the long string.

 

https://supportportal.gemalto.com/csm/?sys_kb_id=61fb0ee1dbd2e78cfe0aff3dbf9619ab&id=kb_article_view&sysparm_rank=21&sysparm_tsqueryId=957514cbdb9ce41080b234523996196e
 

 

The following is the file description needed:

Sentinel® LDK and Sentinel HASP® Run-time Environment Installer GUI for Windows
Refer to the Readme file included in the package for details.
 
MD5 (Sentinel_LDK_Run-time_setup.zip) = 2b9a4dc20e6acc32cc9e4636b1d5eafa
   

Sentinel HASP/LDK Windows GUI Run-Time-installer 8.13 after being installed and then checking Device Manager under Universal Serial Bus controllers shows:

Sentinel USB Key
Sentinel HL Key
Sentinel USB Key

all three show the driver version is actually 7.92.0.0 with a date of 03/29/2019

 

Hope this helps.

Bob Schroeder

Sarasota, FL

rschroeder@comcast.net

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

  • Member Statistics

    31608
    Total Members
    9156
    Most Online
    FireflyHomes
    Newest Member
    FireflyHomes
    Joined
  • Similar Content

    • By Kbird1
      ======================================================================================================
      June 28th 2020
       
      *** AS OF VERSION X11 CHIEF HAS ADDED A TOOL TO PREFERENCES TO DO THIS FOR YOU, GO TO
       
      Preferences > General> File Management > File Association    .........     which is at the very bottom of the TAB.
       
      ======================================================================================================
       
      ***Dec. 2018***   For X10 and lower versions
       
      Microsoft has now fixed File associations and you can do it via
       
      Start>Settings>Apps>Default Apps> scroll down to  Choose Default App by File Type near the bottom (not File Protocol)
       
      Now scroll Down and find each Chief File type and change the Default to Chief Architect X10 ( or your version )
       
      X10 should be in the list for each type to choose from for these File Types...
       
      .alb
      .calib
      .calibz
      .layout           (sketchup maybe associated at times with this one)
      .plan
      .undoplan
       
      If Chief isn't listed or a choice above it should offer to look for Other Apps....
       
      so scroll all the way down to "look for other Apps on this PC" (in blue) if X10 is not on the List already and in the Windows Explorer Window go to :
       
      C:\Program Files\Chief Architect\Chief Architect Premier X10 (64 bit) and select the File Chief Architect Premier X10.exe
       
      after the 1st File type (.alb above) X10 should be in the list for the Others and you won't need to do this part again.... you can only change one at a time so do these 6 types...
       
      Mick.
       
       
      ================================================================================
       
      ***Nov 2018***
       
      A recent Windows  10 Update has Broken File Associations for Many Programs . not just Chief
       
      ---------------------------------------------------------------------------------------------------------------
       
      *** EDITED OCT 2018***
       
      It seems the Methods below may no longer work since the Windows 10 1803 Update in April
       
      Some other Options are :
       
      1.) You can also Right Click any .calibz file or .plan or .layout etc  and Choose Open With>CA X10  (scroll Down to bottom if you don't see X10 listed and choose look on PC  (see path below) and Select it, once found look for the Checkbox that says Always Use this App Check it 1st and then hit Ok
       
      The Default Full Path to the CA X10 Program is
      "C:\Program Files\Chief Architect\Chief Architect Premier X10 (64 bit)\Chief Architect Premier X10.exe"
       
      2.) You can also goto Control Panel>Default Programs>Select CA X10 and the Repair Button should appear and you can Use it to repairs Files for the Installed Program, this does not effect Settings etc at least not when I have tried it. This is useful if you re-install X9 or one of the Home Designer Products or an older version of CA, AFTER X10 and they overwrite the Defaults For X10.
       
      To Open Control Panel Right Click START>System> scroll to bottom on the right hand side and Chose System Info under Related Settings. In the top left hand Corner click on Control panel Home>Programs and Features> select Chief Architect Premier X10 (64bit)  and on the Ribbon next to the Organize dropdown Arrow you should see Repair appear, click on it and the Repair will begin. ( it will look like the Installer is running again)
       

       
       
      3.) There is also some Command-line Options available if you are familiar with Dos and the Command Prompt? ask if you need them , I will post them if needed but I don't want people messing their system up by accident.
       
       
       
      ==================================================================================================
       
       
      Original Method
       
      The X10 Upgrade does not seem to have reset the Default Application for .Plan, .layout .calib and .calibz , .alb Files, .undoplan to X10, which is why X9 is still opening when you double Click any of these File Types instead, from reading here on the Forum, it looks like it hasn't done this on the Mac OS either Instruction for Mac High Sierra OS are in Post #2
       
      Chief does not appear to have the ability to re-register default File Types like some Programs do, but it can be done manually via the settings App or Control Panel ( better/easier ).
       
      In Windows goto :
       
      >Control Panel\All Control Panel Items\Default Programs\Set Associations
       
      if that just takes you back to the Settings App , right click the Start Button >Run and it the box copy and Paste this and hit <Enter> :
       
      control /name Microsoft.DefaultPrograms /page pageFileAssoc
       
      goto each File extension. ( list below) and click the Change program button at top right.
       
      scroll all the way down to "look for other Apps on this PC" (in blue) if X10 is not on the List already ( wasn't for me) and in the Windows Explorer Window goto :
       
      C:\Program Files\Chief Architect\Chief Architect Premier X10 (64 bit) and select the File Chief Architect Premier X10.exe
       
      after the 1st File type (.alb) X10 should be in the list for the Others and you won't need to do that again.... you can only change one at a time so do these 6 types...
       
      .alb
      .calib
      .calibz
      .layout           (sketchup maybe associated at times with this one)
      .plan
      .undoplan
       
       
      Mick.
    • By DH7777
      Can anyone tell how I get XVID or any new codec to install into CA so I can choose it as an option when recording walkthroughs? I need to know the "path" I'm assuming because downloading XVID and installing it just puts in on my computer(somewhere) but not in CA. I'm lost here...
    • By Stevenplane
      Good morning!

      I noticed that suddenly I cannot get my entire floorplan to fit on my screen, including the DBX toolbar across the bottom.  I'm 99.9% certain it's some sort of display setting issue.

      I've Google'd and checked Chief and haven't had luck.  (Hard time thinking of the correct search terms for this issue)

      Any suggestions?

      Thanks!
    • By mkeffer
      Hello, 
      I created these files in Chief X5, but we no longer have the licence for Chief.  I recently purchased Home Designer Architect 2018, and would like to open and edit these files with Home Designer.  (I realize some functionality will be lost; that's okay.)  Can someone out there with Chief open these files and click the setting to make these files editable in Home Designer?  (I think the setting is in the File menu somewhere?)  This has worked for similar files in the past.  (I'm using windows 10, if that matters)
      Thanks in advance!
      mkeffer
      oven tub.plan
      yurt 24 furniture.plan
      cabin_36_east_shed.plan
    • By linChief
      Just wanted to share some installation instructions for the older Chief Architect 10 on newer Windows OS, including Windows 10 without using a virtual machine.
       
      The instructions are the same for each OS.
       
      Here are the steps to follow to install Chief Architect 10:

      1.  Install Chief 10 normally
          Note: during the install it will complain about not being able to install the Aladdin Device driver - just click OK.

      2.  Download and install the Chief Architect 10.08b Full Update for Windows Vista (works with Windows 7/8/10)
           http://www.chiefarchitect.com/support/updates/update10fhist.html
          
          Note: during the update it will complain about not being able to install the Aladdin Device driver just click ok.
      3. A) Download and install the following HASP USB Key driver.

          Sentinel HASP/LDK - Windows GUI Run-time Installer – required for HASP4 API older than v8.0
          http://sentinelcustomer.safenet-inc.com/DownloadNotice.aspx?dID=8589947119
       
      3. Optional - One user had a standalone key (Gray Label), that said "SafeNet Sentinel" on it and had to download and install a different USB Key driver:
       
      Sentinel Driver     v7.5.9     Sentinel SuperPro, UltraPro SentinelPro, SHK From:
      ftp://ftp.cis-app.com/pub/hasp/Sentinel_Legacy/SPI/Sentinel-System-Driver-Installer-7.5.9_Windows.zip
       
      4. Finish installation on first run of Chief - Right-click on Chief Architect 10 icon and choose "run as administrator".
          Note: Right-click on the Chief icon and choosing to "run as administrator" for first run, this is not needed after finishing setup during the first run.

      5. If it asks you when it starts up to check for updates for Chief, select No or Cancel since we've already done that by downloading the latest (and last) update for Cheif 10 in step 2 above.
       
      Enjoy your version of Chief Architect 10 on Windows 10 / Windows 8 / Windows 7.