TonyWed

Inserting object from Library Browser freezes most of the app

Recommended Posts

I'm just starting out in Home Designer 2018 on Windows 10 (a new laptop with 16GB of memory and the latest video drivers.

 

The program works well until I try to use the Library Browser to add objects to the design. For example, with search, The first time I use the search is fine but after I add the object to my design and go to search for anything else, the library browser seems to freeze allowing no interaction (e.g. clicking anywhere does nothing) and outside of the Library Browser, in the main design panel, I see no pointer (though it sometimes returns after switching to other Windows apps). I can close the application and get prompted to save but I can't really work in this staccato fashion. The same thing happens when just browsing for the objects, it's OK for the first object but I can't select any more after adding to the design. Maybe the freeze only lasts a certain time but I did leave it for multiple tens of seconds before deciding it wasn't going to come back (it's impossible to work with that sort of a delay anyway.

 

I have seen one crash, I think that's when I left it for a much longer time and tried to get at other design functions without success. I'm not doing anything unusual, as far as I can tell, so this is quite annoying. If anyone has any ideas, I'd be very grateful.

 

If I try to close the Library Browser only during a freeze, it won't close but the second time I click the X on the Library Browser, I get prompted to save the design, as though I'd closed the design.

Share this post


Link to post
Share on other sites

Hi Tony  ,

1st off you are actually on the Chief Architect Forum here ( green theme) you want to be on the Hometalk Forum ( Blue theme) for the Home Designer Products. You can use the same Username and Password Over there too .  Hometalk is here : https://hometalk.chiefarchitect.com/?_fromLogin=1

 

That being said, it is possible that the issue is the Latest Video (Nvidia?) Driver there are a few Issues for some particularly on Laptops. The fix for most has been to install Nvidia Driver version 382.05 and block Microsoft from updating the Drivers Automatically. I have a detailed post and links on how to do that here :

 

https://chieftalk.chiefarchitect.com/topic/16205-nvidia-driver-388xx-series-drivers-and-a-fix/

 

 

Also, it's good to have your Forum Signature filled in please, especially with the Software Version,
and of course a Name is nice too :) ..............see mine below in Blue for how to do that.
If you don't see my Signature then you have them turned off for the Forum or are perhaps on the CA Mobile WebSite.

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Thanks, Mick, and many apologies for using the wrong forum. I will use the correct one in future. I'll also be sure to check out your suggestions. I'm not sure what the graphics driver version has to do with this but I've seen enough strange software issues to not be too surprised.

 

Thanks again for your assistance.

Share this post


Link to post
Share on other sites

No Problem Tony , happy to help if I can, there a a number of posts here from Home Designer Users as CA doesn't make it Clear about the Forum. 

 

Some Laptops actually have 2 VideoCards, an Intel and a discrete Nvidia Card , assign your Home Designer Title to the Nvidia Card if that is , in fact the case for you , use the Nvidia Control Panel , which you can usually get by right Clicking the Desktop to do that.  There maybe a Intel Option too.  It's the other reason to Fill out your signature with you hardware details as at time like this that can be useful info, eg model no# etc so people can help if they can.

 

M.

Share this post


Link to post
Share on other sites

Thanks, Mick. The NVidia control panel didn't have the ability to select applications (though the Intel one did). I tried various settings on the Intel control panel but none seemed to help. The NVidia driver version was completely different to the one you mentioned, so I simply rolled back (only one roll back allowed, it seems) which took it to driver version 23.21.13.8831. Still didn't help so I tried disabling the NVidia controller and, hey presto, that fixed the problem. I can get 3D views and haven't noticed anything not working so that's certainly an option for me now.

 

Thanks once again.

Share this post


Link to post
Share on other sites

try this Tony  , if HD is using the Intel HD Graphics instead that's good but the Performance won't be the same.

 

Since you hadn't assigned the Nvidia Discrete GFX Card to use it for 3D, you may need to though?  I think it is supposed to switch automatically , but that does not always work for Chief and the Home Designer Titles as it is not a Game and does not have a "Profile" in the Manage 3D Tab of the Nvidia Control Panel, so you have to ADD HD 2018 to the List.

 

1.thumb.JPG.1248db31a12cec09c85e2b0cbe696d7c.JPG

 

 

 

If the below does not work I would check your Laptop Manufacturers Website for specific instructions for your Model.

How to change NVIDIA Optimus graphics settings

 

How do I change the graphics processor preferences using the NVIDIA control panel?

NVIDIA Optimus technology allows your computer to automatically switch between the integrated graphics processing unit (GPU) and the NVIDIA GPU. You can manually adjust these settings to change which GPU is used.

Use the following steps to adjust graphics processor preferences.

  1. Right click on the desktop and select NVIDIA control panel.
  2. Select Manage 3D settings.
  3. Click Global Settings.
    Note: To change settings for an individual program, select Program Settings instead of Global Settings.
  4. Select your preferred graphics processor:
    • Auto-Select – Provides a balance between performance and power savings.
    • High-performance NVIDIA processor – Provides optimal performance.
    • Integrated graphics – Provides optimal power savings.
  5. Under Settings, you can adjust the settings for each feature to meet your needs.
  6. Click Apply to save your changes.
 

 

Share this post


Link to post
Share on other sites

I don't know if the Issue is Nvidia Related , I have just seen many reports here on the Forum Lately so I made the Post linked in  Post No#2 here.

 

your Driver Version is actually the last 5 digits of the Number above ie 388.31 which is known to have issues for some , you need to download the Notebook version and install 382.05 from the Iink to my Other Post above in Post No#2....

 

Perhaps do this 1st , then do the Switch above...

Share this post


Link to post
Share on other sites

Wow, the tips just keep on coming! Thanks again, Mick.

 

Disabling the NVidia controller worked for me but I then tried re-enabling but using the NVidia control panel to set Home Designer to use the Intel chip (I'm angry with myself for not seeing that option before but I guess it wasn't obvious under the circumstances - thanks for the instructions). This also works. However, I will keep in mind the downgrade of the NVidia driver (I've actually downloaded it ready) if I ever feel the need to have Home Designer use it again, though it seems to work fine without.

 

Cheers!

Share this post


Link to post
Share on other sites

You will get better Performance if you use the Nvidia Card for all 3D including HD or Chief ,( or gaming) the issue is that HD and Chief don't have built in Profiles in Nvidia's Control panel , so it doesn't know HD or Chief is a 3D App and switch to the Nvidia Card automatically. The laptop is supposed to use the Intel card for 2D work ( cruising the Forums or whatever) , cos it saves battery power.

 

Microsoft forces the latest Drivers onto systems without them via Windows Update which has caused issues in Chief for many as the 388.xx series Drivers especially on Notebooks has been causing weird issues like not being able to open the Label Tab in DBX's.

 

M.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    28009
    Total Members
    6254
    Most Online
    MattBlanc
    Newest Member
    MattBlanc
    Joined