AlvarD

Disappearing floating dormer window

Recommended Posts

I have a roof plane (auto-roofs ON) where if I place a floating dormer and then just move the dormer one inch in any direction, the window in the dormer disappears.  I can add the window back into the dormer manually, and then if I move it again, it disappears again.  In the attached pic, the dormer in question is the one that is selected, at the rear of the gable roof. I have another floating dormer in the the front roof plane of the same gable roof, that works normally and I can move it at will without losing the window. 

 

BTW, this is happening with X11 beta.

 

image.thumb.png.dce30fe4e4ed2a9d82359c5405557b7a.png

Floating dormer problem.plan

Share this post


Link to post
Share on other sites

Don't know why, but note where the selection is shown.

 

ct1.thumb.jpg.df90e8d7f51cd9b7eba3cbf11362e82f.jpg

Share this post


Link to post
Share on other sites
50 minutes ago, solver said:

Don't know why, but note where the selection is shown.

 

ct1.thumb.jpg.df90e8d7f51cd9b7eba3cbf11362e82f.jpg

 

Yes, I noticed that too. Very strange... I may just submit it as an X11 bug and see if they can figure it out. 

Share this post


Link to post
Share on other sites

I have proved that this is an X11 bug and submitted it.  I pruned the house down to a minimum, and it appears that in this plan, when the gable roof has a room below which doesn't have a flat ceiling, it causes the problem in X11. There is something about the way the roof planes and the ceiling interact in X11 that breaks it. In X10 it behaves properly, and I'm unable to break it. 

 

image.thumb.png.4d20cf6a6d54babd86a3b3ffd8d79fa8.png

Share this post


Link to post
Share on other sites

I will have to try this sometime today. I've only had one plan so far in X11 that required two dormers but I did them manually for I had to be real specific on the wall placement for the engineer. This looks like you have a 3 story house right? Sometimes the problem is plan specific so I'll try a 3 story house.

Share this post


Link to post
Share on other sites

I first ran into it on a three-story raised house (two stories on pilings), but have since duplicated it on a single story house. It must have something to do with how the various roof planes are affecting the dormer. Even though I have auto-roofs on, the generated roofs with the current room heights seem to make this problem occur. If you are interested, I have attached the two plans I sent along with the  X11 bug report, showing the single story house dormer working on X10 and not working on X11.  Also, if in X11 I set the room with the large gable to have a flat ceiling, it works fine, so it's only a problem if you want vaulted ceilings. 

 

-Alvar

 

auto float dormer x10 - works.plan

auto float dormer x11 - broken.plan

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    27469
    Total Members
    6254
    Most Online
    THDesign
    Newest Member
    THDesign
    Joined