Why is the program SO SLOW?


blueriver
 Share

Recommended Posts

Is everyone experiencing a slow program since 14?  The program has gotten a bit slower / taxing on the computer since each update since 10 however 14 is becoming unbearable! Does anyone have any tips??!!  I was running the software on a high end gaming laptop (i prefer a laptop so i can take it to jobsites) however i couldn't stand how slow 14 was so i had an IT professional build me a new desktop with a nvidia 3090, which has definitely improved the speed, BUT even with the 3090 when I have a 3D open and i'm editing in the program is takes several seconds to process and the 3D to update! I feel very inefficient.  

 

Any tips welcome and appreciated! 

  • Upvote 1
Link to comment
Share on other sites

This is a huge problem with no answer and I have been dealing with it too. I even bought brand new computer thinking my 6 yrs old Lenovo was issue. It was not,,, because I still have freeze ups. Make sure window drivers and video card are up to date. I had a rtx 3060 in Lenovo and now I have rtx 3080 in new computer. Running windows 10 in Lenovo and windows 11 in new computer. Also make sure you are working and saving to same directory,,, ESPECIALLY your archive and backup files. 

Link to comment
Share on other sites

My guess is that it is something in your plan, maybe too many symbols?

 

This tech article has lots of good general info:

https://www.chiefarchitect.com/support/article/KB-00521/troubleshooting-slowness-in-chief-architect-plans.html

 

If that doesn't help, then post your plan and I bet someone could figure out what is making it so slow.

 

  • Upvote 1
Link to comment
Share on other sites

16 hours ago, blueriver said:

...when I have a 3D open and I'm editing in the program is takes several seconds to process and the 3D to update! I feel very inefficient.

Please define the term '3D open' above. Which 3D view mode are you using? Physically based (RTRT) Real Time Ray Tracing? Which is not Real Time at all and takes several second to process even with a 3090, or standard mode which should render almost instantaneously and is a better mode for "editing in the program" saving the RTRT more for final faster renders over the CPU RayTrace.

 

My older system (below with an older 1080) in standard mode only slows down on the largest of models. I don't use/need RTRT but the older card works great in standard mode.

 

Also might help others if you post your complete systems specs so others might help.

Link to comment
Share on other sites

@blueriver and @ShaneK I am using a 5 year old off the shelf HP with an Nvidia GeForce GTX 750Ti, which does NOT run the real time raytracing, but does everything else very well. I only say all this because I would expect to have multiple issues with my system and I don't so I think your issues are not related to Chief alone, but something on your end that is causing the problem. I always have auto framing, foundations, and roofs on while I am working on an inital design, and I don't have slow downs at all.

 

And @ShaneK where have you been hiding!? Haven't seen you around for a bit.

  • Like 1
Link to comment
Share on other sites

@HumbleChief and @joey_martin i just use the camera view - i like to keep it open while i'm editing the exterior in the plan, no Ray Trace.  @robdyck i might have automatic framing on but i don't think i do - i'll check, i do not use automatic roofs.  

i'm not running hardly anything else on this computer as it's brand new and i've only transferred outlook, chief, and documents so far

 

is this info helpful?
Processor    12th Gen Intel(R) Core(TM) i9-12900KF   3.20 GHz
Installed RAM    32.0 GB (31.8 GB usable)
System type    64-bit operating system, x64-based processor

nvidia geforce rtx 3090

desktop mode 3440 x 1440, 60 hz

bit depth 8-bit


THANK YOU FOR EACH OF YOUR RESPONSES!  If i can provide any other info or you have any tips they are appreciated! 
 

Link to comment
Share on other sites

46 minutes ago, blueriver said:

@HumbleChief and @joey_martin i just use the camera view...

Which camera view? Is your setup defaulting to the RTRT physically based camera view?  Are you using the 3090 card or the onboard video graphics if available?

 

My experience runs exactly parallel to Joey's comments above. I have an older system that is plenty fast in standard camera view. You have one of the fastest systems available so it makes no sense that you're running slow as described. Have you contacted tech support?

 

Can you post a plan for others to test speed and diagnose?

  • Like 1
Link to comment
Share on other sites

From having browsed the forums since X-14 was released, there is excellent information available on how to gain some speed. 

 

Just a few things to add...

 

  • On any given perspective camera (saved in layout) - make sure it's set to update manually - never automatically.
  • Any busy patterns... things like sand, stucco, concrete, and intricate stone patterns... they are known to slow down 2D generation in layout. 
  • If there are any large 3D objects in the plan - try to switch them out for smaller ones - meaning with lower surface counts. 
  • Even with massive memory on your new computer... set the default undo/redo to about 2 at the most. 
  • And as posted in this thread... any framing which is set to be automatically updated can bog things down. Eliminate that option too. 

 

While CA keeps making vast improvements, all of the above features work quite well for a modest home.

 ...meaning that the software should operate with relative ease when the program isn't pulling a heavy load so to speak.

 

Any large projects or plan files however, will certainly benefit from making these minor adjustments.

...looking forward to more user comments. 

 

 

  • Like 1
Link to comment
Share on other sites

20 hours ago, joey_martin said:

@blueriver and @ShaneK I am using a 5 year old off the shelf HP with an Nvidia GeForce GTX 750Ti, which does NOT run the real time raytracing, but does everything else very well. I only say all this because I would expect to have multiple issues with my system and I don't so I think your issues are not related to Chief alone, but something on your end that is causing the problem. I always have auto framing, foundations, and roofs on while I am working on an inital design, and I don't have slow downs at all.

 

And @ShaneK where have you been hiding!? Haven't seen you around for a bit.

Too many irons in the Fire!!! I'm 60 yrs old and trying to get away from contractor world,,,, online design work has EXPLODED with all these Barndominiums. My post frame experience has paid off, and I see you are doing well,,,, I keep track of you just to make sure I'm up to date. 

  • Upvote 1
Link to comment
Share on other sites

1 hour ago, ChiefUserBigRob said:

Not sure if my Alienware R12 with the 3080 would be slow on X14 but I am not willing to switch over from X13 right now to find out. 

Don't blame you a bit. My dinosaur system is working fine but there's nothing worse than slow downs that can't be solved. Still curious about the OP's problem and if it was solved.

Link to comment
Share on other sites

On 9/28/2022 at 11:56 AM, ChiefUserBigRob said:

Not sure if my Alienware R12 with the 3080 would be slow on X14 but I am not willing to switch over from X13 right now to find out. 

I have almost your same setup and no slowness, but it all depends what kind of projects you have going on and what's in them

Link to comment
Share on other sites

On 9/28/2022 at 12:08 PM, HumbleChief said:

Me too. Wonder if the OP got the problem solved?

Sorry for the late reply, I have barely sat down at my desk all week as I have a couple builds finishing up right now.  I am looking at all the suggestions and going to see what i can change settings wise, i'll come back and update!

 

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

  • Member Statistics

    32614
    Total Members
    9156
    Most Online
    FerrellBuilds
    Newest Member
    FerrellBuilds
    Joined