Font Spacing Changed in X14?


jrussel
 Share

Recommended Posts

Hi Folks,

 

I upgraded from X13 to X14 yesterday and immediately noticed that the font spacing changed in my existing X13 files! I think it is the spacing between lines. My leaders don't line up with the text any more. I am forced to go into each view and re-align the leader to the text. I think that when I upgraded, the X14 Chief Blueprint font overwrote the X13 font in the Windows Fonts folder.

 

My question is how do I go back to the previous font when accessing my X13 files? 

 

Thanks,

 

John

Link to comment
Share on other sites

9 minutes ago, jrussel said:

Hi Folks,

 

I upgraded from X13 to X14 yesterday and immediately noticed that the font spacing changed in my existing X13 files! I think it is the spacing between lines. My leaders don't line up with the text any more. I am forced to go into each view and re-align the leader to the text. I think that when I upgraded, the X14 Chief Blueprint font overwrote the X13 font in the Windows Fonts folder.

 

My question is how do I go back to the previous font when accessing my X13 files? 

 

Thanks,

 

John

 

Link to comment
Share on other sites

27 minutes ago, jrussel said:

I am forced to go into each view and re-align the leader to the text. 

This is an ongoing gift from Chief with almost every version. Rich Text will resize if your monitor display scale is changed, Rich Text will resize with almost every version. This creates endless amounts of text fixing with each new version.

Some fonts are also STILL buggered up when used in an elevation marker.

This is an honest question for many users to Chief: Why would you do this to us?

image.thumb.png.3f53d006dc28154e058d62fe8ceac4f4.png

 

Link to comment
Share on other sites

Hi Rene,

 

Thank you for the update. However, I don't have the attributes in my text DBX for X14.

 

I also checked for any program updates, and seem to have the latest version.

 

I also compared the Chief Blueprint font from the X13 data folder to the X14 data folder. The X14 folder has several extra fonts for bold, italic, etc. The X13 folder only has the TTF file. Maybe Chief is upgrading the quality of the font. Either way, it is creating havoc for my older files.

 

Thoughts?

 

John

Text Menu Screenshot.jpg

Link to comment
Share on other sites

1 hour ago, jrussel said:

Hi Rene,

 

Thank you for the update. However, I don't have the attributes in my text DBX for X14.

 

I also checked for any program updates, and seem to have the latest version.

 

I also compared the Chief Blueprint font from the X13 data folder to the X14 data folder. The X14 folder has several extra fonts for bold, italic, etc. The X13 folder only has the TTF file. Maybe Chief is upgrading the quality of the font. Either way, it is creating havoc for my older files.

 

Thoughts?

 

John

Text Menu Screenshot.jpg

Please either tag me or use the quote system, otherwise I do not get notified of a response...I just happened to come back here to check.

You are using Rich Text instead of Text...something I would encourage you to switch away from. Attributes for margins will be in your appearance panel in the dbx you screenshotted

Link to comment
Share on other sites

1 hour ago, jrussel said:

I also compared the Chief Blueprint font from the X13 data folder to the X14 data folder. The X14 folder has several extra fonts for bold, italic, etc. The X13 folder only has the TTF file. Maybe Chief is upgrading the quality of the font. Either way, it is creating havoc for my older files.

 

Chief Did update the Font in X14 and added some extras like Bold, italic etc. , I personally don't use it so probably haven't noticed the Issue so much.Chief shuld of renamed the Font slightly different perhaps so the Old Version and New Version could co-exist on Users computers.

 

M.

Link to comment
Share on other sites

1 hour ago, Renerabbitt said:

Please either tag me or use the quote system, otherwise I do not get notified of a response...I just happened to come back here to check.

You are using Rich Text instead of Text...something I would encourage you to switch away from. Attributes for margins will be in your appearance panel in the dbx you screenshotted

Hi Rene,

 

I get it now! Thank you very much! 

 

What are the advantages of using "text" versus "rich text"?

 

Thanks again,

 

John

Link to comment
Share on other sites

37 minutes ago, jrussel said:

What are the advantages of using "text" versus "rich text"?

You can quickly change a text style on a per layer basis which can be on a Saved Plan View Basis or a Layer Set/Default Set Basis.
A few clicks of a button and you can change all parameters of text using this method, including labels and callouts etc.

Link to comment
Share on other sites

Does Chief plan to fix this?  I've been waiting to upgrade for this very issue.  Based on this thread, I assumed it was fixed.  So I upgraded and bam, spacing issues all over the place on our notes page.  I am not using Chief Blueprint font.  I stopped that a while ago since they kept changing it and got tired of redoing my notes page.  Using a steady font made upgrades smooth.  Now they are messing with the spacing of all fonts.  My screen scale is at 100%.  Trying the margins to zero changed it very slightly, but still way off.  What a PITA.  Not going to upgrade all my machines until this is fixed or a solution provided without me having to redo all my notes...especially if this is going to happen every upgrade.

Link to comment
Share on other sites

Response from Chief...I realize each our issues may be slightly different, but perhaps this helps someone:

 

Quote

This appears to be related to an issue we've been seeing in X14 with certain fonts that aren't default to Windows. This issue is what's causing the additional spacing between the lines when using that font.

Our development team is aware of the issue and are working towards a fix, which we hope to see in a future update to the program. Until then, the only workarounds I can suggest are to either change the font to something like Arial, which fixes the spacing, or set a custom line spacing in the Rich Text Specification to about 85%, which gets close to the original spacing in X13

 

Link to comment
Share on other sites

On 7/29/2022 at 4:51 PM, BenPalmer said:

Does Chief plan to fix this?  I've been waiting to upgrade for this very issue.  Based on this thread, I assumed it was fixed.  So I upgraded and bam, spacing issues all over the place on our notes page.  I am not using Chief Blueprint font.  I stopped that a while ago since they kept changing it and got tired of redoing my notes page.  Using a steady font made upgrades smooth.  Now they are messing with the spacing of all fonts.  My screen scale is at 100%.  Trying the margins to zero changed it very slightly, but still way off.  What a PITA.  Not going to upgrade all my machines until this is fixed or a solution provided without me having to redo all my notes...especially if this is going to happen every upgrade.

There are other font issues...these can show up in the numerical portion of an elevation marker used in a dimension line. This has STILL NOT BEEN FIXED!! 

1865554829_compressedtext2.thumb.jpg.622a2c54b81f028cc874acf752243224.jpg

1977309385_compressedtext.thumb.jpg.2fd8e5ed5a0174ed7b9c7d7759522f5a.jpg

Link to comment
Share on other sites

11 minutes ago, Renerabbitt said:

FYI I don't have this problem, what font are you using, what are your settings on markers for story pole?

Font: Trebuchet MS

image.thumb.png.e792a11cf70188b7bea5987a079c74e1.png

image.thumb.png.fc9bb1a0bba1a873b980561ceacd6d6d.png

Link to comment
Share on other sites

12 minutes ago, Renerabbitt said:

Post a plan?

what the font.plan

In the plan there is an elevation camera with a storypole as well as some text markers (which show the dimension font correctly). There are quite a few fonts that display incorrectly and I sent this plan to TS. If I remember correctly they said they were able to reproduce the problem.

Link to comment
Share on other sites

32 minutes ago, robdyck said:

what the font.plan 4.58 MB · 0 downloads

In the plan there is an elevation camera with a storypole as well as some text markers (which show the dimension font correctly). There are quite a few fonts that display incorrectly and I sent this plan to TS. If I remember correctly they said they were able to reproduce the problem.

 

  • Like 2
Link to comment
Share on other sites

Thank-you!@Renerabbitt

Nice work Rene! There is some level of matching that needs to happen between the dimension string and the marker. The elevation marker dimension font is being stretched or squashed by the native height of the font used for the dimension string. 

In my plans, I have been using a shorter font for dimensions. The simplest fix (for me) is to match my dimension font to the font used  for 'Text Below Line" in the marker default settings.

 

You found the cause of this problem really quickly. I'll send this info to TS.

Link to comment
Share on other sites

Reminder, per the reply from Chief, this is an issue with 'fonts that aren't default to Windows'.  So, if default to windows, there should be no issues.  If not default, then spacing issues 'may' occur.  I would 'assume' that each non-windows font would behave differently.

Link to comment
Share on other sites

14 hours ago, BenPalmer said:

issue with 'fonts that aren't default to Windows'.

Thanks Ben. I read that in your post and immediately checked to see if my fonts were windows fonts. Good tip / reminder!

  • Like 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

  • Member Statistics

    32047
    Total Members
    9156
    Most Online
    mamamakula
    Newest Member
    mamamakula
    Joined