x12 Toolbar Scrambles itself regularly--anyone else have this issue?


zowie123
 Share

Recommended Posts

Hi All,

I've reset all my options to stock: stock templates, stock toolbars, but the tool bar still scrambles a few times a week. Anyone else have this issue.  I'm thinking of reloading the program. I'm not sure if it occurs when toolbars are locked. I'll have to reset and lock it, sometimes I unlock it to add something.  But I've never locked it in the past and it hasn't bee an issue.

 

I've been using chief for about 15yrs, I do about 50 projects a year, never had this issue before.

 

Thank you,

Barry

 

 

Link to comment
Share on other sites

Yes I've had this issue for a few different versions of chief - it's not really fixed, but I have a work-around. When using my toolbar, I have my 'reset' toolbar, and always make a copy to have as my active toolbar. Then when it messes up, you have to go grab one of the tool 'docks' and drag it off the toolbar so it's floating - this seems to break the mess-up - then you can go and make a new copy of your reset toolbar for the active toolbar.

 

Hope that makes sense. 

 

some other things you can do - arrange your toolbars with less individual/small tools arranged, and make big long toolbars with lots of stuff in them - I think the issue is related to the organizing of the toolbars, so having less has seemed to make the problem happen less.

 

Another thing was there were some missing tools in my toolbars - I deleted these and recreated. It certainly happens less now (once a month perhaps) but still does it occasionally - I manage.

 

One last tip - make sure all your toolbars are turned on for all the different types of views - this actually helps in the time-lag between swithching from 3D - 2D - layout - cad etc - just make all of them the same toolbar.

 

Cheif's original toolbar layout is really bad. I put all my 'objects' on the left panel, my navigation (up/down floors, left/right pages in layout, layer/annoset drop downs) along the top of the page, then have all my camera/snaps/etc off to the right panel. I once sent chief an email about helping them redesign their layout, but obviuosly never heard back.

513770558_ScreenShot2020-04-24at1_11_46PM.thumb.png.ad2cde1f54d537076285a7c3505e9d71.png1177916876_ScreenShot2020-04-24at1_11_50PM.thumb.png.1f9f4668216b8337abc78432456a77d4.png1733421141_ScreenShot2020-04-24at1_11_54PM.thumb.png.c271afd0b27244a66275d3191f95c245.png

 

Link to comment
Share on other sites

Working from a copy:

2080507121_ScreenShot2020-04-24at1_12_47PM.thumb.png.42fb79ff392a0c260c7bba9716ac4dcc.png

 

But warning: if you try to work from a copy without FIRST grabbing one of the toolbars (doesn't matter which one) and dragging it to become floating, it will just mess up immediately again. Sucks but can't really do anything else from what Iv'e found

Link to comment
Share on other sites

3 minutes ago, kylejmarsh said:

Thanks Kyle! That's a well researched work-around.  I'll add that to my overflowing toolbox of Chief workarounds:( I use the most basic toolbar set with a few additions, I mainly use hotkeys.  I posted my hotkey file a while back, they're built on key letters from the tool names which makes them easier to use. I'll give your method a try.  I wonder why after all these years I'm having this issue?  Thank you for your informative reply. Cheers, B

 

Link to comment
Share on other sites

Probably. Yes I've emailed back and fourth with them about it back when X11 was coming out I did the beta test and it was present there - never got resolved but I've learned to deal with it. When I combined a bunch of toolbars into some bigger ones, reducing the number of toolbars, it seemed to help with how frequent it happens.

 

Having/knowing about backup toolbars is key otherwise you literally have to reconstruct your toolbar every time.

Link to comment
Share on other sites

While I haven't had it happen to me personally, one of my employees has it happen to him once or twice a week in X12...never had it before for anyone on any computer or software version prior to this happening with X12 (20 years+).  We have backups and can get it back pretty quick, but an annoyance for sure.  We haven't reported it because we can't reproduce it...we haven't been able to find an action that causes it...seems to be random...for us anyway.  We'll consider some of the tips listed above and see if that helps.

Link to comment
Share on other sites

We have been trying to reproduce this in house for a while, is there anything you can provide that will help us determine what the trigger is?  Are you floating certain toolbars and/or side windows? Are you using multiple monitors or only a single monitor? Are your multiple monitors the same resolution?  Is this on a laptop and you use a docking station? What was the last thing you did when you noticed your toolbars were scrambled?  Are you switching between views?  What OS, screen resolution, screen dpi setting, video card, and can we get a copy of your toolbars?

Link to comment
Share on other sites

I've reported the crap out of this issue with Chief.

 

The problem seems to be if you run Chief off of a laptop and use an external monitor in the office.

When you grab your laptop and go see a client or whatever, Chief has to redraw your big toolbar configuration and get it to fit on the laptop.

Then when you get back to the office and plug in your external monitor Chief has to again fit your toolbar back onto the larger screen.

 

This has been my experience at least.

There is no fix.

 

Even re-selecting your saved toolbar or renaming it, or deleting and re-importing it etc... doesn't work.

You just have to re-adjust your toolbar off of a saved screenshot and re-save it.

 

Nobody at Chief has had this issue apparently, or at least they haven't been able to reproduce the problem.

I am on a Macbook, however, and the universe appears slightly warped from this perspective.

 

 

 

 

 

Link to comment
Share on other sites

I've had it happen twice when way from my office using my MacBook with my iPad as the second monitor (Sidecar feature). I sent it in to tech. support and they weren't able to replicate it either. Haven't tried it again in quite a while to investigate further

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
 Share

  • Member Statistics

    30394
    Total Members
    9156
    Most Online
    Char91
    Newest Member
    Char91
    Joined