nVisionTEKBIM

Area Macro's #Evaluation Error#

Recommended Posts

Does anyone know how to resolve my issue of randomly getting my area macro's to show up as #Evaluation Error#? This has been extremely frustrating and I can't seem to find out "WHY" it does this. I want to avoid having to manually type the building area totals since that's nothing but a major spot for user error as the project gets tweaked.

 

The macros work fine, but just randomly not work.

 

image.thumb.png.5ba7e42642c4bcaf9decd076e87c9af2.png

Share this post


Link to post
Share on other sites
6 hours ago, nVisionTEKBIM said:

Does anyone know how to resolve my issue of randomly getting my area macro's to show up as #Evaluation Error#? This has been extremely frustrating and I can't seem to find out "WHY" it does this. I want to avoid having to manually type the building area totals since that's nothing but a major spot for user error as the project gets tweaked.

 

The macros work fine, but just randomly not work.

 

image.thumb.png.5ba7e42642c4bcaf9decd076e87c9af2.png

 

Who’s method are you using?

Share this post


Link to post
Share on other sites

If they're label based, ensure the labels are turned on in that view. If they're referenced by an arrow, you're SOL. The arrows love to find new objects to 'touch'. One thing I found to be helpful for referencing arrows is to have them all on their own layer, and sent to the back. If I'm using them to reference polylines, I create a separate saved plan view showing those items and the text and arrows only. Then, that saved plan view can be displayed with another saved plan view, or sent to layout separately. That will add stability to reference arrows.

Another option for arrows that reference polylines is to move the polyline away to an area where nothing else exists. For example, if I've created a polyline to represent the area of an attached garage, once the plan is finalized, I'd drag it or replicate it to a blank area left or right of the final displayed portion of a plan view, just to make sure the arrow doesn't 'find' something else.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

  • Member Statistics

    28631
    Total Members
    9156
    Most Online
    sawallace64
    Newest Member
    sawallace64
    Joined